Skip to main content

Changing the Template of an Existing Part or Assembly

Problem

In this article, we will discuss how to replace an existing Part or Assembly document template in SOLIDWORKS. A document's template is selected when you first make a SOLIDWORKS document. Changing the template can be helpful to apply units, assign custom properties, change image quality, or even troubleshoot problems related to the document template.

For drawings, the sheet format (not the drawing template) can be changed using the steps in the article below:

How to Change Drawing Sheet Format

Solution 1: Changing the Template of a Part

  1. Go to File > New (CTRL+N) and open a new part with the desired template. This should be the template you want to apply to the existing part.
  2. Go to Insert > Part
  3. Activate the ‘Break link to the original part’ option.

    Visual representation of breaking the link in the Property Manager
  4. Browse to the part to update. SOLIDWORKS inserts the part and creates a folder that contains all of the features of that part that was inserted. If preferred, delete the folder to make all features appear without being contained in a folder.

    Part with replaced template
  5. Save the part with the same name and overwrite the existing part.

Solution 2: Changing the Template of an Assembly

  1. Go to File > New (CTRL+N) and open a new assembly with the desired template.
  2. Go to 'Insert Component', and locate the existing assembly.
  3. Insert the assembly at the origin. By holding the cursor over the PropertyManager (Insert Component flyout window on the left), this will align the origin of the new assembly with the old assembly.
  4. Right-click the subassembly and select "Dissolve Subassembly". 

    Dissolve subassembly location
  5. When completing this, the assembly will lose the assembly-level feature data, explode steps, and configurations. These will have to be added in manually once finished. The removed data can be viewed in the "Assembly Structure Editing" window. Click "Move" to continue.
Assembly Structure Editing Window
  1. Save the assembly with the same name and overwrite the existing one.

For additional support, existing customers can submit a ticket or new customers can contact Hawk Ridge Systems.

Was this article helpful?
0 out of 0 found this helpful

Articles in this section

Comments

0 comments

Article is closed for comments.