Problem
SOLIDWORKS Rx is an important tool for troubleshooting many problems. With 3DEXPERIENCE SOLIDWORKS Design, it cannot be launched in the same way we normally use it with desktop SOLIDWORKS. This article will explain how to launch SOLIDWORKS Rx with 3DEXPERIENCE SOLIDWORKS Design and how to apply its safe modes.
SOLIDWORKS Rx can be used for a few different purposes:
- Checking system diagnostics to ensure SOLIDWORKS is set up to run well
- Capturing problems with video and logs to provide to Technical Support for in-depth troubleshooting
- Launching SOLIDWORKS in safe modes to isolate the source of an issue
This article will apply to users using 3DEXPERIENCE SOLIDWORKS Design, also known as SOLIDWORKS Design (or formerly SOLIDWORKS Connected). For users using desktop SOLIDWORKS, including the Collaborative Designer for SOLIDWORKS add-in, please refer to these articles:
Rx Problem Capture Tool – Hawk Ridge Systems
Starting SOLIDWORKS in Rx Safe Modes – Hawk Ridge Systems
Solution 1: Launching SOLIDWORKS Rx with 3DEXPERIENCE SOLIDWORKS Design
Although the 3DEXPERIENCE SOLIDWORKS Design installation does not create a Start Menu shortcut for SOLIDWORKS Rx, the application is installed. There are three ways to run the application:
-
Select the "SOLIDWORKS Rx" command in the Help menu within SOLIDWORKS
-
Right-click on the SOLIDWORKS Resource Monitor icon in the System Tray and select "Run System Diagnostics"
-
Run the sldrx.exe application in: C:\Program Files\Common Files\SOLIDWORKS Shared\2026\sldrx
SOLIDWORKS Rx can be used to capture a problem that is difficult to explain or reproduce. Please see our Rx Problem Capture Tool guide to learn how to create an Rx capture, and enable the "Include 3DEXPERIENCE debug logs" when using 3DEXPERIENCE SOLIDWORKS Design.
Solution 2: Using Safe Modes in 3DEXPERIENCE SOLIDWORKS Design (2026 and newer)
The 3DEXPERIENCE SOLIDWORKS Design Rx tool includes the ability to launch SOLIDWORKS in two safe modes to narrow down the source of an issue. The "Software OpenGL" safe mode can pinpoint an issue with the graphics card or its driver, and the "Bypass the Tools/Options Settings" safe mode can pinpoint an issue with the SOLIDWORKS settings or registry.
We can enable one or both of the safe modes to help troubleshoot settings or graphics-related issues by selecting the checkboxes and then clicking "Launch SOLIDWORKS".
Solution 3: Using Safe Modes in 3DEXPERIENCE SOLIDWORKS Design (2025 and older)
The 3DEXPERIENCE SOLIDWORKS Design Rx tool for versions 2025 and older did not have the safe mode launch options. As a result, we can manually enable the following workflows to troubleshoot:
Using Software OpenGL in 3DEXPERIENCE SOLIDWORKS Design:
- Open SOLIDWORKS
- Make sure no SOLIDWORKS files are open.
-
Go to the Performance section of the System Options and disable the "Enhanced graphics performance" option
- Hit "OK" to confirm the change and restart SOLIDWORKS for the change to take effect
-
Go to the Performance section of the System Options and enable the "Use software OpenGL" option
- Attempt to recreate the issue
If the issue cannot be replicated after following those steps, the issue is likely caused by the graphics card or driver. To stop using this safe mode and restore the settings, follow the steps below:
- Open SOLIDWORKS
- Make sure no SOLIDWORKS files are open
- Go to the Performance section of the System Options and disable the "Use software OpenGL" option
- (Optional) In the Performance section of the System Options, enable the "Enhanced graphics performance" option
- Click "OK" to accept the changes and then restart SOLIDWORKS
Using Bypass the Tools/Options Settings in 3DEXPERIENCE SOLIDWORKS Design:
- Open SOLIDWORKS
- Make sure no SOLIDWORKS files are open.
-
Go to Tools > Save/Restore Settings
-
Select "Save Settings", click "Next", ensure all settings are selected, a location is specified to save the settings file, and click "Finish" to create a backup of the existing settings
- Go to Tools > Save/Restore Settings
- With the Settings Window open, close SOLIDWORKS
-
Select "Reset Settings", select "Reset Only", click "Next" to reset the SOLIDWORKS settings, and click "Finish" to close the Settings Wizard
- Attempt to recreate the issue
If the issue cannot be replicated after following those steps, the issue is likely caused by the settings or registry. To stop using this safe mode and restore the settings, follow the steps below:
- Open SOLIDWORKS
- Make sure no SOLIDWORKS files are open.
- Go to Tools > Save/Restore Settings
-
Select "Restore Settings", select "Browse" to choose the settings file, ensure all settings are selected, click "Next", and click "Finish" to restore the settings
For additional support, existing customers can submit a ticket or new customers can contact Hawk Ridge Systems.
Comments
Article is closed for comments.