This article discusses the differences between Sheet Formats and Drawing Templates, both of which are used in the SOLIDWORKS drawing environment. When using Custom Drawing Templates or Sheet Formats, we recommend creating backups of them.
Drawing Template
In short, a Drawing Template (.drwdot) stores document settings that can be used again and can include Sheet Formats. Here are some examples of these settings:
- Drawing Document Properties: Drafting Standards, Units, Font style, and sizes, etc.
- Custom Properties
- Tree Display
- Predefined Views
File Properties and Custom Properties are accessed through the Standard Toolbar > File Properties or File > Properties. Document Properties are accessed through the Standard Toolbar > Options > Document Properties or Tools > Options > Document Properties.
To create a new Drawing Template, start by making a new Drawing file and modify its settings as desired to customize it for reuse. For more information on creating Drawing Templates, check out these Videos from our YouTube Channel:
Drawing Templates from Scratch in SOLIDWORKS: Part I - YouTube
Drawing Templates from Scratch in SOLIDWORKS: Part II - YouTube
When modifying a drawing, we can also set up the desired sheet formats to use in multiple sheets. Simply add as many sheets as desired for the template and then edit each sheet to change the sheet format used. In the example below, there are three sheets, so when a drawing template is created from the drawing, the template will start with three sheets.
Once a drawing has been modified as desired, the next step is to create the Drawing Template file. Go to File > Save As, select Drawing Templates (.drwdot) from the "Save As type" drop-down menu, give the template a name, and save the file.
The default template location is specified in Tools > Options > System Options > File Locations > Document Templates and can be modified to add more file locations as desired. We recommend storing custom Templates in a separate location to avoid SOLIDWORKS upgrade issues and creating backups of them.
Now, when starting a new SOLIDWORKS file, the new template will show up in the Template Selection.
Sheet Format
In contrast, a Sheet Format (.slddrt) specifies the paper size and, mainly, defines the title block for the drawing. Here are things that can be saved in a sheet format:
- Title block and the information contained in it
- Drawing Border and Block Geometry
- Notes
- Images like a company logo
- Anchor Points for Tables
By default, when opening a new or existing drawing file, there is a Sheet Format specified by the Drawing Template, or there will be a Prompt to select one. Right-click anywhere in the graphics area within a drawing and select "Edit Sheet Format" to modify the sheet format. Note: Some users may need to expand the right-click menu using the double arrow at the bottom in order to see this option.
Once a user is in the sheet format, a user can change the title block lines, insert/change any text in the background, or add pictures like a company logo. Looking at the top right-hand corner of the graphics area, there will be a sheet format icon indicating the sheet format is being edited.
To exit editing the sheet when done editing, right-click the sheet to select "Edit Sheet", or click the Sheet Format icon in the top right-hand corner. Currently, the changes made to the sheet format are contained in the current drawing only.
The Sheet Format can be saved for use with future drawings. Sheet Formats can’t be saved by clicking File > Save As like Drawing Templates; instead, click on File > Save Sheet Format.
The default file location for Sheet Formats is:
C:\ProgramData\SolidWorks\SolidWorks <year>\lang\english\sheetformat.
Additional Sheet Format file locations can be added in Tools > Options > System Options > File Locations > Sheet Format.
Note: If the ProgramData folder isn’t shown, go into the Windows File Explorer Options and turn on "Show hidden files, folders, and drives".
When starting a new Drawing from a Drawing Template, there is the opportunity to select the Sheet Format to use if the Template is set up to Prompt for it.
The Sheet Format can also be changed in an existing drawing by right-clicking in the drawing and selecting "Properties" or by right-clicking the sheet in the Drawing Tree to select "Properties".
This is what the Sheet Properties window looks like when editing an existing drawing. Select a new sheet to use and click "Apply Changes" to apply the new sheet to the drawing.
If the sheet format is saved in the drawing template, newly created drawings will automatically have the sheet format in them. It is a good practice to save the sheet format separately, so that it can easily be brought into different drawings or edited.
For additional support, existing customers can submit a ticket or new customers can contact Hawk Ridge Systems.
Comments
Article is closed for comments.