Save a Multi-Body Part as an Assembly

Problem

This article goes over how to use the Save Bodies feature in a multi-body part file to save each body to a separate Part file and create an Assembly.

Solution

  1. Open up a part file with multiple bodies in it. Note: The example below has four bodies.

    Part file with four bodies
  2. Go to Insert > Features > Save Bodies

    Go to Insert>Features>Save Bodies
  3. This will bring up the Save Bodies Property Manager showing all the available bodies and some options for the feature

    Image of the Save Bodies Property Manager
  4. Check the box near each body in the list to enable it and have the name auto-assigned. The "Auto-assign Titles" button can also be used to have this done for all listed bodies. 
  5. To use a custom name, double-click the body in the list under Title or the flag in the graphics area.
    Name the solid bodies
  6. Under Template Settings, use the default templates set in Tool > Options > System Options > Default Templates, or override this by selecting the 3 dots next to each template file path

    Image of the Template Settings options
  7. Select "Consume cut bodies", which removes the body from being listed in the FeatureManager design tree under Solid Bodies
  8. Select "Propagate visual properties" to transfer the visual properties
  9. Use the "Origin location" selection box to change the origin
                                                             Image of options for Consume cut bodies, visual properties, and origin
  10. To create an assembly, select "Browse" under the "Create Assembly" section to choose a name and location for the assembly

    Click browse to set the assembly file location
  11. Accept the feature by clicking the green check mark, and a new feature at the bottom of the tree for this command will appear
    Save Bodies feature in feature tree
  12. If any new bodies are added or changes are made, they will need to be added before this Save Bodies feature in order to show up when editing the Save Bodies feature

The separate Part files can now be opened, which will have a feature referencing the Save Bodies feature, and the Assembly file can be opened as well.

Image of a save bodies part file

In the assembly, all parts will be fixed and have an external reference back to the original part file.

Image of a save bodies assembly file

For additional support, existing customers can submit a ticket or new customers can contact Hawk Ridge Systems.

Was this article helpful?
1 out of 1 found this helpful

Articles in this section

Comments

0 comments

Article is closed for comments.