Comprehensive Toolbox Guide

 

This guide is written for the Toolbox add-in of SOLIDWORKS. Some of the options and features may vary slightly depending on your version of SOLIDWORKS.

This information is subject to change without notification. If you have any questions or find that there are discrepancies between this document and the SOLIDWORKS website or documentation, please contact Hawk Ridge Systems technical support.

If you are experiencing serious issues with your SOLIDWORKS software, you may need to fully uninstall the program and all associated programs and files before attempting to reload the software. This document covers how to do this complete removal of the product.

This is not a troubleshooting guide. If you have any technical issues with SOLIDWORKS
please contact Hawk Ridge Systems technical support.

 

Contents

Installation

Starting the Toolbox

Shared Toolbox

    Accessing a Shared Toolbox Library

Using the Toolbox

    Adding a Toolbox Fastener to an Assembly

    Adding Parts to the Toolbox Library

    Creating New Parts from the Toolbox Components

Configuring the Toolbox

    Reorganizing Toolbox Folders

    Disabling Folders

    Copying Standards for Geometry Modification

Hole Wizard

Customizing Your Hardware

Standard Properties for Toolbox Standards, Categories, and Types

Standard Properties for Components

Custom Properties

    Adding Custom Properties

User Settings

Permissions

Configure Smart Fasteners

Applications

    Circular Cams - Setup

    Circular Cams - Motion

    Circular Cams - Creation

    Linear Cams - Setup

    Linear Cams - Motion

    Linear Cams - Creation

Favorites

Grooves

O-Ring Grooves

Retaining Ring Grooves

Beam Calculator

Bearing Calculator

Structural Steel

Concurrent Installations

Notes

 

Installation

1. Select the Toolbox and Libraries for Installation

The Toolbox will be installed onto your computer using the SOLIDWORKS Installation Manager. It can be added during the initial installation or added in at a later date, provided you have a SOLIDWORKS Professional or higher License. On the Product Selection page of the Installation Manager, check the box for the Toolbox, as well as any of the hardware standards you’d like to include in the Toolbox library.

 

Solidworks product selection page showing the Toolbox item

 

2. Select the Installation Location

In the summary section of the Installation Manager make sure that the installation location is appropriate for your application. By default, the toolbox library will be installed in the SOLIDWORKS Data folder. If multiple users will be using the Toolbox, please refer to the Shared Toolbox Portion of the document. If the Toolbox has already been installed, you will be unable to change the location through the Installation Manager.

 

The summary page of the installation manager showing the Toolbox options

 

If you are upgrading SOLIDWORKS, be aware using the existing common data location will update the library to the latest version and you will no longer be able to use older versions of the software with this library. Refer to the Concurrent Installations section of the document for additional information.

If you are using a shared location, you need only update the shared location once. You can have the other users install to the default location and then repoint their toolbox location in the System Options of SOLIDWORKS to the shared library. This is explained in detail under the Multi-User section of this document.

 

Starting the Toolbox

After installation, the Toolbox Add-Ins must be turned on to access the toolbox resources in SOLIDWORKS. Installing the Toolbox gives you two additional Add-ins to turn on.

  • SOLIDWORKS Toolbox Utilities loads Beam Calculator, Bearing Calculator, and the tools for creating cams, grooves, and structural steel.
  • SOLIDWORKS Toolbox Library loads the Toolbox configuration tool and the Toolbox Design Library task pane, where you can access Toolbox components.

For more information on the use of the different tools within the Toolbox Add-Ins, see the Applications section of this document.

From the add-ins menu you may choose whether the Toolbox is turned on every time SOLIDWORKS is active or just for the current session. This can be accessed by going to the “Options” and picking the “Add-Ins” choice from the menu. Enable both the SOLIDWORKS Toolbox Library and SOLIDWORKS Toolbox Utilities. The Active Add-ins column controls the Add-ins running in the current session of SOLIDWORKS and the Start Up column controls whether the Add-in is active when SOLIDWORKS is first started up. Select “OK” to save the changes.

Showing the add-in dropdown menu and the Toolbox Library option

 

The Toolbox browser can also be enabled on a per session basis from the Task Pane by selecting the “Design Library Tab” and enabling the Toolbox by clicking “Add in Now”. This is effectively the same as activating the SOLIDWORKS Toolbox Browser from the Add-Ins menu mentioned earlier.

 

Showing the Toolbox Add in now option in the task pane

 

Shared Toolbox

Toolbox can be shared in a multi-user environment by placing a copy to a shared network location. This is ideal when multiple users are collaborating on the same assemblies because it forces the Toolbox to reference a single location rather than having multiple standalone references on each computer. Use the steps below to create a multi-user environment from existing standalone installations. Please refer to the Enterprise PDM Installation guide for steps on sharing a Toolbox in an EPDM environment.

 

1. Identify the Most Complete Library

Identify the computer that has used SOLIDWORKS Toolbox most extensively; this person will have the most part configurations already created and this will take the least amount of work to get the entire company library added to it. If you have all new installations any user will do.

 

2. Copy Folder to New Location

Move the entire SOLIDWORKS Toolbox parts directory (for example, C:\SOLIDWORKS Data) from the user's computer to a shared location. It is recommended that the shared location be on a computer that does not run the SOLIDWORKS software. This location is typically on a server.

 

Showing the Solidworks data folder
 

 

3. Write Protect the Folders

To ensure that no Toolbox components are modified outside of the Toolbox, it is a good Idea to make the folders read only. Later we will enable editing through appropriate methods on a per part basis. Right click on the "browser” folder within the copied SOLIDWORKS Data folder and go to “Properties

 

showing the right click menu when selecting on the browser folder

Showing the read-only option in the properties menu

 

 

4. Repeat Step 3 for the Copied Parts folder.

 

5. Enable or disable Toolbox Editing through SOLIDWORKS

The write access for the Toolbox will need to be adjusted for SOLIDWORKS. This can be done by going to Options>System Options>Hole Wizard/Toolbox then press the “Configure” button.

This will open the Toolbox and the Toolbox Setup Menu will appear. Select “Define User Settings”. Within the User Settings menu select the radio button “Always change read-only status of document before writing” if you would like users to be able to add new configurations of hardware to the Toolbox. This can be prevented by selecting the radio button “Error when writing to a read-only document”. This option is selected when you manage Toolbox component files from a PDM system.

 

Showing the Toolbox Setup menu

 

6. Select method for adding new Toolbox sizes for fasteners.

If you would like Users to be able to create new sizes for Toolbox components, you must choose a method for storing the data in the Files section of the User Settings.

Create Configuration- Size information is stored as a configuration in the master part file. Whenever a fastener is dragged and dropped into an assembly. Behind the scenes, SOLIDWORKS opens up the Master Toolbox part file for the fastener. The user selects size and any other custom properties. SOLIDWORKS checks the Master Part to see if the specified size already exists as a saved configuration. If it exists, the saved configurations will be used. This method is recommended for greater control over the management of the Toolbox database.

Create Part- Any new fasteners are saved as part files separate from the master part file for each new size specified. When assembly documents with Toolbox Fasteners are opened, SOLIDWORKS will look in the specified folder for the Toolbox Fastener first. If the fastener or folder is missing SOLIDWORKS will look for the Master Model in the Toolbox library to generate the part. This option is recommended if you expect to be sharing files containing Toolbox fasteners because assemblies that have been sent using Pack and Go will contain references to actual part files rather than the Toolbox Master Part which may not be present for users who do not have the Toolbox Add-In.

 

The user settings menu with Create Configurations and Always change read-only options selected

 

 

7. Set Permissions for all users

Go to the 4th page in the Toolbox configurator to set permissions for all users. Once your password has been set, you can lock down permissions and force all users to use the same settings. This needs to be done to avoid complications with a mixed environment and allows your administrator to control who can modify the Toolbox.

 

  • Allow editing of Content- When cleared, the data on the Content tab is view-only.
  • Allow editing of Properties- When cleared, the options on the Properties tab are view-only.
  • Allow adding of parts to Toolbox- When cleared, you cannot add parts to the library of Toolbox components.
  • Allow editing of Favorites- When cleared, you cannot add or change Favorites in the Toolbox property manager.
  • Allow editing of Configuration Name/File Name- When cleared, you cannot add or change configuration or file name in the Toolbox property manager.

 

The permissions menu

Settings:

Specify how settings are applied in a multi-user environment.

  • Set separately for each user- Options on the Settings tab are set separately for each user.
    • Allow user to change-Users are allowed to make changes to their own User Settings.
  • Set the same for all users- Options on the Settings tab are set globally for all users.

 

Smart Fasteners:

Specify how Smart Fasteners settings are applied in a multi-user environment.

  • Set separately for each user- Options on the Smart Fasteners tab are set separately for each user.
    • Allow user to change- Users are allowed to make changes to their own settings.
  • Set the same for all users- Options on the Smart Fasteners tab are set globally for all users.

 

Accessing a Shared Toolbox Library

You can add an existing SOLIDWORKS Toolbox user to an existing shared environment. Users who migrate to the shared environment might have assembly documents that reference local versions of the SOLIDWORKS Toolbox parts. Potential issues include:

  • A user might have assigned part numbers and descriptions to local SOLIDWORKS Toolbox parts that are different from the shared parts.
  • A user's local SOLIDWORKS Toolbox parts might contain part configurations that do not exist in the shared environment.

 

To add an existing user to a shared environment:

  1. Make sure the existing seats in the shared environment and the seat that is migrating to the shared environment have the same SOLIDWORKS and SOLIDWORKS Toolbox versions.
  2. In SOLIDWORKS go to Tools, Options, System Options, Hole Wizard/Toolbox press the Browse button to the right of the line calling out the Hole Wizard and Toolbox folder location and set the path to the shared toolbox “SOLIDWORKS Data” directory.


                                     The search button for setting the hole wizard/toolbox location

  3. Press the Configure button on this page and make sure the Define User Settings tab is set to create configurations and always change read only status of part before writing as described on the previous page. This option should be greyed out if the password has been set and the permissions were set to All Users in the previous section.

Updating the references

If users have been previously creating hardware with a local library and are now switching to a shared toolbox environment you will need to take a couple of steps to ensure that existing assemblies change to referencing the shared location for all hardware.

If you are working in SOLIDWORKS 2011 or later you can specify the shared Toolbox location as the default reference location for any Toolbox components found in an assembly.

  1. In SOLIDWORKS Click Options (Standard toolbar).
  2. Click Hole Wizard/Toolbox.
  3. Select Make this folder the default search location for Toolbox components and specify the shared toolbox folder.

 

The option checked for Make this folder the default search location for Toolbox components

 

 

Otherwise:

  1. Delete the user’s local C:/SOLIDWORKS Data folder.
  2. In SOLIDWORKS go to Tools, Options, System Options, External References check on the box in front of the option Search file locations for external references

                                     Load documents in memory only option shown

  3. Then go to Tools, Options, System Options, File Locations then show the folders for Referenced Documents press the Add button and browse to the shared toolbox location.

Showing the add option for Referenced Documents

 

Now SOLIDWORKS will automatically use the shared location for the location of all Toolbox parts and will automatically generate the correct configuration sizes if none exist. When this happens you will get a warning that Toolbox will generate new versions of the hardware. This new version will not have any previously added part names or properties that were generated at the local level.

 

Using the Toolbox

The below sections wil show how to use the toolbox to add them to an assembly, add parts to the toolbox, and creating new parts in the toolbxo.

Adding a Toolbox Fastener to an Assembly

  1. Browse for the Type and Style: To add a part to an assembly, Activate the Toolbox, located on the Task Pane toolbar on the far right of the graphics area, then pick the standard and type of hardware. Now in the lower pane of the task manager browse for the specific style and version of the hardware you would like to use in your assembly.

                                           Image of the Toolbox folder structure in the toolbox configurator

  2. Drag and drop onto reference geometry: Add the Toolbox Fastener by dragging and dropping it into the assembly. Many of the components in the Toolbox, including Bearings, Bolts and Screws and retaining rings, contain mate references to automatically add concentric and coincident mates with any circular edge. The size of the fastener will be driven by the size and type of the Hole Wizard Hole the Toolbox component is being applied to or the size of the geometry the components is dragged over for other components.

                  Showing the drag and drop capability

  3. Configure Other Properties: After the Toolbox Component has been dropped into the assembly the Configure Component Property Manager will appear. From the Property Manager use the drop-down menus to select any specifics you would like for the hardware.

                                                 Image of the Configuration Component Property Menu

  4. Save the Configuration: Part Numbers and Descriptions can be added to the component by clicking Add. This can be leveraged later on in documents such as the Bill of Materials and can be reviewed in the Toolbox Settings.

    The Part Number and Description will appear in the Part Number field of the Configure Component PropertyManager any time that type of fastener is used allowing you quickly recall the configurations of your hardware for future application. You do not need to add a Part Number or description to use a Toolbox Component. The information dictating the size and other properties of the fastener will be saved based on the method specified in the User Settings.

  5. Insert Additional Instances: Once you have configured the Toolbox component, clicking on the green check box will exit the property manager and allow you to insert any additional instances of the configured component without the need to drag and drop from the Task Pane or re-enter sizing information.

  6. Alternative Method: Right clicking on the hardware in the browser and picking “Insert into Assembly” will also insert the Toolbox Component into your assembly. Adding a part this way will place the part “floating” at the origin, you will need to mate the component in to place yourself and specify the size from the PropertyManager.

    You can delete a Part Number and Description by activating it then clicking delete.

                                                        Showing the delete button for part numbers

    Selecting Edit will allow you to change the Part Number and Description for a Component configuration.

    You can get back into the configure Component Property manager by right clicking on the any part added using the Toolbox by right clicking on it and selecting Edit Toolbox Component.

 

Adding Parts to the Toolbox Library

Use Add to Library to add parts to the SOLIDWORKS Toolbox library. You can add parts to existing SOLIDWORKS Toolbox groups, or you can create your own groups. Administrators can control who is allowed to add parts to a shared library through the tool box settings.

To add a part to the Toolbox library navigate to the Toolbox Settings from the Start menu. The Toolbox will be located in the SOLIDWORKS Tools folder.

 

Showing the Toolbox Location in the Start menu

Once the toolbox is open select Customize your hardware from the Home menu.

 

Showing the Toolbox Setup menu

By Right clicking on any of the folders displayed in the tree on the left you can add additional folders or Parts to the existing structure.

 

Image showing the right click menu of the folder in the Toolbox configure tool

 

Creating New Parts from Toolbox Components

As an alternative to setting up configurations of the Standard Toolbox components when inserting them into an Assembly you can right click on the component from the Design Library in the Task Pane and select Create Part...

 

The Create part option in the Task Pane

 

This will open the Toolbox Component as well as the Configure Component PropertyManager, from there you can specify the size information and display properties. If you would like to have the configuration of the Toolbox component available in the Property Manager for rapid selection select Add in the Part Number dialogue box and give your Toolbox fastener a Part Number and Description.

Selecting the green check will close the toolbox Component. Note: This doesn't create a new part. This "Part Number" identifies the configuration from the properties selected and adds the Part Number and Description to that configuration. You can check this by right clicking on the toolbox part and selecting Configuration.... and browse to the configuration in the Toolbox Settings > Customize Hardware .See the User Settings of this document for more information on how fasteners are being saved.

 

Image of the Configure Component menu with the add button

 

If you are using a part that has been manually added to the Toolbox any valid configurations of that Part will appear in the Properties area in the PropertyManager as a drop down.

 

Configuring the Toolbox

If you are a single user or administering a shared library you will want to create settings for how the library will function. This includes selecting the components that will be available as well as the Toolbox components associated with certain Hole Wizard holes. Once set up this can dramatically decrease the often tedious task of adding fasteners to an assembly. An administrator can restrict modifications to the standards data. Other users can view, but not modify, the restricted data without the administrative password. (See Permissions Section)

  1. Select the Options from the Standard Toolbar.

Image of the Options menu in the standard toolbar

  1. Navigate to the Hole Wizard/Toolbox section in the System Options and select Configure

Image of the Configure Button in the system options

  1. Select Customize Hardware from the Toolbox window that opens.

 

Toolbox Setup Welcome menu

 

Reorganizing Toolbox Folders

You can customize Toolbox content from the Customize Hardware page of Toolbox Settings by copying, pasting, deleting, and renaming Toolbox folders.

 

Disabling Folders

You can disable folders within the toolbox so that they do not appear in the task pane for use. This is done by checking or un-checking the standards and styles as shown below.

 

Image of the Folders and how to enable or disable them

Showing both folders or items enabled and disabled

 

Copying Standards for Geometry Modification

If you would like to modify the geometry of a certain standard, beyond what is available as a Toolbox configuration, you will need to first create a copy of the standard you wish to modify. To do this Right click on the folder or component you want to copy and select copy. Create a new Folder and rename it with your desired Standard name.

Once you’ve copied any files to the new Toolbox location click the save icon in the top left of the window to update the Toolbox database.

 

Showing the My Toolbox folder

 

To make modifications Follow the steps in the Creating New Parts From Toolbox Components portion of the guide except when you confirm the new part number the part will not close and you will be able to make modifications to the features and existing geometry. Be aware that this can eliminate some of the configuration categories available for that piece of hardware.

 

Hole Wizard

Not only does the Toolbox contain hardware components, but it also controls all the Standards, Types, and Holes available in the Hole Wizard. The sizes, thread data, and default associated hardware can be modified from the Hole Wizard area in the Toolbox.

 

Showing the top of the hole wizard menu and location 1

 

Hole Wizard holes are organized into Standards, Types, and Holes.

 

shows the tree structure of the hole wizard folders

 

Just like Toolbox Components, you can disable the use of Standards, Types, and Holes by unchecking the box next to the name.

Shows enabled and disabled toolbox items

 

Once a specific hole is selected you can review the default Smart Fastener assigned. Clicking reassign will allow you to choose a different Toolbox component to be applied to the associated hole.

 

Image showing the reassign button for smart fastner option

 

Hole Wizard Holes have standard properties representing their available Sizes, Thread Data and Screw Clearances.

  • Thread Data can be used when adding annotations or Hole Callouts to a hole.
  • Screw Clearances effect the final diameter of the hole being created. A looser fit creates a larger hole.

Shows an example of the different size options for screw clearance

Shows an example of the different size options for screw clearance

 

Customizing Your Hardware

Within the Toolbox there are four levels to each folder. Properties can be assigned in this section we will look at the different properties we can assign for each level. The levels are as follows:

 

Showing folder structure of the Toolbox section

 

Standard Properties for Toolbox Standards, Categories, and Types

At each of the levels we can apply Standard Properties and Custom Properties. For the Standard, Category and Type folder level there are only two Standard Properties you can configure, General and Color.

 

Showing the Standard Propeties options

 

Selecting the ‘General’ Standard Property will allow you to change the name that is displayed in the Task Pane when accessing the Toolbox from SOLIDWORKS.

The color Property will allow you to change the default color of all components inserted from that directory. This can be particularly useful when trying to visually organize large assemblies.

 

Showing the color pallete selector

 

Standard Properties for Components

Once we drill down to the component level there are several more properties that can be configured. These are the properties that should be used to dictate the hardware that is available for toolbox users. You’ll notice that as the properties are disabled the number of possible configurations decreases. The available may vary depending on the component being configured. For example “Finish” is a property not present for all bolts. For more complex components in the toolbox such as gears the Standard Properties will be completely different however the theme of the Standard properties are properties that effect geometry such as size and shape.

 

Shows the standard properties options

 

  • General - This property changes the name that will be displayed in the task pane for the component, the file name used and whether that Component is available in the Toolbox.
  • Size - The size property will display the driving dimensions for a component except for length and thread length. You can disable certain sizes of the hardware and key in custom values for the names and sizes of those configurations. If you would like to add new size configurations click on the plus icon in the top left corner of the properties area.

Shows where the plus icon is to add new size configurations

 

  • Length - The length property allows you to specify the available lengths of a component based on its size.
  • Display - Display will determine how threads are displayed in the toolbox component. Simplified removes any thread display, cosmetic only shows a graphical representation of the threads. Schematic creates the thread geometry in the model. For better performance in large assemblies, less thread detail is highly recommended. If you are using the Schematic thread display the size of the threads can be controlled from the Thread Data property.

Shows the different thread options and how they will display

 

Custom Properties

Properties can be applied to components within the database, these can be referenced later like properties in any model to be called out in title blocks, bills of materials, or linked to notes.

These properties can be applied at any level within the database, as a configuration specific property or each value for a property can require a new configuration name (i.e. you can have 2 versions of a geometrically identical bolt but they are made of different material or bought from different vendors).

 

Adding Custom Properties

To add a new custom property select a standard, category, type, or component and press the Add New Custom Property button. This will bring up a dialogue box to set up the custom property.

Shows the button for adding a new custom property

Image of the custom property definition menu

 

  • Property Name - This will be the name of the property applied to the selection
  • Type - There are two types to pick from:
    • Textbox- The property is a text string. You will need to assign a default value that can be changed when configurations are generated.
    • List- This allows a list of values to be populated, these can be set in the PropertyManager when the component is added to an assembly. If you are using a list you can define the material of the part from the value entered into the custom property
  • Options -These determine where the Property will be stored and if it will generate new configurations
    • Add as configuration specific property- this means that the property will only be stored in the configuration on the toolbox component. If the size of the component ever changes the property will no longer be applied.
    • Each Value Requires a New Configuration Name – When this option is selected the property will generate a new configurations of the component even if one of the same size and length exists. If you are using a list to generate the Property the value entered in as the suffix will appear at the end of the configuration name. If the property is only a textbox the entire text string will appear at the end of the configuration name.
    • Show in PropertyManager- The property can be modified when the configuration is generated in the PropertyManager.

      In the example shown below a Custom Property has been added to allow the user to select Material for the Toolbox component. Not only will the Property be added, the material will be available as a drop down when the Toolbox component is inserted into an assembly.

 

Image of an example Toolbox item added with certain properties

 

  • Applying Properties - Once a custom Property is defined remember to enable them for the components. They will appear for all levels and Standards. Select a Standard, Category, Type, or Component and choose to apply them as needed. You can also use the icons to the right of the values to edit or delete properties. Below is an example of properties that were set up at the Type level. Material has been disabled as a property for some of the Components in the Type.

Image of how to enable different properties of a component

 

User Settings

You can set the user settings by going into the define user settings section.

 

Image of welcome to toolbox setup pointing to define user settings

Image of the user settings menu

 

Files: Specify what happens when you drag a part from the Toolbox Browser into an assembly.

  • Create Configurations - A configuration is added to a master part file each time you use a new size of a particular fastener.
  • Create Parts - An individual part file is created each time you use a new size of a particular fastener.
  • Create Parts on Ctrl-Drag - An individual part file is created if you Ctrl-drag the fastener from the Toolbox Browser. A configuration is added to the master part file if you use a standard drag.
  • Create Parts in this folder - Specify the folder for parts created when you select Create Parts or Create Parts on Ctrl-Drag.

Writing to read-only documents: Specify how SOLIDWORKS Toolbox interacts with read-only documents.

  • Always change read-only status of document before writing - SOLIDWORKS Toolbox temporarily overwrites the read-only attribute of a file to make a change. An example of a change is the creation of a new configuration for a different size fastener. After a change is done, SOLIDWORKS Toolbox resets the file attribute to read-only. This option allows multiple users to make changes to the same document because write access occurs briefly during the change. Documents that are read-only because of user rights or security settings in your operating system are not affected.
  • Error when writing to a read-only document - SOLIDWORKS Toolbox cannot change read-only documents; an error message appears.

Part Numbers: Part Numbers are used to save favorite configurations of hardware in your toolbox. You can create more than one configuration of a part in the SOLIDWORKS Toolbox database with the same Part Number if the parts are geometrically equal. For example, you might want to change the value of a custom property but retain the same part number in the SOLIDWORKS Toolbox database because geometry is unchanged.

Allow duplicate part numbers for geometrically equal components: Allow more than one part in the SOLIDWORKS Toolbox database with the same part number.

In certain cases you may want one part number for a variety of lengths of a toolbox component such as Unistrut or Structural Steel. If this behavior is desired the setting must be enabled for each profile it should apply to.

Image showing the option to use single part number option

 

Display Options: Here you can select different file properties to be used for Component Names, BOM Part Numbers and BOM descriptions.

For DIN, GB, ISO, and KS standards the Designation can be used in place of Custom properties in FeatureManager or in the BOM. The Designation is listed at the component level.

 

Permissions

An administrator creates a password and sets permissions for various Toolbox functions. Other users can view, but not modify, the restricted functions without the administrative password.

Password - Click Create/Change to create a password. The next time you open the Configure Data dialog box, click Login and enter the password to gain change access.

 

Image of the password dialog box

 

Configure Smart Fasteners

For Smart Fastener components added to Hole Wizard Holes SOLIDWORKS uses the settings located in the Toolbox. The can user to specify the exact fastener they would like to be used for a given Hole Standard. This applies not only to the screw or bolt but also any washers, nuts etc.

An administrator can restrict modifications to the Smart Fasteners data. Other users can view, but not modify, the restricted data without the administrative password. See Settings.

Washer Sizes

Select from the options to limit the available washer types, depending on the size of the Smart Fastener. The washer will be matched to the diameter of the fastener because these measurements are not always identical it’s suggested that a tolerance be used. The toolbox will not select a washer that is smaller than the fastener it is added with.

  • Exact match: Limits the available types to washers that exactly match the fastener size.
  • Greater than tolerance: Limits the available types to washer’s hole diameter that match the fastener size within the tolerance you type. (i.e., the washers hole diameter will always be a given percentage larger than the bolt or screw.)
  • Unrestricted: All washer types are available.

Image of the washer sizes option in the dialog box with options

 

Automatic Fastener Changes

These settings allow the top and bottom stack hardware sizes to be driven by the size of the screw or bolt associated with them.

  • Change fastener length to ensure minimum thread engagement: Fastener length increases when you add additional stack hardware, and decreases, to the specified thread distance or diameter multiple specified when you remove stack hardware. The first setting applies to bolts, the second applies to screws. Fastener length changes by standard increments and cannot be longer than the longest in the standard.
  • Change stack components when fastener size is changed: Nut and washer sizes automatically change when the fastener size changes.

image of the automatic fastener change dialog box

 

Fasteners to Use with Non-Hole Wizard holes

When you attempt to apply Smart Fasteners to a circular hole that was not created with the Hole Wizard, SOLIDWORKS will use the Hardware Standard specified in this path to add a fastener to the hole

 

Image of the fastener to use twith non-hole wizard holes dialog box

 

Applications

Cams: The toolbox can automate the creation of cams and followers with defined motion paths. There are three steps to creating a Cam: Setup, Motion and Creation. You will need to have a blank part or assembly document open to start the tool. The Cam creator can then be accessed by going to Tools>Toolbox>Cams…

 

Circular Cams-Setup

Units- Specify the unit system you would like to work in for the creation of the cam. If metric is selected dimensions you enter such as diameter will be interpreted as millimeters.

Cam Type- The two options here are circular and linear. See the next section for details on linear cams.

Follower Type- There are 5 options here but they can be broken down into two categories driven by the motion of the follower.

Linear Motion

image of traslating, offset left, and offset right follower type

Angular Motion

image of the angular motion swing left and swing right follower type

Follower Diameter-This is equal to the diameter of the groove that is cut in the cam.

Starting Radius-This is the distance from the center of cam rotation to the center of the follower.

Starting Angle- This is the angle between the follower and a horizontal line through the center of the cam. For a translating follower, type the value. For an offset or swing follower the starting angle can be computed or adjusted. If you select computed, the software calculates the starting angle for you. If you select adjusted, type the value.

Rotation Direction- Clockwise or Counter Clockwise

(Offset Follower only)

Offset Distance (A) and Offset Angle (B). See the illustration for descriptions of (A) and (B).

Image of the offset dtance and offset angle for offset follower only

(Swing Follower only)

Arm Pivot X Offset (A), Arm Pivot Y Offset (B), and Arm Length (C). See the illustration for descriptions of (A), (B), and (C). In the illustration, (B) is equal to (C) because the Swing Follower is vertical.

 

Image of the offset dtance and offset length for swing follower only

image of common terms for Cams motion

 

Circular Cams-Motion

On the Motion tab of the Cam dialog box, you specify information about how your follower moves around the cam. The Starting Radius and Starting Angle for circular cams are taken from the Setup tab. Total Motion displays the sum of the values in the Degree Motion column. If this value goes over 360 degrees to the path will be drawn in a sketch however the cut feature will not work.

To add a motion definition after the other motion definitions click Add.

The Motion Creation Details dialog box appears where you can add a new motion definition:

1. Select one of the 14 supported motion types from the Motion Type list.

Ending Radius is the distance from the center of cam rotation to the center of the follower when the motion definition is complete.

Degrees Motion is the distance the cam rotates through this motion definition.

2. Click OK to return to Motion tab of the Cam dialog box.

 

To insert a motion definition before an existing motion definition:

Select the numbered row of the motion definition where you want to insert the new motion definition, and click Insert.

The Motion Creation Details dialog box appears where you can add a new motion definition.

You can also drag the Motion steps around in the list to reorder. To do this, Left click and hold on the grey number boxes on the left side of the list

 

To edit a motion definition

1. Select the numbered row of the motion definition you want to edit, and click Edit.

2. The Motion Creation Details dialog box appears where you can edit the values.

3. To delete one or more motion definitions:

4. Select the numbered row of the motion definition you want to remove, and click Remove or Click Remove All to remove all of the motion definitions.

 

Circular Cams-Creation

When creating a cam using the toolbox there is no need for existing geometry in your part file. The cam will be built using the size parameters specified in the creation tab.

Image of the circular cams setup and some common terms

Blank Outside Diameter and Thickness - This is the outside diameter of the circular cam and the thickness of the cam plate.

Near Hub Diameter and Length - This is the diameter of the hole and the distance from the cam surface to the top of the hub on the near side of the cam. The near side is the side where the cam is cut for a cam with a blind track surface.

Far Hub Diameter and Length - This is the diameter of the hole and the distance from the cam surface to the top of the hub on the far side of the cam. The far side is the opposite of the side where the cam is cut for a cam with a blind track surface.

Blank Fillet Radius and Chamfer - This is the value for the fillet between the hub and the cam surface and the value for the chamfer at the top face of the hub.

Thru Hole Diameter - This is the value for the hole that goes through the hub.

Track Type and Depth - Cam tracks can be Blind or Thru. If Blind, the Depth value is the depth of the cam track into the cam surface. The Depth value cannot be greater than the Blank Thickness.

Resolution Type and Value - Cam tracks are comprised of arcs, curves, and lines where the points on the curve are calculated based on your selections on the Motion tab. You can control the resolution or tolerance between the points on these entities.

If you select Chordal Tolerance then the value you type represents the maximum distance from the chord between two consecutive curve points and the curve itself.

If you select Angular Increment then the value you type represents the maximum angle between two consecutive curve points.

Track Surfaces - Controls how the cam track is created. You can select Inner, Outer, or Both depending on your selection of Track Type.

Image of the track surface options of inner, outer, and both

Arcs - When this check box is selected, the cam track is created using a series of tangent arcs. When this check box is cleared, the cam track is created using a series of lines.

Click Create to create a cam in a new SOLIDWORKS part document.

Click Done when you are finished.

 

Linear Cams-Setup

Units- Specify the unit system you would like to work in for the creation of the cam. If metric is selected dimensions you enter such as diameter will be interpreted as millimeters.

Cam Type- The two options here are circular and linear. This section will go over the details of linear cams

Follower Type- There are 4 options here but they can be broken down into two categories driven by the motion of the follower.

Linear Motion

Images showing examples of linear motion translating and inclined follower types

Angular Motion

Images showing examples of angular motion swing trail and swing lead follower types

Follower Diameter - This is equal to the diameter of the groove that is cut in the cam.

Starting Rise - This is the vertical distance from the base corner of the cam to the center of the follower.

Starting Run - This is the horizontal distance from the base corner of the cam to the center of the follower.

Image showing the starting run location

For a Translating or Inclined follower, type the value. For a Swing follower, the Starting Run can be Computed or Adjusted. If you select Computed, the software calculates the Starting Run for you. If you select Adjusted, type the value.

 

Cam Motion - Left or Right

(Inclined Follower only) Follower Angle - This is the angle between the follower and a line that is perpendicular to the motion of the cam. The value must be +/- 45°.

Image of inclined follower only angle example

(Swing Follower only) Arm Pivot X Offset (A), Arm Pivot Y Offset (B), and Arm Length (C). See the illustration for descriptions of (A), (B), and (C).

image of the swing follower only arm pivot distances example

 

Linear Cams-Motion

On the Motion tab of the Cam dialog box, you specify information about how your follower moves around the cam. Starting Rise and Starting Run are taken from the Setup tab. Total Motion displays the sum of the values in the Run Distance column.

1. To add a motion definition after the other motion definitions click Add.

2. The Motion Creation Details dialog box appears where you can add a new motion definition.

3. Select one of the 14 supported motion types from the Motion Type list.

4. For a linear cam, set the Ending Rise and Run Distance values.

5. Ending Rise is the vertical distance from the base corner of the cam to the center of the follower when the motion definition is complete.

6. Run Distance is the distance the cam moves through this motion definition.

7. Click OK to return to Motion tab of the Cam dialog box.

 

To insert a motion definition before an existing motion definition

1. Select the numbered row of the motion definition where you want to insert the new motion definition, and click Insert.

2. The Motion Creation Details dialog box appears where you can add a new motion definition.

3. You can also drag the Motion steps around in the list to reorder. To do this, Left click and hold on the grey number boxes on the left side of the list

 

To edit a motion definition

1. Select the numbered row of the motion definition you want to edit, and click Edit.

2. The Motion Creation Details dialog box appears where you can edit the values.

 

To delete one or more motion definitions

Select the numbered row of the motion definition you want to remove, and click Remove or Click Remove All to remove all of the motion definitions.

 

Linear Cams-Creation

Blank Thickness, Blank Width, and Blank Length - These values define the size of the cam block.

Track Type and Depth - Cam tracks can be Blind or Thru. If Blind, the Depth value is the depth of the cam track into the cam surface. The Depth value cannot be greater than the Blank Thickness.

Resolution Type and Depth - Type a value for the maximum Motion Increment per motion definition. Depending on your motion type and resolution you could end up with an extreme number of faces even for a simple motion.

Image of a model showing a track example part

Track Surfaces - Controls how the cam track is created. You can select Upper, Lower, or Both depending on your selection of Track Type.

image showing the track surface option examples for lower, upper, and both

Arcs - When this check box is selected, the cam track is created using a series of tangent arcs. When this check box is cleared, the cam track is created using a series of lines.

Click Create to create a cam in a new SOLIDWORKS part document.

Click Done when you are finished.

 

Favorites

You can load, edit, or delete your favorite cam types. Favorites include settings from the Setup, Motion, and Creation tabs of the Cam dialog box.

SOLIDWORKS Toolbox includes cams in the Favorites list. These favorites vary between circular and linear cams, as well as between Metric and Inch units of measure.

To load, edit, or delete a favorite

 

1. From the Cam dialog box, click Favorites, List.

2. The Favorites dialog box appears.

3. Select a name from the Name list.

4. Click one of the following buttons:

5. Load. Loads the data from the favorite into the Cam dialog box.

6. Edit. Edits the name or template status of the cam. When you select Template, you cannot edit the setup, motion, or creation properties of the cam.

7. Delete. Removes the favorite from the list.

8. Click Done to close the Favorites dialog box.

 

Grooves

The toolbox can be used to automatically cut grooves in shafts for specific O-rings and retaining rings.

 

O-Ring Grooves

1. Click Tools > Toolbox > Grooves. The Grooves dialog box appears

Image of the gooves loactions in the Tools dropdown menu

  1. In the O-Ring Grooves tab you can specify what standard of O-ring you would like to create. Below that will be the type of the O-ring groove you want to use. The potential types break down into three categories:

Image of the O-ring grooves tabs you can use. face o-ring, external -ring grooves, and internal o-ring grooves.

                         Face O-Ring Grooves        External O-Ring Grooves        Internal O-Ring Grooves

 

3. Select a cylindrical face or circular on a part where you want to place the groove. For an internal O ring select an internal cylindrical face, for a Face O-Ring Grooves select a circular face. Tip: By pre-selecting a cylindrical face, the software determines the diameter for the groove and suggests appropriate groove sizes.

showing the external face of a cylinder

4. On the O-Ring Grooves tab, do the following:

a. Select a standard, a groove type, and an available groove size from the lists on the top left of the tab this will update the fields in the Property and Value columns.

b. Selected Diameter is set for you because you selected a cylindrical face in Step 1.

c. Mate Diameter. This is a reference value for the diameter of the non-grooved mating part that completes the seal.

d. Notice the values for the Groove

Diameter (A), Width (B), and Radius (C). These will be initially be driven by the size you select but can be overridden by typing a value in the cells.

e. For Internal and external O-rings there is no dimension to locate the O-ring along the shaft. The initial position is based on the position along the cylindrical face you initially

Showing the grooves pop up menuImage of the created groove on a model

 

Click Create to add the groove.

Once the O-Ring Groove has been created it acts as a revolved cut feature. If you would like to position the groove along the shaft, edit the sketch.

 

Retaining Ring Grooves

1. Click Tools > Toolbox > Grooves. The Grooves dialog box appears

Image of the gooves loactions in the Tools dropdown menu

 

2. In the Retaining Ring Grooves tab you can specify what standard of Retaining Ring you would like to create. Below that will be the type of the Retaining Ring groove you want to use. The types break down into two categories:

Images showing an external and internal groove

                                                 External                                                      Internal

3. Select a cylindrical face or circular on a part where you want to place the groove. For an internal retaining ring select an internal cylindrical face. Tip: By pre-selecting a cylindrical face, the software determines the diameter for the groove and suggests appropriate groove sizes.

showing the external face of a cylinder

4. On the Retaining Ring Grooves tab, do the following:

a. Select a standard, a groove type, and an available groove size from the lists on the top left of the tab. The fields in the Property and Value columns update.

b. Notice the Selected Diameter is set if you selected a cylindrical face in Step 2.

c. Notice the values for the Groove Diameter (A), Groove Width (B), and Radius (C). These will be initially be driven by the size you select but can be overridden by typing a value in the cells.

Showing the grooves pop up menu

5. Click Create to add the groove.

Once the O-Ring Groove has been created it acts as a revolved cut feature. If you would like to position the groove along the shaft, edit the sketch.

Iamge of the feature tree showing the groove feature

 

Beam Calculator

The Beam Calculator dialog box allows you to perform basic deflection and stress calculations on steel beams with a constant cross section.

1. Start the Beam Calculator by going to

Image of the beam calculator loaction in the Tools dropdown menu

2. Tools > Toolbox > Beam Calculator…

 

3. Use the slider to select the loading scenario you would like to perform a calculation for.

Showing different beam loading scenarios

4. Under Type of Calculation select what you would Deflection or Stress.

beam calculator pop up menu

5. Choose the beam cross section you would like to use by clicking on the Beams button Image of the beam button

image of the beam calculator showing the profile selections option

6. Select an Axis to determine the value in the Moment of inertia or Section modulus box. The axis directions are determined by the orientation of the cross section of the profile shown in the beams dialogue box. Y+ is up X+ is right.

7. Type a value in the rest of the boxes in the Input area except for the one to be solved, and click Solve. For example, make sure there is a value in all of the boxes except for the Deflection box if you are trying to solve for the deflection.

 

8. Click Done to close the Beam Calculator dialog box.

Image showing the beam calculator dialog boxalt=

 

Bearing Calculator

Using the Bearing Calculator dialog box, you can perform the following bearing calculations:

  • Capacity ratings
  • Basic life values

To calculate capacity ratings or basic life values

  1. Start the Beam Calculator by going to Tools > Toolbox > Bearing Calculator…

                                   image of the location of the bearing calculator in the tools dropdown menu

  2. To select a bearing for your calculations, select a standard, a bearing type, and an available bearing from the lists on the bottom left of the dialog box.

                           bearing calculator pop up menu
  3. Under Capacity, select Calculated to determine the capacity based on the dimensions and bearing parameters or Rated if the capacity is known or specified by the manufacturer. If you select Calculated, do the following:

    a. Type a value in the # Balls and Ball Diameter (or # Rollers and Roller Diameter if you selected a roller bearing) boxes, or accept the defaults for the selected bearing.
    b. Click Solve Capacity.
    c. The Capacity value appears.
  4. In the Equivalent Load box, type a load value which represents the combined radial and thrust loads for the bearing.
  5.  In the Speed box, type the revolutions per minute.
  6. Click Solve Life to calculate the Life in Revs (in millions of revolutions) and Life in Hours. If you only require the Life in Revs value, you do not need to type a value in the Speed box.

 

Structural Steel

Using the Structural Steel dialog box, you can bring the cross-section sketch of a structural steel beam into a part. The sketch is fully-dimensioned to match industry standard sizes. You can extrude the sketch in SOLIDWORKS to create the beam.
To add a sketch of a structural steel beam to a part

  1. Make sure you are not currently editing a sketch, then select a plane or planar face in your part.
  2. Click Toolbox, Structural Steel. The Structural Steel dialog box appears.
                  pop up menu for profile selection menu
    Select a standard, a beam type, and an available cross-section from the lists on the top left of the dialog box.
  3. Click Beam Calculator to use the Beam Calculator dialog box to help you determine which beam to select.
  4.  Click Send To to send the structural steel properties to a printer or a text file.
  5.  Click Create to add the sketch of the cross-section of the structural steel member to a part.
  6.  If you do not select a plane or planar face in Step 1, the sketch appears on the Front plane.
  7.  Click Done to close the dialog box.

To precisely locate the cross-section, right-click the new sketch, select Edit Sketch, and add dimensions or relations to position the sketch.

 

Concurrent Installations

If you are testing a new release of SOLIDWORKS, or working with more than one version of SOLIDWORKS at the same time you will need to have each version use its own library.
When installing a newer version of SOLIDWORKS, you have the opportunity to install as an upgrade or a new installation. By choosing a new installation, you can simultaneously run multiple versions of SOLIDWORKS on the same computer as long as they have the same serial number. However, there are many things to consider, especially if you are a Toolbox user.


Notes

• Any previous version assemblies that are opened in current version will be opening their toolbox parts from the previous version toolbox. If saved in current format, you could potentially overwrite the Toolbox master part with a current version. It will no longer not be accessible by the previous toolbox (even in other assemblies). To avoid corruption of the previous toolbox's, all references should be changed to the previous toolbox before opening in previous version. For more information on this process see the section on reference locations.
• Any previous version assemblies opened in the current version with the Toolbox references pointed to the new Toolbox will have problems because the configurations called out will be missing from the current toolbox. All configurations will have to be manually recreated in the current toolbox when previous version assemblies are moved to the newer version
• If both toolboxes are being used in conjunction, new configurations will be created in each that will not be common to both.
• When installing, choose new installation and specify a new directory for the SOLIDWORKS program files and Toolbox/Hole Wizard. Generally appending the year to the folder name is sufficient, i.e. C:\Program Files\SOLIDWORKS 2024 for the program files and C:\SOLIDWORKS Data 2024 for the Toolbox folder.

Was this article helpful?
0 out of 0 found this helpful

Comments

0 comments

Please sign in to leave a comment.