Problem
In SOLIDWORKS Simulation 2025, there is a bug that can cause studies to become corrupt & be deleted after switching to a different SOLIDWORKS Document with the Simulation Add-in on. This is noted in the following bug: "BR10000400636 - Switching between documents can trigger a message "Storage for study [name] is not found" and cause either missing studies or unexpected/obsolete/reverted study setup despite saving".
This issue affects only SOLIDWORKS 2025 SP1.2 and SP2, and is fixed in 2025 SP3 & newer.
Recommendations to help minimize the risk of unexpected SOLIDWORKS Simulation study setup data loss in SOLIDWORKS 2025 SP1.2 and SP2 are as follows:
- Avoid switching between SOLIDWORKS documents while the Simulation add-in is enabled.
- Activate SOLIDWORKS Backups by going to Tools > Options > System Options > Backup/Recover to set the 'Number of backup copies per document' to be ON and increase the number of backup documents. A value between 5 and 10 should suffice for most situations. Adjust for your situation as needed.
- Use the Save command regularly: If the issue occurs, closing (without saving), then reopening the affected document could restore missing/expected study data in some situations. However, this could cause other changes to be lost, so it is better to first enable the SOLIDWORKS Backup option as described above and subsequently save the file. Then, use Windows File Explorer to navigate to the folder specified in "SOLIDWORKS > Tools > Options > System Options > Backup/Recover > Backup > Backup folder" and open available backup copies until you locate the one that contains the data that you expect. Depending on the specific workflow, including the timing of Save commands, some backup copies may contain different/various portions of the expected study data. There might not be a single backup copy that contains all the expected study data.
Solution
Upgrade to SOLIWORKS 2025 SP3 or newer to fix the issue from occurring in the future. This fix prevents new occurrences of the issue, and it cannot repair or recover previously corrupted/lost study data.
Here are some additional notes on the behavior:
- If studies are still missing after loading backups, they cannot be recovered and will need to be remade
- Creating an identical study will not relink to any existing Simulation results, as it will have a different unique internal identifier that will not match up
- If you need to load the remaining studies in a file, you may need to disable "Load all Simulation Studies" from Simulation>Options. This is the Simulation dropdown at the top of SolidWorks.
- This issue only affects SOLIDWORKS Simulation. Other Simulation products (Flow Simulation, Motion, Plastics, Sustainability) are not affected by this issue.
For additional support, existing customers can submit a ticket or new customers can contact Hawk Ridge Systems.
Comments
Article is closed for comments.