Forming a New Assembly from Existing Components

Problem

This article discusses how to form a subassembly from existing assembly components in SOLIDWORKS.

Solution

The method below allows selecting as many parts in an assembly as desired and combining them into a subassembly.

  1. Open the desired Assembly
  2. Hold down the CTRL key and left-click components to select them

    Components Selected with CTRL key held down and left clicking
  3. With the components selected, right-click to select "Form New Subassembly"

    Right click and select Form New Subassembly
  4. Now make a choice on how to position the Origin of the new Subassembly with the window that comes up

    Specifify Assembly Origin
  5. Click the green checkmark for the "Reorganize Components" window that comes up and note any warnings on features that will be affected

    Click the green checkmark for Reorganize Components
  6. The outcome of "Form New Subassembly" depends on whether "Save new components to external files" is disabled or enabled, under Tools>Options>System Options>Assemblies

    Save new components to external files option in system options
  7. If "Save new components to external files" is disabled, then the newly formed subassembly saves as a virtual component within the parent assembly.
  8. If "Save new components to external files" is enabled, then the "Save as" dialog box appears when saving the top-level assembly 
  9. The new subassembly can be saved as its own assembly document by browsing to the new file location in the Save as dialog box, entering a File name, and choosing Save
  10. The selected components are now inserted into a new subassembly within the assembly file. 
New Subassembly

For additional support, existing customers can submit a ticket or new customers can contact Hawk Ridge Systems.

Was this article helpful?
0 out of 0 found this helpful

Articles in this section

Comments

0 comments

Article is closed for comments.