How to fix Error: The database file "C:\SOLIDWORKS Data\lang\english\swbrowser.sldedb" is not the Expected Version

Problem

This article goes over how to resolve common Hole Wizard/Toolbox version errors seen when trying to access the Hole Wizard or Wizard/Toolbox section of the System Options. This is caused by the Toolbox being the wrong version or missing. Here are some of the errors:

  1. Error: The database file <filepath\swbrowser.sldedb> is not the expected version <version number>
  2. The Hole Wizard and Advance Hole has unspported database version
the database file is not the expected version
sw toolbox hole wizard unsupported version

 

Solution 1: System Option Change

If SOLIDWORKS is installed and the location of the correct toolbox with the correct version is known, follow the steps below to point SOLIDWORKS at it:

  1. Locate the correct SOLIDWORKS Data folder. The Default location is located in 
    C:\SOLIDWORKS Data
  2. If there is more than one SOLIDWORKS Data folder, the correct version can be determined by checking the ToolboxFiles.index file in each SOLIDWORKS Data folder
  3. The index file will have a version line near the top when opening the file using Notepad.
    Note: Version numbers follow the following pattern: 2026=34.#.#.#, 2025=33.#.#.#, 2024=32.#.#.#, etc. 

    ToolboxFiles index-version-number
  4. Note the location of the correct SOLIDWORKS Data folder
  5. Open SOLIDWORKS
  6. Navigate to Tools > System Options > Hole Wizard/Toolbox 
  7. Click on the "..." button and select the corresponding SOLIDWORKS Data folder. If the warning appears again after choosing a folder, then the wrong folder was selected.

    set hole wizard toolbox file location

     

  8. Click OK to close the system options and try to use the Hole-Wizard tool to verify that the setting was saved.

Solution 2: Download a SOLIDWORKS Toolbox Data Folder

Here are some links to download a Default SOLIDWORKS Toolbox Data folder. Download the correct SOLIDWORKS Data folder for your version of SOLIDWORKS that you are missing below:

2022 - Link

2023 - Link

2024 - Link

2025 - Link

2026 - Link

Once a file set has been downloaded, follow the steps below to extract the files and configure SOLIDWORKS to use this Toolbox Data folder:

  1. Once downloaded, right-click on the zip file > Properties > select Unblock > Apply > OK, and extract the folder to the Local (C:) Drive.

    Once downloaded, right-click on the zip file > Properties > select Unblock > Apply > OK
  2. Open SOLIDWORKS
  3. Navigate to Tools > System Options > Hole Wizard/Toolbox 
  4. Click on the "..." button and select the corresponding SOLIDWORKS Data folder. If the warning appears again after choosing a folder, then the wrong folder was selected.

    set hole wizard toolbox file location

     

  5. Click OK to close the system options and try to use the Hole Wizard tool to verify that the setting was saved.

For information on other common Toolbox issues or Toolbox installation, check out these articles:

Updating the SOLIDWORKS Toolbox – Hawk Ridge Systems

SOLIDWORKS Toolbox Error: SOLIDWORKS database "sldbrowser.sldedb" is missing – Hawk Ridge Systems

Blank Error Box – Missing or Incorrect Hole Wizard/Toolbox Path – Hawk Ridge Systems

Create a New SOLIDWORKS Toolbox during a SOLIDWORKS Installation – Hawk Ridge Systems

Upgrade an existing SOLIDWORKS Toolbox during a SOLIDWORKS Installation – Hawk Ridge Systems

For additional support, existing customers can submit a ticket or new customers can contact Hawk Ridge Systems.

Was this article helpful?
9 out of 9 found this helpful

Articles in this section

Comments

0 comments

Article is closed for comments.