License Initialization Failure on Composer Launch after Admin Image Installation

This article goes over the current solution for the "License Initialization Failed" messages that prevent SOLIDWORKS Composer from being launched after installing Composer using an Administrative Image.

 

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SUMMARY

When attempting to launch SOLIDWORKS Composer, the user receives a "License Initialization Failure" error. At the bottom of the error, it prompts the user to "Click Here for More Information," however this leads to a blank page. Ultimately, SOLIDWORKS Composer fails to launch. This issue is known to affect SOLIDWORKS 2015 - 2018 on multiple versions of Windows.

 

CAUSE

The issue is caused when the incorrect SOLIDWORKS Composer Player item is selected in the Administrative Image Options Editor.

 

SOLUTION

Currently, there is one known solution, which is outlined in the SOLIDWORKS Knowledge Base, under issue #S-071144. It is resolved by modifying the admin image options, then redeploying the image. 

 

1. Uninstall SOLIDWORKS and SOLIDWORKS Composer.

2. Open the Administrative Image Option Editor.

3. Click on "Software to Install."

4. Deselect all of the items, starting with the top-level products.

5. Re-select the products from top to bottom, ensuring that you select the top-level SOLIDWORKS Composer option, prior to selecting any sub-items.

6. If done correctly, the sub-item "SOLIDWORKS Composer Player" will be have a greyed-out check-box next to it.

7. Continue to select products from top to bottom. Do NOT select the second SOLIDWORKS Composer Player, top-level item.

8. Redeploy the image.

 

 

This image shows the configuration which will result in the initialization error.

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This image shows the proper configuration, which should not produce an error.

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