"This product is not registered. Trial Evaluation Period: 0 days left" Licensing Error When Launching Network Install of Composer

The article explains how you can resolve the 3DVIA Composer - Licensing pop up message: "This product is not registered. Trial evaluation Period: 0 days left"

 

 

Problem

If you open SOLIDWORKS Composer and it brings forth a pop up message asking if you want to start in “Trial mode” or “Register your product” that looks like the image above, then this is the correct document for you. Clicking on "Trial", or "Register" does not work because this is a legacy error message from the older 3DVIA Composer versions.

Background Information

This guide is written for SOLIDWORKS Composer, activation based network versions 2013sp2, sp4, and all 2014 Network installations. It should also apply to 2015 Composer network licenses as well. If you are using an earlier version of 3DVIA that is license file based please download our earlier installation documents to correctly load and administer your version of 3DVIA.

Root Cause

You are typically getting this Composer license error when changing from a Standalone license to a floating Network license, or changing from a Trial Standalone license to a floating Network license.


Options For Repair

You may be installing SOLIDWORKS Composer Network version where Standalone was installed before.

  1. If this is SNL based, try "borrowing" the Composer license and then try to restart Composer. If it opens with the borrowed license it proves that you have a good, active license on the server.
  2. Return the license.
  3. Now you can open "regedit" and look for the registry key:HKEY_CURRENT_USER\Software\FLEXlm License Manager
  4. In this key, create a new string value named "SW_D_LICENSE_FILE" and enter 25734@<servername> as its value.

 

If this key and string was not there before, and you created it, Composer should open normally now.
Please open and test SOLIDWORKS Composer.

This solution is from S-062209 (VAR only) and is listed last. It has been my experience that if this registry key and string value is not present in the client computer on a network installation of Composer, then this is the one thing that will almost always cure the issue listed.

 

 

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