Using Auto-Recover After SOLIDWORKS Crash

When you start SOLIDWORKS after the system has crashed, any available auto-recovered documents are listed under Document Recovery on the SOLIDWORKS Recovery tab of the Task Pane. From there they can be saved as a new file or used to replace the original.

To open an auto-recovered document:

  • Double-click the document in the Document Recovery list, or right-click the document and select Open.
    Document Recovery List fixed.png
  • You can then save the document either by using Save to replace the original file or by using Save As to create a new file.
To check your auto-recovery settings you can navigate to:
Tools > Options > System Options > Backup/Recover
Recovery options fixedj.png
Sometimes the SOLIDWORKS Recovery tab does not appear after a crash.
 
If you take a look at the folder listed under the Auto-recovery setting you will discover where SOLIDWORKS has been saving your Auto-recovery data. Navigating to the folder within Windows Explorer, you should see a file with a .SWAR extension.
 
Visibility of this file extension requires having hidden files visible within your Windows Explorer options.
 
To enable the viewing of hidden files and folders in your Windows folder options:
Folder Options > View > Show hidden files, folders, and drives

If you look at the name of the auto-recovered file, you will see that SOLIDWORKS has saved a copy of the part or assembly file, added a prefix, and appended the file extension.

  • For Example: PART A.SLDPRT – Is saved as: AutoRecover Of PART A.SLDPRT.SWAR
    Recover File Explorer.png

If you edit the name and extension of the file, removing the Auto-Recover prefix and replacing the .SWAR extension with the correct part, assembly, or drawing file extension – we end up with a copy of our original file, that has the last change saved based on the number of minutes set in the Backup/recover options.

Was this article helpful?
0 out of 0 found this helpful

Comments

0 comments

Please sign in to leave a comment.