Before starting any Flow Simulation Project, we have developed a to-do list of preprocessing steps to perform on your CAD geometry. This tends to minimize headaches when you've already put hours and hours into an analysis. The following is a list of things we do before creating a new Flow Simulation Project (in no particular order):
Force Rebuild with Verification on Rebuild (VOR) turned on
When disabled, when a new feature is created, SOLIDWORKS checks that the new feature does not intersect or overlap with any adjacent faces in the Solid model. When enabled, SOLIDWORKS will check that new or changed features do not intersect or overlap with any model faces or edges.
- Go to Tools > Options > System Options Tab > Performance and check the box for "Verification on Rebuild" and click "OK" to close Options
- Press CTRL-Q on the keyboard to perform a Force Rebuild with Verification on Rebuild on. Depending on the file, this may take a while. This setting checks every feature against all existing faces and edges, not just adjacent faces and edges. When this option is turned on, features that cause invalid geometry fail.
- If any features fail, fix them now
Check Entity
The Check Entity tool can be accessed from Tools > Evaluate > Check or from the Evaluate tab in the Command Manager. It is a simple tool to check for undesirable geometry.
Check Entity can check all bodies, selected bodies, or only features. Check Entity can determine:
- Invalid Face(s)
- Invalid Edge(s)
- Short Edge(s)
- Open Surface(s)
- The Minimum Radius of Curvature
- The Maximum Edge Gap
- The Maximum Vertex Gap
The results will display under the 'Result List' where each requested value can be selected; it will highlight the component in the graphics area with an arrow pointing to the point of interest. Then it is recommended to review the results and determine how to modify the geometry to resolve the undesirable geometry.
Flow Simulation’s Check Geometry
The Check Geometry tool helps identify invalid contacts that Flow Simulation rejects. While it can fix some issues, it's best to correct them yourself first. It also verifies if you have a fully enclosed fluid volume, which is essential for internal analysis.
This tool can be found with the Flow Simulation add-in turned on under Tools > Flow Simulation > Tools > Check Geometry. Click the Check button to test the model for a few different tests. For more information on the tool, check out the Flow Simulation help file: Check Geometry (SOLIDWORKS Flow Simulation)
Interference Detection
Interference detection is useful for both Simulation and Flow Simulation. While Flow Simulation is less focused on interference, it's crucial for heat conduction problems to ensure the faces you expect to be touching are actually in contact.
- Open SOLIDWORKS and load the Flow Simulation Model
- Go to Tools > Interference Detection or find it from the Evaluate tab in the Command Manager
- Check "Treat coincidence as interference”. Having this checkbox on will list, in addition to any material interferences, all sets of touching faces.
- Check "Include multibody part interferences"
- Click "Calculate" to start the tool to check if parts are touching as desired for Conduction
Import Diagnostics
When working with imported geometry (IGES, STEP, Parasolid, etc.), use Import Diagnostics early. It helps identify faulty faces or gaps that can cause issues later. Run the tool to heal all problems or manually delete and patch faulty areas to save time. Find Import Diagnostics at the part level under Tools > Import Diagnostics.
Comments
Article is closed for comments.