Problem
This article explains how to remove Detailing Mode data from SOLIDWORKS 2020-2021 drawing files. Detailing mode data can greatly increase file size, causing longer open and save times. Detailing mode was introduced in SOLIDWORKS 2020 SP0, but the option to disable it and remove its data is available starting in 2020 SP4. Please update to 2020 SP4 or later to continue.
Please note that this article only applies to SOLIDWORKS 2020 to 2021. For SOLIDWORKS 2022 or newer, review this article: Drawings are Slow to Save in SOLIDWORKS 2022 – Hawk Ridge Systems
Solution
First, we need to confirm if Detailing Mode data exists in the Drawing. In SOLIDWORKS, go to File > Open and open the drawing file in question. Move the slider to detailing mode before attempting to open the file. This option is only available if the file has been saved with detailing mode data.
Another way to confirm if the drawing is affected is by observing a dramatically larger file size after saving the drawing in the newer version of SOLIDWORKS (EX: 5MB drawing increasing to 100MB), which can cause the drawing to open and save much slower than previous versions.
Since detailing mode data remains even after turning off the setting, simply disabling it won't reduce file size. To remove this data, hide the reference files in the drawing to prevent view recreation, resulting in blank detailing mode data. Follow the steps below to remove detailing mode data:
-
Move all assembly and part files directly referenced by the drawing views to a new folder in a location that does not typically store SOLIDWORKS files. The Desktop should generally work for this step. Also select the option to exclude recent save locations if you do use the Desktop to save SOLIDWORKS files from Tools > Options > System Options > External References.
- Open the drawing file. This will take the same loading time as before. If prompted, select the option to suppress all missing components so that the drawing views are blank.
-
Disable the setting to save with detailing mode data from Tools > Options > System Options > Drawings > Performance.
- Save the drawing again and close it. The file size should now be greatly reduced.
- Move the reference parts and assemblies back into their original folders so that the drawing file can see them again.
- Open the drawing again. It will open with blank views. Right-click on each view and select "Show". This will show drawing views as they were originally.
- Save the drawing file.
If multiple drawings are having this issue with file size and long opening times, it is recommended to keep detailing mode data turned off in the SOLIDWORKS system settings.
For additional support, existing customers can submit a ticket or new customers can contact Hawk Ridge Systems.
Comments
Article is closed for comments.