Problem
This troubleshooting guide is designed to help users troubleshoot a wide variety of issues with SOLIDWORKS PDM Web2, which can all be caused by a misconfigured Application Pool Identity in Internet Information Services (IIS). This issue is especially common after performing an upgrade or migration of Web2.
If the SOLIDWORKS PDM Web2 application pool does not use the correct identity, using the Web2 client to log in to the file vault will either:
- Repeatedly show the login page.
- Stop responding after entering the login credentials.
- Open successfully upon login, but then fails to navigate between folders or stops responding when viewing file details (such as previewing the file).
- Display any of the following errors: "SyntaxError: Unexpected token...", "Could not open database. This could happen if the network connection is broken or if the database has been removed", "500 Internal Server Error", or "Error 34 OI ExRunExport failed".
Solution
In order to solve the problem, we will need to reconfigure the Application Pool Identity in IIS following the steps below in order:
- SOLIDWORKS has created a comprehensive troubleshooting guide for this issue, which is attached to this article as QA00000119331
- If the guide does not resolve the issue, please follow the additional steps found in the attached article QA00000121076.
For additional support, existing customers can submit a ticket or new customers can contact Hawk Ridge Systems.
Comments
Article is closed for comments.