This troubleshooting guide is designed to help users troubleshoot a wide variety of issues with SOLIDWORKS PDM Web2, which can all be caused by a misconfigured Application Pool Identity in Internet Information Services (IIS). This issue is especially common after performing an upgrade or migration of Web2.
Diagnosis:
If the SOLIDWORKS PDM Web2’ application pool does not use the correct identity, using the Web2 client to log in to the file vault will either:
1. Repeatedly show the login page.
2. Stop responding after entering the login credentials.
3. Opens successfully upon login, but then fails to navigate between folders or stops responding when viewing file details (such as previewing the file).
4. Display any of the following errors:
- '"SyntaxError: Unexpected token..."
- "Could not open database. This could happen if the network connection is broken or if the database has been removed"
- "500 Internal Server Error"
- "Error 34 OI ExRunExport failed"
Solution:
In order to solve the problem, you'll need to reconfigure the Application Pool Identity in IIS.
SOLIDWORKS has created a comprehensive troubleshooting guide for this issue, which is attached to this article as "S-070903 - What could cause Web2 login to hang or show -Could not open database-.pdf".
If the guide does not resolve the issue, please follow the additional steps found in the attached guide, "Instructions how to use a non-administrative Windows user for the Web2 application pool.pdf".
If you have any questions regarding the information above, please contact Hawk Ridge Systems Technical Support at 1-877-266-4469 (US), 1-866-587-6803 (CAN), or support@hawkridgesys.com.
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