Error: The Operating System on Index Server does not support Indexing Service

Problem

This article is about an error that can occur when enabling the File Vault Archives option for the Indexing node in the PDM administration tool. When enabling the File Vault Archives option, an error occurs: "The Operating System on Index Server does not support Indexing Service". Attempts to restart the Windows Indexing service or launch the admin tool using a Windows administrator account do not resolve the error.

PDM Index Error

Before proceeding, a PDM backup is recommended. Follow the instructions in this article to create the backup:

EPDM: Backup and Restore - Hawk Ridge Systems

Solution

The error can be caused by the Windows Search service being disabled on the PDM archive server. Depending on how PDM is installed in your environment, there may be a separate Archive and Database server. If there is a separate PDM Archive and Database server, then the Windows Search service will need to be running on both machines. 

  1. Navigate to the Windows Control Panel > System and Security > Administrative Tools
  2. Open the Microsoft Windows Services console under the Administrative Tools menu
  3. Verify if the Windows Search service is running in the Windows Services Console
  4. Restart the Windows Search Service if it is not running on the PDM server
Check Windows Service
  1. After restarting the Windows Indexing Service, open the PDM Administration tool and log in with the PDM administrator account when prompted 
  2. Navigate to the Indexing node in the PDM admin tool and attempt to enable archive indexing on the PDM server. 
  3. If there is no error, the following menu should appear with the checkbox to enable indexing. Check the box for 'Index File Vault Archives' and click the 'OK' button to save changes.
Enable Index File Vault Archives
  1. Start the SQL Server Management Studio (SSMS) tool located on the PDM Database server.
  2. Log in to the SSMS tool using the SQL 'sa' account (Administrator).
  3. Expand the PDM Vault Database, select "Tables", and right-click the dbo.SystemInfo table. 
  4. Select "Edit Top 200 Rows" from the pop-up menu in the SSMS tool. 
  5. Locate the column "Indexed" and change the value to "False" if the current value is "True" in the table. 
  6. Find the column labeled "IndexServer" and, if there is a value listed, change it to "NULL" in the table. 
  7. Log out of the SMSS tool and restart the PDM administration tool.
  8. Log into the PDM administration tool as 'admin' and then try opening the Index node again.

    Set Index Server Node to NULL

For additional support, existing customers can submit a ticket or new customers can contact Hawk Ridge Systems.

 

 

Was this article helpful?
0 out of 0 found this helpful

Articles in this section

Comments

0 comments

Article is closed for comments.