Follow

Best Practices for Referenced Documents - PDM

Kevin Glick

 

Best Practices for Referenced Documents in PDM

When files are first migrated in PDM, file references may still require additional updating. While files may have been checked into the vault and the vault references are correctly saved, files can still reference their initial locations from outside of the vault.

There are two different instances when file relations can be updated:

  1. Before files are initially checked in to the vault
  2. After files have been initially checked in to the vault

Each method has a different process due to how the file references can be updated.

Before Initial File Check In

Before an assembly has completed the initial check in operation, it can be useful to verify, and if needed, update the file references. Select a file that has not completed its initial check in, and go to Tools > Update References.

 

 

 

Update references allows you to see the existing references, search for files within the vault that match the filename, and select the location of those files if more than one identically named file exists. The referenced in column will also show you the existing location of the file.

Once you select which file references to update, you will be shown the changes that will go into effect.

 

When the file has had its references completely updated, you can safely check in the file and expect the references to be correctly populated in PDM as well as SOLIDWORKS.

 

 

 

After Initial File Check In

If a file has been checked into PDM, any broken relations can now no longer be corrected via Update References. Instead now, SOLIDWORKS uses predetermined search routines to locate a file. SOLIDWORKS will first attempt to open a referenced file from the last saved directory of the file. If this file is not found, SOLIDWORKS will revert to its default search routine.

1. RAM. If a file with the correct name is already in memory, it will use that file.
2. The paths specified in the Folders list on the File locations tab (Tools> Options> System Options> File locations). 
3. The last path specified to open a document.  When opening a parent document (e.g. an assembly), SOLIDWORKS will search in the same directory for the referenced files.
4. The last path used by the system to open a document.  This will apply if the system opened a referenced document last.
5. The path where the referenced document was located when the parent document was last saved. This is the path stored in the parent document except that the drive path (C:\, D:\) is considered to be the current drive.
6. The path where the referenced document was located when the parent document was last saved with the original disk drive designation. The absolute path name stored with the parent document.
7. If the referenced document still cannot be found, SOLIDWORKS will ask to browse for the file.

 

This can cause issues if a file is found outside of the vault where in its original directory. If a copy of the file is still found in the original directory outside of PDM, and the last save of the assembly referenced this file, then this file will be selected and used as the referenced document.

If this last saved location is still available, you may need to manually update the reference of the file. The best way to update these files is through the reference update of the open dialog.


Example:

A file was added into PDM via drag and drop but was last saved referencing components on a user’s desktop. Upon viewing the file references, we see the assembly file correctly referencing the location in the vault where it is being opened from, however since the part files were last saved on the desktop (and still exist there) the file opens with the shown references.

 

PDM references show all parts are located in vault, yet the SOLIDWORKS references are showing that the part files are still being pulled from the desktop, and not the vault.

 

To correct this, there are a few options.

  1. Rename or delete the old files located in the original directory. This will cause SOLIDWORKS to be unable to find the original source location (In this case, the desktop) and will use the search routine to find the correct file in the vault. This open is faster, but gives less control.

 

  1. Instead of breaking the file references and forcing the search routine, use the File > Open dialog in SOLIDWORKS and use the References… option to update and specify the exact file you need.
  • From this dialog, you will be able to see all referenced documents and can update the referenced file location manually.

Before

 

 After

 

Once the file has been opened with the correct references, save the document, check the file back into PDM, and all future references of the file will correctly reference the vaulted files.

  

Once file references have been updated by a user, it may be necessary to verify that the updated references are correctly being used. To determine whether file references of a file are correctly working, open your file within SOLIDWORKS and open the file references File > Find References

This list of files should match the PDM Contains tab and should correctly reference the files within the vault.

 

 

 

Was this article helpful?
2 out of 2 found this helpful
Have more questions? Submit a request

Comments