How to fix Error: The database file "C:\SOLIDWORKS Data\lang\english\swbrowser.sldedb" is not the Expected Version

Problem

This article goes over how to resolve common Hole Wizard/Toolbox version errors seen when trying to access the Hole Wizard or Wizard/Toolbox section of the System Options. This is caused by the Toolbox being the wrong version or missing. Here are some of the errors:

  1. Error: The database file <filepath\swbrowser.sldedb> is not the expected version <version number>
  2. SOLIDWORKS database "sldbrowser.sldedb" is missing
  3. The Hole Wizard and Advance Hole has unspported database version
the database file is not the expected version
solidworks database file is missing information dialog box
sw toolbox hole wizard unsupported version

 

Solution 1: System Option Change

If SOLIDWORKS is installed and the location of the correct toolbox with the correct version is known, follow the steps below to point SOLIDWORKS at it:

  1. Locate the correct SOLIDWORKS Data folder. The Default location is located in 
    C:\SOLIDWORKS Data
  2. If there is more than one SOLIDWORKS Data folder, the correct version can be determined by checking the ToolboxFiles.index file in each SOLIDWORKS Data folder
  3. The index file will have a version line near the top when opening the file using Notepad.
    Note: Version numbers follow the following pattern: 2026=34.#.#.#, 2025=33.#.#.#, 2024=32.#.#.#, etc. 

    ToolboxFiles index-version-number
  4. Note the location of the correct SOLIDWORKS Data folder
  5. Open SOLIDWORKS
  6. Navigate to Tools > System Options > Hole Wizard/Toolbox 
  7. Click on the "..." button and select the corresponding SOLIDWORKS Data folder. If the warning appears again after choosing a folder, then the wrong folder was selected.

    set hole wizard toolbox file location

     

  8. Click OK to close the system options and try to use the Hole-Wizard tool to verify that the setting was saved.

Solution 2: Create New Toolbox during Installation

During a reinstallation or new Installation of SOLIDWORKS, we can have SOLIDWORKS create a new toolbox data folder.

  1. Start the installation of SOLIDWORKS
  2. At the Summary page, click the blue "Change" button in the Toolbox/Hole Wizard Option section

    Click the blue Change button in the Toolbox Hole Wizard Option section.png
  3. Select the "Create a new SOLIDWORKS 20XX toolbox" option

    Create a new SOLIDWORKS 20XX toolbox.png
  4. Click "Back to Summary"
  5. Accept the terms and start the installation

SOLIDWORKS will create a new folder for the toolbox during the installation and name it SOLIDWORKS Data (#), where "#" represents the number of times SOLIDWORKS has been installed on this computer and other SOLIDWORKS Data folders already exist, each for another version of SOLIDWORKS. The default file path is:
C:\SOLIDWORKS Data

To avoid confusion in the future, we recommend replacing the "(#)" with the year version of SOLIDWORKS that is being installed (i.e., SOLIDWORKS Data 2026). Further details here: Best Practices for Multiple Installs of SOLIDWORKS – Hawk Ridge Systems

Solution 3: Use an Existing Toolbox during Installation

When reinstalling or installing SOLIDWORKS on a machine with an older version or a custom toolbox, SOLIDWORKS can use and upgrade that toolbox during installation.

  1. Start the installation of SOLIDWORKS
  2. At the Summary page, click the blue "Change" button in the Toolbox/Hole Wizard Option section
    Click the blue Change button in the Toolbox Hole Wizard Option section.png
  3. Select the "Use an existing SOLIDWORKS Toolbox" option and click the "Browse" button to navigate to that toolbox folder

    Use an existing SOLIDWORKS Toolbox option
  4. Optional: Check on "Upgrade a copy of your 20XX Toolbox data" so that a copy of the toolbox folder is upgraded instead. This will not modify the original toolbox folder so that the older version can still use it. This is useful for client machines that run multiple versions of SOLIDWORKS
    Upgrade a copy of your 20XX Toolbox data options.png
  5. Click "Back to Summary"
  6. Accept the terms and start the installation

SOLIDWORKS will now install and upgrade the toolbox folder selected to the version being installed.

Solution 4: Download a SOLIDWORKS Toolbox Data Folder

Here are some links to download a Default SOLIDWORKS Toolbox Data folder. Download the correct SOLIDWORKS Data folder for your version of SOLIDWORKS that you are missing below:

2022 - Link

2023 - Link

2024 - Link

2025 - Link

2026 - Link

Once a file set has been downloaded, follow the steps below to extract the files and configure SOLIDWORKS to use this Toolbox Data folder:

  1. Once downloaded, right-click on the zip file > Properties > select Unblock > Apply > OK, and extract the folder to the Local (C:) Drive.

    Once downloaded, right-click on the zip file > Properties > select Unblock > Apply > OK
  2. Open SOLIDWORKS
  3. Navigate to Tools > System Options > Hole Wizard/Toolbox 
  4. Click on the "..." button and select the corresponding SOLIDWORKS Data folder. If the warning appears again after choosing a folder, then the wrong folder was selected.

    set hole wizard toolbox file location

     

  5. Click OK to close the system options and try to use the Hole Wizard tool to verify that the setting was saved.

For information on upgrading the Toolbox Data folder manually, check out this article:
Updating the SOLIDWORKS Toolbox – Hawk Ridge Systems

For additional support, existing customers can submit a ticket or new customers can contact Hawk Ridge Systems.

Was this article helpful?
9 out of 9 found this helpful

Articles in this section

Comments

0 comments

Article is closed for comments.