Creating Custom Thread Tool Profiles in SOLIDWORKS

Problem

The Thread tool in SOLIDWORKS comes with many standard thread sizes available. However, what if you need to model a size that isn’t already included? This article will walk you through the process of adding a new custom thread size to the thread tool.

Solution

Follow the steps below to locate the Thread Profile files and modify them to create a Custom Thread:

  1. Go to Tools > Options > File Locations and set the dropdown to “Thread Profiles”.
Set to thread profiles
  1. Browse to the file location listed. The default location is: C:\ProgramData\SOLIDWORKS\SOLIDWORKS 2026\Thread Profiles. Note: If the ProgramData folder is hidden on the C drive, enable "Hidden Items" in the Windows Explorer settings from the View Tab on Windows 10 and View > Show > Hidden Items on Windows 11.
Click View tab and check Hidden Items
  1. These SLDLFP (Library Feature Part) files contain all the data for the different thread sizes available in the Thread tool. They will always open as Read Only in SOLIDWORKS.

    Thread Library Files
  2. Open SOLIDWORKS and go to File > Open, and browse to your thread profiles file location
  3. Open the existing file that most closely matches the type of thread to add. In this example, we will use the Inch Die file.
mceclip4.png
  1. For the warning about Read-Only access, select “Open Read-Only” in the dialog window. Note: The default thread profiles MUST be opened Read-Only, so any changes or edits made will be saved as new files with new file names. 
Click open read-only
  1. Once the file is open, go to the Configuration Manager and delete all but one of the configurations. 
Delete all but one thread configs
  1. For the warning about making changes to a Read Only file, click "OK" on the warning to continue

  2. Go back to the Feature Manager, right-click on the “ThreadProfile” sketch, and select “Configure Feature
Configure Thread Profile Sketch
  1. Right-click the Configuration Name to rename the existing configuration to whatever name makes sense for the custom thread size. 
mceclip9.png
  1. Enter values for the Pitch, Profile_Land, and Profile_Height dimensions. See the image below for where these dimensions correspond to on the thread profile sketch.
Edit table values
mceclip10.png

 

  1. To add multiple thread sizes, add more configurations to the table by clicking in the “Creates a new configuration” box and typing the name of the new configuration.
Add new configuration for new size
  1. Once done adding all custom data, click “Apply” and then “OK” to close the configuration window
Click Apply then click OK to close the window to save the changes
  1. Go to the Configuration Manager again, and confirm that all the new configurations have been added
Confirm the configurations have been added
  1. Go to File > Save As and give the file a name. This is the name we will see under the “Type” dropdown in the Thread tool. Save the new file to the same location as the other thread profiles.
Save the file
  1. Close the thread profile Library feature part
  2. Open a new or existing part with a cylindrical body in it, and start the Thread tool.
Start the thread tool
  1. Select the new file in the “Type” dropdown and test out the new custom sizes in the “Size” dropdown.
Set to custom size to test

For additional support, existing customers can submit a ticket or new customers can contact Hawk Ridge Systems.

Was this article helpful?
0 out of 0 found this helpful

Articles in this section

Comments

0 comments

Article is closed for comments.