Troubleshooting Importing Files into SOLIDWORKS

Problem

Sometimes, users encounter issues importing files into SOLIDWORKS from another computer-aided design (CAD) software. This article goes over some helpful steps to increase the chances of success when importing.

Solution

Here are some steps that can be taken to help improve the chances of success when importing files:

  1. Get as much information about the original file as possible. What units were used? Can the original CAD application successfully read the exported file back into itself?
  2. Determine whether the original CAD software uses a common kernel, either Parasolid or ACIS. If it does, use either of these file formats to export from the other CAD and then attempt to import into SOLIDWORKS.
  3. Use Import Diagnostics (Tools > Evaluate > Import Diagnostics) in SolidWorks. This tool attempts to repair an invalid solid body using the Heal button. Problems include gaps between faces and invalid surface geometry.
  4. Manually repair the model in SolidWorks. Locate the problem areas using Import Diagnostics and use the Delete Face command along with the surface tools to manually patch up the model. This video goes over some tools for editing imported models: SOLIDWORKS: Direct Editing for Imported Models
  5. When working with a file containing a large number of bodies, using the import option "Import multiple bodies as parts" can be useful. Checking this option will make a new part for every Solid or Surface Body located within the imported part. This option is accessed from Options > System Options > Import.
  6. Review the SOLIDWORKS list of file types that can be imported with information on each type from this help file: File Types - 2027 - SOLIDWORKS Design Help

For additional support, existing customers can submit a ticket or new customers can contact Hawk Ridge Systems.

Was this article helpful?
0 out of 0 found this helpful

Articles in this section

Comments

0 comments

Article is closed for comments.