Follow

Building Model from CircuitWorks Produces Empty Assembly

Sam Frew

This article discusses an issue in which a PCB file that is opened and built in CircuitWorks produces an empty assembly in SOLIDWORKS rather than a populated PCB assembly.

 

The workflow that produces the problem is:

1. Enable the CircuitWorks add-in.

2. Open the PCB file in CircuitWorks.

3. Click Build Model and respond appropriately to any prompts encountered through the build process.

4. Once the build process is complete, notice that the resulting assembly appears, but is empty.

 

A known cause of this problem is having corrupt or future version SOLIDWORKS model files associated to components in the CircuitWorks library. If those components are a match to the components on the PCB, CircuitWorks will try to use the associated model, but if that model cannot be opened because it is corrupt or from a future version of SOLIDWORKS, the build process will fail. Unfortunately, CircuitWorks will not give an error message alerting the user that this is the case.

To check for files in your library with this issue, we suggest running through the following steps using the SOLIDWORKS Task Scheduler for the same year version in which you are using CircuitWorks. This will create and run a task to open, rebuild and save each of the files in the folder. Any that fail will show in the status report once the task completes. Note that for a lot of files, the task could take a long time to run, so you may want to start it at the end of the day and run it overnight.

1. Make a copy of your CircuitWorks component library folder in a new location. You can find the path of this directory from Tools > CircuitWorks > CircuitWorks Options > Models > Components.

2. Open Start > Programs > SOLIDWORKS 20XX > SOLIDWORKS Tools > SOLIDWORKS Task Scheduler 20XX.

3. Select Update Files from the list on the left.

4. Click Add Folder and browse to the copied folder. Click OK.

5. Leave the other options default and click Finish. This will start the task.

 

6. Once Complete, click the link in the Status column to bring up the status report. Any corrupt files will show in red with a message like that in the image below.

 

7. These files will need to be removed from the library folder and either recreated automatically with CircuitWorks or manually in SOLIDWORKS.

 

Note that there is also a bug report related to this issue:

SPR 648898: “Blank assemblies are generated if single component in board is corrupt or in newer version format (cannot be read), no error”.

If you would like to be added to this enhancement request and receive an e-mail notification when its status changes:

1. Log into the SOLIDWORKS Customer Portal (http://customerportal.solidworks.com)

2. Click Enhancement Requests under the My Support section

3. Search “648898” and click on the search result

4. Complete and submit the form.

Was this article helpful?
0 out of 0 found this helpful
Have more questions? Submit a request

Comments