Follow

Using ScanTo3D to create a Solid Body

Mike Miura

This article outlines the steps to import a model using ScanTo3D and convert it into a Solid Body. It links to other articles that provide more in-depth descriptions of the tools used.

 

SOLIDWORKS has embraced the emergence of 3D scanning technology with the ScanTo3D add-in for SOLIDWORKS Premium and Professional users. With this add-in, users can speed up their design process by scanning existing components, importing them into SOLIDWORKS and creating a Solid Body. Below are the steps to accomplish this.

 

Importing Files Into SOLIDWORKS

ScanTo3D currently supports the following file types: .XYZ, .TXT, .ASC, .VDA, .IGS, .IBL, .NZIP, .NXM, .SCN, .3DS, .OBJ, .STL, .WRL, .PLY, & .PLY2. Some of these file types can be opened by SOLIDWORKS without ScanTo3D enabled, but to proceed using this method, the files need to be opened with the ScanTo3D option enabled (Tools > Add-ins, check "ScanTo3D"). When this is done, go to File > Open, then filter by file type. The bottom two selections should be ScanTo3D Mesh and Point cloud file types. The file must be opened in this method.

 

Creating A Usable Mesh

To create a solid, we first need a working mesh. Once the part is imported, a mesh needs to be created or may need to be refined. If you have imported a clean mesh, this step may not be necessary. Using the Mesh Prep Wizard (Tools > ScanTo3D > Mesh Prep Wizard), you can create a mesh from a point cloud or refine an imported mesh file. This tool can be used to remove noise, smooth surfaces, and simplify the mesh. Follow this link for a guide with a description of the options in the Mesh Prep Wizard.

 

Turning The Mesh Into Surface Bodies

Once you have created the mesh, using the Surface Wizard (Tools > ScanTo3D > Surface Wizard). The purpose of this tool is to divide the mesh into regions and calculate a surface body that can be applied to incorporate those regions. Upon completion of the Surface Wizard, you will be left with multiple surfaces that hopefully combine to create an enclosed volume. Follow this link for a guide with a description of the options in the Surface Wizard.

 

Using The Surface Bodies To Create A Solid Body

Now that you have a surface bodies, you will most likely need to create a fully enclosed volume with the bodies you have created. This may include editing some of the geometry created by the Surface Wizard, Extending Surfaces, filling in gaps using other surfacing techniques. There are multiple methods to form a Solid Body from a surface, and they can be found here.

 

If you have completed all the steps above, congratulations, you now have a solid model and can proceed in the design process. If you have any questions or need clarification on any of the methods described in this article, feel free to contact Hawk Ridge Systems Technical Support at support@hawkridgesys.com.

 

Was this article helpful?
1 out of 1 found this helpful
Have more questions? Submit a request

Comments

  • Avatar
    Mike Rodgers

    Good article. Thanks.