Follow

ScanTo3D - Using the Mesh Prep Wizard

Mike Miura

This article was written to assist in the process of creating a mesh from an imported point cloud, or refining an imported mesh. To use these features, you must have the ScanTo3D add-in, which is included in the SOLIDWORKS Professional and Premium packages in 2016.

 

Opening Files and Supported Types

To Open a file as a point cloud or mesh, you will first need the ScanTo3D add-in enabled. To do this, go to Tools > Add-ins, the select ScanTo3D. Once enabled, go to File > Open, then under the file type drop down, you can select Mesh Files or PointCloud Files. The supported file types are shown below, and the add-in must be enabled to view these file types. Some of the file types listed can also be imported as their native type, but to bring them in as a mesh or point cloud, you must select the corresponding file type.

Point Cloud Files

  • .XYZ
  • .TXT
  • .ASC
  • .VDA
  • .IGS
  • .IBL

Mesh Files

  • .NZIP
  • .NXM
  • .SCN
  • .3DS
  • .OBJ
  • .STL
  • .WRL
  • .PLY
  • .PLY2

Once open, the item in the feature tree should reflect the file type. To access the Mesh Prep Wizard, go to Tools > ScanTo3D > Mesh Prep Wizard.

Mesh Prep Wizard - Point Cloud Files

  • Welcome - Select Point Cloud to import. With the selection manager, choose the newly imported point cloud or if multiple clouds exist, choose the cloud you want to convert into a mesh
  • Point Cloud Orientation - If desired, you can re-orient the imported cloud to your desired co-ordinate system. The options are reflected below.
    • None
      • Uses the existing orientation for the mesh or point cloud.
    • Automatic
      • Positions the model using the centroid and principal axes of inertia. Optionally select a point for the origin under Origin Reference, or refine the angles around the axes using Translation and Rotation Parameters.
    • Selected References
      • Aligns the mesh or point cloud using your selections. Select a point as the origin under Origin Reference. Select any two other points to define two axes (X, Y, or Z) under Mesh Reference.
    • Numeric Input
      • Aligns the mesh or point cloud using numeric inputs to achieve a fine degree of control. Select a point as the origin under Origin Reference. Move the mesh or point cloud along the axes using Translation Parameters or rotate it using Rotation Parameters.
    • Parameters
      • Origin Reference – Select a point to use as the origin
      • Translational Parameters – Moves imported entities based on XYZ inputs
      • Rotational Parameters – Rotates imported entities about the referenced origin in the global X, Y and Z directions
      • Mesh Reference - Select points on the mesh or point cloud to establish the X axis, Y axis, and Z axis
  • Noise Removal - Removes outlier data from the data cloud point set
    • This slider will automatically remove outlier points. As you move the slider to the right, SOLIDWORKS will remove points that are not within a proportional distance to other points. The property tab will show the original points and the resulting points based on removal
  • Extraneous Data Removal - Removes extra data from the data cloud point set
    • While Noise removal will eliminate outlier locations, there may still be areas that are not wanted in the mesh. In this section, you can select points by region using the selection tools. Then, remove them from your imported data by deleting the selected areas. The result should resemble the desired structure.
      • Allow selection depth adjustment - Lets you set the selection depth of the mesh or point cloud feature to adjust the selected areas. The depth selection bounding box is based on your view into the model.
      • Trim mesh boundary to selection - Trims a mesh boundary exactly to the selection boundary, smoothing all serrated boundaries.
  • Simplification - Reduces the total number of points in the point cloud
    • There may be many points located in the area of a flat surface. You can simplify your point cloud data to reduce the size and of the resulting mesh by simplifying the model. You can do this at a global level where it will automatically remove points based off of a percentage or slider, or you can select a desired point cloud size and SOLIDWORKS will remove points accordingly to reach the desired size. Alternatively, you can simplify at a local level, selecting points and simplifying regions where the point density is too high.
      • If the software detects it could be a thin walled part, the Optimize Mesh with thin thickness option may be available as well. Select this if your part is a thin walled part.
  • Smoothing - Smooths the produced mesh
    • Smoothing the mesh can help rectify jagged or unrefined areas. You can smooth the entire mesh or only local regions.
      • Global Smoothness
        • Using the slider, applies a smoothness to the entire mesh
      • Local Smoothness
        • Using the slider, applies a smoothness to any area selected using the selection tools
        • Allow selection depth adjustment - Lets you set the selection depth of the mesh to smooth. The depth selection bounding box is based on your view into the model.
      • Boundary Smoothness
        • Smooths and relaxes any boundary of the mesh. Open edges can be smoothed using the slider
  • Fill Holes - Closes gaps in the mesh
    • SOLIDWORKS by default will locate and fill in every gap. These holes will be listed under the Holes to Fill selection box and the corresponding holes will, by default, have a green boundary surface in the model. 
    • If you do not want to fill certain holes, clear them from the list or select them in the graphics area to clear them. Filling holes is particularly important if you are extracting B-surfaces with the Face Identification Property Manager because you achieve better results. Unfilled holes will have a yellow boundary edge

After going through the Fill Holes, your mesh is complete. From here, you can automatically start the surface wizard or click the green check mark to complete your mesh.

Mesh Prep Wizard - Mesh Files

    • Welcome - Select Point Cloud to import. With the selection manager, choose the newly imported point cloud or if multiple clouds exist, choose the cloud you want to convert into a mesh
    • Mesh Orientation - If desired, you can re-orient the imported mesh to your desired co-ordinate system. The options are reflected below.
      • None
        • Uses the existing orientation for the mesh or point cloud.
      • Automatic
        • Positions the model using the centroid and principal axes of inertia. Optionally select a point for the origin under Origin Reference, or refine the angles around the axes using Translation and Rotation Parameters.
      • Selected References
        • Aligns the mesh or point cloud using your selections. Select a point as the origin under Origin Reference. Select any two other points to define two axes (X, Y, or Z) under Mesh Reference.
      • Numeric Input
        • Aligns the mesh or point cloud using numeric inputs to achieve a fine degree of control. Select a point as the origin under Origin Reference. Move the mesh or point cloud along the axes using Translation Parameters or rotate it using Rotation Parameters.
      • Parameters
        • Origin Reference – Select a point to use as the origin
        • Translational Parameters – Moves imported entities based on XYZ inputs
        • Rotational Parameters – Rotates imported entities about the referenced origin in the global X, Y and Z directions
        • Mesh Reference - Select points on the mesh or point cloud to establish the X axis, Y axis, and Z axis
    • Noise Removal - Removes outlier data from the data cloud point set
        • This slider will automatically remove outliers. As you move the slider to the right, SOLIDWORKS will remove mesh entities that are not within a proportional distance to the rest of the mesh. The property tab will show the original points and the resulting points based on removal
    • Extraneous Data Removal - Removes extra data from the data cloud point set
        • While Noise removal will eliminate outlier locations, there may still be areas that are not wanted in the mesh. In this section, you can select points by region using the selection tools. Then, remove them from your imported data by deleting the selected areas. The result should resemble the desired structure.
          • Allow selection depth adjustment - Lets you set the selection depth of the mesh or point cloud feature to adjust the selected areas. The depth selection bounding box is based on your view into the model.
          • Trim mesh boundary to selection - Trims a mesh boundary exactly to the selection boundary, smoothing all serrated boundaries.
        • Mesh Boundaries - Creates a boundary edge along the mesh boarder, most commonly on surface meshes or meshes that have large holes.
          • To create a boundary edge, the mesh edge must have only one triangle touching the edge for a given location
        • Simplification - Reduces the total number of meshed entities
          • There may be many areas that represent a simple surface where the mesh is overly dense. You can simplify your mesh to reduce the size and of the final mesh. You can do this at a global level where it will automatically simplify and relax mesh areas based off of a percentage or slider, or you can select a desired mesh size and SOLIDWORKS will remove points accordingly to reach the desired size. Alternatively, you can simplify at a local level, selecting local areas and simplifying regions where the mesh density is too high.
            • If the software detects it could be a thin walled part, the Optimize Mesh with thin thickness option may be available as well. Select this if your part is a thin walled part.
        • Smoothing - Smooths the produced mesh
          • Smoothing the mesh can help rectify jagged or unrefined areas. You can smooth the entire mesh or only local regions.
            • Global Smoothness
              • Using the slider, applies a smoothness to the entire mesh
            • Local Smoothness
              • Using the slider, applies a smoothness to any area selected using the selection tools
              • Allow selection depth adjustment - Lets you set the selection depth of the mesh to smooth. The depth selection bounding box is based on your view into the model.
            • Boundary Smoothness
              • Smooths and relaxes any boundary of the mesh. Open edges can be smoothed using the slider
        • Fill Holes - Closes gaps in the mesh
          • SOLIDWORKS by default will locate and fill in every gap. These holes will be listed under the Holes to Fill selection box and the corresponding holes will, by default, have a green boundary surface in the model. 
          • If you do not want to fill certain holes, clear them from the list or select them in the graphics area to clear them. Filling holes is particularly important if you are extracting B-surfaces with the Face Identification Property Manager because you achieve better results. Unfilled holes will have a yellow boundary edge

After going through the Fill Holes, your mesh is complete. From here, you can automatically start the surface wizard or click the green check mark to complete your mesh.

Was this article helpful?
0 out of 0 found this helpful
Have more questions? Submit a request

Comments