This article walks through the steps necessary to resolve the 'AddDTSFireWallRule' error, which can interfere with the installation or upgrade of SOLIDWORKS.
Cause
The error shown in the illustration above indicates that the installation process was unable to add an exception to the Windows Firewall for the SOLIDWORKS Task Scheduler, which allows processes and tasks to be scheduled for a later time. This error typically occurs when a Windows user profile does not have adequate permissions to make changes to the Windows Firewall.
Fixing the Problem
Because the SOLIDWORKS installation process is unable to add this Windows Firewall exception automatically, permissions will need to be manually updated before SOLIDWORKS is able to install.
If your Windows user profile does not have the permissions required to complete the steps listed below, please consult your IT department to make the necessary changes.
Solution
For the following process, the Windows Registry Editor will be utilized. It will be extremely important to not edit anything other than what is listed in the steps below.
1. Open the Windows Start menu, type 'regedit' into the Windows search field, right click on 'regedit.exe', and select 'Run as administrator'.
2. Navigate to HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\SharedAccess\Parameters\FirewallPolicy
3. Right click on 'FirewallPolicy' and select 'Permissions'.
4. Select the user profile that is attempting to install SOLIDWORKS, select the appropriate checkbox to allow full control, and click 'Apply'.
5. Perform steps 3 and 4 for the additional registry key: HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\SharedAccess\Defaults\FirewallPolicy
6. After performing steps 2 through 5, navigate to HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\SharedAccess\Epoch
7. Right click on 'Epoch', select 'Permissions', and then select 'Advanced'.
8. In the new window that appears, select the entry named 'MpsSvc', and click on the 'Edit' dialogue box.
9. Select the boxes found under 'Allow' for the 'Query Value' and 'Set Value' listings, and then select 'OK'.
10. Apply these settings in the previous 'Advanced Security Settings for Epoch' window, and exit the registry editor.
11. Restart the installation of SOLIDWORKS.
Performing these steps should allow the SOLIDWORKS installation process to make the required changes to the Windows Firewall. If these changes do not resolve the issue, please contact Hawk Ridge Systems Technical Support at: support@hawkridgesys.com
Comments
Please sign in to leave a comment.