Follow

Creating a Renamed Copy of an Assembly and its References in SOLIDWORKS

Sam Frew

It is possible to create a copy of an assembly in SOLIDWORKS with all of its referenced files and to somewhat automate the renaming of the files if desired. This article outlines two methods for doing so.

Firstly, open the assembly to be duplicated in SOLIDWORKS. In the example here, all the assembly files have “_v1” appended to their file names. The methods below will create a copy of the files with the file names updated to “_v2”. Note that the option under Tools > Options > System Options > External References > Update component names when documents are replaced should be enabled so that the updated file names will be used as the component names in the updated assembly.

 

Method 1: Save as Copy

1. Click File > Save As.

2. Browse to the location in which to save the copy of the assembly.

3. Select the option Save as copy and continue or Save as copy and open.

4. Enable the option Include all referenced components then click the Advanced button.

5. In the new dialogue, click the Name column header to highlight all the files.

6. Check that the specified folder is correct and that Save all as copy is enabled.

7. Click the Find/Replace button.

8. For Find what, type the text to be replaced (“v1”) and under Replace with, type the text to replace it (“v2”). Enable Match case.

9. Click Replace All then Close. All of the files names have updated.

10. Click Save All to complete the process.

 

Method 2: Pack and Go

1. Click File > Pack and Go.

2. Choose the directory to save to under Save to folder.

3. Click Select/Replace.

4. In the Search drop-down, select Save To Name and select the option Replace text with.

5. In the for field, type the text to be replaced (“v1”) and in the Replace text with field, type the text to replace it (“v2”). Disable Ignore case.

6. Click Replace All then Close. The file names will update in the Save To Name column.

7. Click Save to complete the process.

The renamed copy of the assembly resulting from the above methods is shown below. This can now be edited to create the second revision.

Was this article helpful?
0 out of 0 found this helpful
Have more questions? Submit a request

Comments

  • Avatar
    Alan Klenk

    Strangely, the first method did not allow me to find/replace my "rev.04" to "rev.05"; the second method DID end up working - hmmmm....