Follow

How do I add New Materials to the SOLIDWORKS’ Database?

Mina Bassalious

This article describes different methods you can use to add materials information for use in SolidWorks Simulation.

Method One: Adding custom materials by modifying an existing one

  1. In a part document, right-click Material in the FeatureManager design tree and select Edit Material.
  2.  In the material tree, select the material on which to base the custom material.
  3.  Right-click and select Copy or press Ctrl + C to copy the material to your paste buffer.
  4.  In the material tree, select a category in a custom library. You can use the Custom Materials library or a library you created.
  5. Right-click and select Paste or press Ctrl + V.
  6. Optionally, rename the material. Right-click the material and select Rename.
  7. Edit properties of the material, then click Save.

Method Two: Downloading Materials from the SolidWorks Web Portal

Note this option is only available to customers with subscription service and have a license of SolidWorks Simulation Professional or SolidWorks Simulation Premium. The SolidWorks Web Portal is hosted by Matereality LLC.

 

  1. In the Material dialog box, select the option on the lower left side: Click here to access more materials using the SolidWorks Materials Web Portal.
  2. Select the settings for Select Study, Select Material Model, and Select Type of Materials.
  3. Click Locate Materials.
  4. Hover the mouse over a specific material node to view information about its data source and material properties. Click the node to activate the material.
  5. Click the Download button at the top left side. When prompted to open or save the material database (*.sldmat), click Save.
  6. Note the folder location where the material database is stored.
  7. In the SolidWorks Material dialog box, click Open. Browse to the folder location of the material database to open the file (*.sldmat).

Note: You specify the default location of the SolidWorks Materials Web Portal database at Tools >Options > System Options > File Locations. Select Material Databases for Show folders for. All subsequent material downloads are stored under the Matereality Materials folder, in the appropriate subfolder (Rubber, Plastic, or Metal).

     8. Click Apply and then Close

Was this article helpful?
0 out of 0 found this helpful
Have more questions? Submit a request

Comments