Follow

SOLIDWORKS File References - resolving incorrect references.

Patrick James

This article describes techniques to resolving incorrect references in SOLIDWORKS

Note: This document was written for SOLIDWORKS 2015. These techniques may be applied to previous versions of the software.

When a document has referenced files of many revisions saved in different file locations, mismatches may occur. Which files SOLIDWORKS opens as references is not random. You can see which file is being accessed in your assembly, drawing or part by going to File> Find References.

If one of these files is being pulled from the “wrong” location, you may consult the SOLIDWORKS search routine to find which step is causing this file to be opened:

http://help.solidworks.com/2015/English/SolidWorks/sldworks/c_Search_Routine_for_Referenced_Documents.htm

 

Tips to prevent file reference mismatch:

  1. Use unique names for all SOLIDWORKS files.

This applies to files of the same extension. You may have a part, drawing, assembly, pdf and word document all of the same name, but not 2 part documents of the same name. If there is not a duplicate file name for your part files, there is no chance that the wrong file will be used.

  1. Use a PDM solution.

SOLIDWORKS offers 2 Product Data Management solutions, Workgroup PDM and Enterprise PDM. Workgroup PDM users have a “working” folder where local copies of checked out files are stored to be viewed or modified. In this case as long as there are no other locations (most commonly on shared drives or test folders) that have files of the same name, the correct file will be referenced.

With EPDM, the same practice of unique filenames and no alternate locations of files should be used. Here the “working folder” is taken out of the equation and handled in the background of the program. The best practice here is to only work inside the vault and not save to separate shared drives or working folders.

  1. Use a referenced documents search path.

If alternate save locations must be used, adding a referenced documents search path may solve any referencing issues. This options is found in Tools> Options> System Options> File Locations> Referenced Documents. When you have a working folder where you want all of your files to open from and also alternate save locations use this reference documents search path. If you add the working folder into this referenced documents path, as long as other documents of the same name are not open in memory, this directory will be searched first for reference files.

 

Tips to restore an incorrectly referenced document

  1. Open the correct referenced file(s) in SOLIDWORKS before opening the assembly or drawing file.

If you recall, the first part of the SOLIDWORKS search routine is “any open document with the same name”. We can force SOLIDWORKS to use the correct file if it is already opened.

  1. If option 1 is impractical (too many files out of reference) add a search path to the correct directory (step 3 of preventing mismatch).
  2. You may change the reference path for the assembly or drawing one by one in the open dialogue:
    1. In SOLIDWORKS go to File> Open, browse to the assembly or drawing in question and select it (do not open yet).
    2. Click “References”.
    3. Double click on the part with the incorrect reference path, browse to the correct file and click “open”.
    4. Click OK and Open to open the newly referenced file.

**With all of these techniques, once the file has been restored, rebuild with CTRL+Q and then save the document.**

 

If you have any further questions about these steps or if these steps do not resolve the issue, feel free to call Hawk Ridge Systems Technical Support at 877.266.4469 (US) or 866.587.6803 (Canada) or email us at support@hawkridgesys.com.

Was this article helpful?
0 out of 1 found this helpful
Have more questions? Submit a request

Comments