Follow

SolidWorks Hidden Commands - These ARE the Commands You're Looking For

Ricky Huynh

By Holly Cheek

When I began using SolidWorks every day at work, I started picking up all of these extremely useful hidden commands. Then I started to wonder: What other, less obvious SolidWorks hidden commands were out there, and could I be using them to save time and accomplish my different tasks?

Listed below are some of the most useful SolidWorks hidden commands that I've come across.

1.       Feature Manager Design Tree Commands

[Ctrl+T] flattens out those features: When creating a new feature, the sketch gets absorbed into the feature. To pull that back out, you can use this command to toggle to an expanded tree view.     

   SolidWorks Hidden Commands - Flatten out features

[Shift+C] collapses the tree: Often I have been lost in my FeatureManager Design Tree, having to click through and minimize each feature. This useful command collapses everything all at once.

2.       The [A] key when using the line sketch entity

When sketching with the line tool, you can simply hit the [A] key on your keyboard and it will switch entities from line to arc for you. You can also swipe your cursor over the end sketch point of the line you just created. To switch back to the line tool, just hit the [A] key again. Note: This only works if you use the click-click method of creating a line, where you click at each line endpoint.  

 SolidWorks Hidden Commands - A key

3.       Virtual Sharp

To create an intersection point, or a “virtual sharp”, hold down [Ctrl] and select two non-parallel lines, then click on the Point entity in the Sketch tab in the CommandManager.  A constrained sketch point will be created at the point where the two lines would meet. Note: The symbol for the point can be controlled in Tools->Options->Document Properties->Virtual Sharps. .

 SolidWorks Hidden Commands - Virtual Sharp

4.       Adjusting Dimensions: [Ctrl + Mouse Wheel]

After double clicking on a dimension to activate modify, you can hold [Ctrl] and rotate the mouse wheel to adjust by 10x the defined increment (default: +/- 1.0in or 100mm). [Alt + Mouse Wheel]: After double clicking on a dimension to activate modify, you can hold [Alt] and rotate the mouse wheel to adjust by 0.1x the defined increment (default: +/- 0.01in or 1mm). To define increments:  Go to Tools->Options->System Options->Spin Box Increments

5.       Create Offset Plane with the [Ctrl] key

You can use an existing plane to create an offset from it. Just show the plane in the graphics area, hold [Ctrl] down and left mouse select the shown plane, and drag in the direction you want the plane to go. Then release the [Ctrl] key and the left mouse button to define the exact distance to offset. Note: To help you remember this one, just think of it as making a “copy” of the existing plane, since any time you [Ctrl-drag] something in the Windows environment you make a copy of it.

6.       Dimension Palette

When the Dim Palette vanishes if you move your cursor too fast, no worries, just hit [Ctrl] on your keyboard to get it back!

SolidWorks Hidden Commands - Dimension Palette

7.       Bringing back the Context Toolbar during a Multiple Select

You can also bring back these other toolbars that like to vanish by hitting the [Ctrl] key. The Context Toolbar is the pop-up that appears at your cursor once items are selected. Note: To get it back, your cursor does need to be approximately in the same location as where the Context Toolbar appeared on your screen.

 SolidWorks Hidden Commands - Context Toolbar

8.       Use the right mouse button (RMB) to remove more faces when using Select Other

If the face you want to select is 3 or more faces into the part, you can use select other and just RMB on additional faces until you reach the face that you wish to select.

9.       Hold [Shift] to select transparent faces

By default SolidWorks lets you select through the transparent face, not on the transparent face.If you want to select the transparent face, you can just hold [Shift] (instead of having to change the transparency). You can also choose to never select through transparent faces if desired (Tools->Options->System Options->Display/Selection->Enable selection through transparency: should be unchecked).

10.   Normal to and rotate

Select the face you want to be normal to, [Ctrl+click] the other face you wish to be facing 'up' in the view, then select Normal To. This is one of the most buried commands that most people are unaware of! Hope these few commands are useful to you! Have you found any SolidWorks hidden commands that aren't on this list? Feel free to post them in the comments below.

Was this article helpful?
0 out of 0 found this helpful
Have more questions? Submit a request

Comments