Follow

Starting SOLIDWORKS in RX Safe Modes

James Christiansen-Salameh

This article explains how to start SOLIDWORKS in the Safe Modes  

The Safe Modes are beneficial in identifying the cause of unexpected behavior in SOLIDWORKS.   

Starting in the Safe Modes 

  1. Close SOLIDWORKS
  2. Go to Start>Programs>SOLIDWORKS Tools 20XX>SOLIDWORKS RX 20XX



  3. At the bottom of the 'Home' Tab, you should see a section titled 'SOLIDWORKS Safe Modes'
  4. Click 'Click here to launch SOLIDWORKS in Software OpenGL mode' or 'Click here to launch SOLIDWORKS while bypassing the Tools/Options settings' to launch SOLIDWORKS in the respective Safe Modes.

A Safe Mode will only apply for the duration of one session.  If SOLIDWORKS is closed after starting in a Safe Mode and reopened normally, it will no longer be in the Safe Mode.

'Click here to launch SOLIDWORKS in Software OpenGL mode'

Software Open GL mode is used to determine whether the graphics card/driver is the cause of an issue. This disables the graphics adapter hardware accelerator, and enables graphics rendering using only software. Essentially, the graphics card/driver is bypassed.  RealView graphics will not work in Software OpenGL.

If an issue no longer occurs in Software OpenGL, check that your card is supported and on the most recent supported driver here.

If the problem persists with a supported card on the correct driver, try launching in the other Safe Mode or contact technical support. 

Note: If you would like to use SOLIDWORKS in Software OpenGL mode for longer than one session, you can permanently enable it by checking 'Use Software OpenGL' in Tools>Options>System Options>Performance.  

'Click here to launch SOLIDWORKS while bypassing the Tools/Options settings'

This option will launch SOLIDWORKS with the default settings.  This includes toolbars and system options.  If unexpected behavior is resolved in this safe mode, it generally means one of two things.  

It is likely that a setting you changed from default causes the behavior you are seeing.  You should compare your settings to the default settings and identify discrepancies.  

The other possibility is that your settings are corrupt. SOLIDWORKS settings are stored in the registry, which can become corrupt for various reasons.  In this case, you should perform a SOLIDWORKS registry reset to permanently restore settings to default, or contact technical support.    

 

Was this article helpful?
6 out of 6 found this helpful
Have more questions? Submit a request

Comments