Follow

Enabling SOLIDWORKS 3D Interconnect

James Christiansen-Salameh

This article walks through the process to enable 3D Interconnect

SOLIDWORKS 3D Interconnect is a valuable new functionality in SOLIDWORKS 2017, available as Beta functionality up to SP1, with the formal release coming in SP2.  3D Interconnect replaces SOLIDWORKS current translation capabilities with new technology and workflows for working with third-party native CAD data in SOLIDWORKS 2017, without converting to a SOLIDWORKS file format.

 

To enable 3D Interconnect:

  1. Navigate to Tools>Options>System Options>Import
  2. In the 'File Format' drop down menu, select Inventor/Catia V5/Creo/NX/Solid Edge
  3. Check the box labeled 'Enable 3D Interconnect'
  4. Select OK to save and exit the Options Menu

 

 

3D Interconnect is now enabled and ready for use.  Refer to this section of the SOLIDWORKS help document for information on inserting, opening, and editing third party native CAD files in SOLIDWORKS with 3D Interconnect:

Solidworks 3D Interconnect

 

 

 

Was this article helpful?
0 out of 0 found this helpful
Have more questions? Submit a request

Comments