Follow

New in SOLIDWORKS 2017: Edit All File Locations

James Christiansen-Salameh

This article goes over accessing and utilizing the 'Edit All File Locations' option that is new to SOLIDWORKS 2017.  

Most frequent SOLIDWORKS users are familiar with the file locations menu in system options (Tools>Options>System Options>File Locations). The file locations menu allows a user to specify the folders that SOLIDWORKS searches for different types of documents. For example, a user creates a new part template and saves it to a folder on their computer. SOLIDWORKS will not know to look in this location for part templates until this folder is added in the 'Document Templates' section of File Locations.

In SOLIDWORKS 2016 and earlier, the file locations interface has a 'show folders for' drop-down menu, which can be used to individually view the file locations for each category. Add and Delete buttons are used to edit the listings. For editing a single category file location, this works just fine.

 

However, things get a bit tedious and time-consuming when a user wants to view and change several file locations. The new 'Edit All File Locations' menu allows users to easily view and edit all file locations in one window. The menu also includes a find/replace feature in which a user can enter a phrase, locate all paths with this phrase, and replace the phrase with a new one. This is especially useful for the situation many users encounter after importing file location settings from a previous version of SOLIDWORKS. The import results in lots of categories pointing to the default file location of the previous version, which may no longer exist or contains files that are not compatible with the new version.  The Using Find/Replace section of this article walks through an example in which all paths containing the phrase 'SOLIDWORKS Corp 2015' are are replaced with the phrase 'SOLIDWORKS Corp 2017'.

 

 

Accessing the 'Edit All File Locations' Menu

To access the the file locations menu, open SOLIDWORKS and go to Tools>Options>System Options>File locations. In 2017, just as in previous versions, the 'show folders for' drop-down menu can still be used to individually view and edit file locations. If you look in the upper right hand corner, you will notice there is a new button labeled 'Edit All'.

 

 

Selecting 'Edit All' will open up a new window, which displays a table with file location, current path, and new path. When you first open the menu, all listings in new path will match the listing in current path.

 

 

Changing Individual Paths

To individually change a path, simply double click the listing in the new path column. Another window will open in which you can browse to the new location.

 

 

When you have browsed to the new location click the 'Select Folder' button and the select folder window will close. The path you chose will display in the new path column, shown in green text to indicate that the new path no longer matches the current path.

 

 

At this point you can press Save to update the current paths to the new paths, or cancel to exit without updating any paths.

 

Using Find/Replace

Double clicking to browse to a new path is useful in cases where paths need to be edited individually. But what about a situation similar to the one described earlier, where a user wants to perform a batch operation to update several paths at once? This is when the Find/Replace option comes in handy. For this example, take a look at the current file paths.

 

 

We can see that although this is a 2017 Installation, quite a few paths are pointing to the 'SOLIDWORKS Corp 2015' folder. We want to change all these locations to point to the same path, but in the 'SOLIDWORKS Corp 2017' folder. We could individually edit each path by double clicking and browsing to the new path, but the find/replace option is much more efficient in this case. Selecting 'Find/Replace' opens a sub-menu with text entry field for 'find' and 'replace'.

 

 

If we enter 'SOLIDWORKS Corp 2015' into the 'Find' entry field and repeatedly select 'Find Next', SOLIDWORKS will go down the list from top to bottom, highlighting paths containing the text 'SOLIDWORKS Corp 2015'.

 

 

Now let's enter 'SOLIDWORKS Corp 2017' into the Replace entry field. If we select Replace, 'SOLIDWORKS Corp 2015' will be replaced with 'SOLIDWORKS Corp 2017' in the currently highlighted path. If we select 'Replace All', all paths containing 'SOLIDWORKS Corp 2015' will be replaced with 'SOLIDWORKS Corp 2017'.

 

 

Now all we have to do is close out of the Find and Replace dialogue, select 'Save' in the edit all file locations menu, and select 'OK' to exit System Options.  The changes made to the file locations are now saved.  

Was this article helpful?
0 out of 0 found this helpful
Have more questions? Submit a request

Comments