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SOLIDWORKS PCB 2021 Client-Server  

Installation Guide  

  

 

This guide gives instructions for installing SOLIDWORKS PCB 2021. It is written for client-server 

installations of SOLIDWORKS PCB 2021. In this configuration, SOLIDWORKS PCB Services (or Altium 

Vault) is installed on a server system, and SOLIDWORKS PCB is installed on client systems. This is a 

shared configuration where a server computer hosts SOLIDWORKS PCB Services (or Altium Vault) data, 

while client computers run either SOLIDWORKS PCB, SOLIDWORKS PCB Connector and/or the 

SOLIDWORKS PCB Add-In. Please contact Hawk Ridge Systems Technical Support if you are unsure of 

your SOLIDWORKS PCB configuration type.  

SOLIDWORKS PCB 2021 uses the same installation manager as other SOLIDWORKS products, including 

the 3D CAD software. If upgrading other SOLIDWORKS products, along with SOLIDWORKS PCB 2021, 

please also refer to their upgrade guides for further instructions.  

This is not a troubleshooting guide. If you have any technical issues with SOLIDWORKS PCB, please 

contact Hawk Ridge Systems technical support. This document is only to be distributed and used by 

Hawk Ridge Systems customers. Any other use is prohibited. 
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ABSTRACT: This guide gives instructions for installing SOLIDWORKS PCB 2021.  
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Product Information  

SOLIDWORKS PCB is a PCB design tool that integrates with SOLIDWORKS 3D to allow collaboration 

between electrical and mechanical designers. Changes to a PCB design can be made in either 

SOLIDWORKS PCB or SOLIDWORKS 3D then synchronized between the two programs.  

 SOLIDWORKS PCB Connector is also available. This product enables SOLIDWORKS 3D integration with 

Altium Designer. Here the PCB design tools are provided by Altium Designer, while the 3D collaboration 

tools are provided by SOLIDWORKS PCB Connector. Note that sales and support for Altium Designer are 

not provided by Hawk Ridge Systems or SOLIDWORKS.  

 Refer to www.solidworkspcb.com for more information. 

Licensing  

SOLIDWORKS PCB 2021 can be used with standalone and network licenses. Note that the license type 

can differ from the installation configuration type, which can be standalone or client-server. The license 

type can be standalone or network (this guide is for the client-server configuration). Either license type 

can be used with either configuration type.  

If you have a standalone license, you will need to activate SOLIDWORKS PCB 2021 after installing. You 

will be automatically prompted to do this when launching the application after an upgrade. Refer to our 

guide titled 2021 Product Activation for more information on activation methods. If you are moving your 

SOLIDWORKS PCB 2021 installation to a new computer, you will need to transfer your license activation 

off the old computer before activating on the new one. Refer to the Appendix for instructions on 

transferring your SOLIDWORKS PCB standalone license.  
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If you have a network license, the SolidNetwork License Manager on the license server computer needs 

to be of a version at or above the version of SOLIDWORKS PCB 2021 that you are installing. If this is not 

already the case, refer to our guide titled 2021 Network Server Installation to install and activate the 

SolidNetwork License Manager. 

Configuration Requirements  

If you are installing SOLIDWORKS PCB 2021 and are looking to take advantage of 3D imaging and data 

transfer, you must either install SOLIDWORKS 3D along with SOLIDWORKS PCB 2021 or have 

SOLIDWORKS 3D previously installed on a given computer. It is recommended that SOLIDWORKS 3D and 

SOLIDWORKS PCB be of the same version and service pack, however it is not required.  See the 

compatibility matrix below. 
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Program Components  

If you have purchased SOLIDWORKS PCB, you will need to install:  

• SOLIDWORKS PCB 

• SOLIDWORKS PCB Services (or Altium Vault)  

If you have purchased SOLIDWORKS PCB Connector, you will need to install:  

• SOLIDWORKS PCB Connector 

• SOLIDWORKS PCB Services (or Altium Vault)  

Refer to the table below for more information on the four primary program components.  

Program Component  Description  Typical Installation Location  

SOLIDWORKS PCB  

Services  

Service that enables communication and 

collaboration between the SOLIDWORKS 

PCB and SOLIDWORKS 3D programs  

Server computer accessible to 

all user computers  

SOLIDWORKS PCB  Standalone PCB design program typically 

used by an electrical designer  

ECAD user computer  

SOLIDWORKS PCB  

Connector  

Extension for Altium Designer to allow it to 

connect to SOLIDWORKS PCB Services (or 

Altium Vault), enabling 3D integration  

ECAD user computer running 

Altium Designer  

SOLIDWORKS PCB  

Add-In  

Add-in for SOLIDWORKS 3D (typically 

used by a mechanical designer), allowing 

it to connect to SOLIDWORKS PCB 

Services (or Altium Vault) and push 

changes back to SOLIDWORKS PCB  

MCAD user computer running 

SOLIDWORKS 3D  
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Installation Type  

SOLIDWORKS PCB can be installed in a shared or local configuration.  

In a shared configuration, SOLIDWORKS PCB Services (or Altium Vault) is installed on a server computer 

or another computer that is accessible over the network to all the user computers. The user computers 

run either SOLIDWORKS PCB, PCB Connector or the SOLIDWORKS PCB Add-In. These components all 

connect to SOLIDWORKS PCB Services (or Altium Vault) over the network. This is illustrated in the image 

above.  

Before Installation  

Hawk Ridge Systems highly recommends taking a moment before installing SOLIDWORKS and ensuring 

you are ready to load your new software. First, check the following links to ensure minimum system 

requirements and the video card compatibility is met. Also, confirm that the hard drive has enough space 

to have at least 15% free space, after the full installation. Back-up data such as any shared Toolbox 

library, Design Library, Template files, or a data management vault. As always, verify workmates, 

customers, or vendors are all on the same version of SOLIDWORKS. SOLIDWORKS cannot open files 

from newer versions. 

Hawk Ridge Systems also highly recommends ensuring the following TCP ports are open between 

SOLIDWORKS PCB client systems and the SOLIDWORKS PCB Services (or Altium Vault) server system: 

9780 – HTTP port 

9785 – HTTPS port 

3690 – SVN port 

4649 – WebSocket port 
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Installing SOLIDWORKS PCB Services  

This section installs the SOLIDWORKS PCB Services program.  

1. Select Server Products on the Welcome screen and navigate to SOLIDWORKS PCB Services  

2. Check the box next to SOLIDWORKS PCB Services and click Next.  
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3. Specify the installation location, database folder, revisions file folder, and port number by selecting 

CHANGE, next to PCB Options on the Summary Page, for custom settings.  Click Back to Summary 

when finished. We recommend keeping the default values for all options here. 
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4. CHANGE or accept the default(s), shown in the screenshots below, then click Download and Install. 

 

5. Open a browser and go to the URL http://machinename:9780, where machinename is the name of 

the computer running SOLIDWORKS PCB Services and 9780 is the port used at step 3 above (e.g. 

http://server01:9780). Note that machinename can be specified as localhost if you are connecting to 

SOLIDWORKS PCB Services from the same computer on which it is installed. We suggest 

bookmarking this page for easy access to the SOLIDWORKS PCB Services interface.  

6. Log in with the user name admin and password admin.  

 

http://www.hawkridgesys.com/


   

www.hawkridgesys.com USA: 1.877.266.4469  CANADA: 1.866.587.6803 

7. Click on USERS > Add User, then use the form to enter information for a new user. Repeat this for all 

the users that will be connecting to SOLIDWORKS PCB Services.  Note that users can be added to 

roles and new roles can be created. Roles can then be used to control user permissions to 

SOLIDWORKS PCB data.  

 

8. After adding all users, click on the VCS tab to show the DefaultRepository. Click on the Share button 

to bring up the Manage Permissions dialog. Add users or roles to the repository to give the users 

added at step 7 access to this repository. Note that you can create multiple repositories with different 

users having different permissions to each.  

 

http://www.hawkridgesys.com/
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9. Click Sign Out when finished.  

10. Note that all user computers will need to be able to communicate with SOLIDWORKS PCB Services 

over the network on the port specified at step 3. Add exceptions to all firewalls or security programs 

that might affect this communication.  

SOLIDWORKS PCB Client Installation  

REMINDER: If upgrading from a previous version of SOLIDWORKS PCB, we strongly recommend backing 

up data before proceeding.  

1. Make sure you are logged in as the administrator. 

2. Disable all anti-virus and anti-spyware tools and turn off Windows User Account Control.  

3. Locate your SOLIDWORKS 2021 installation media (DVD or download) and launch the setup 

application (setup.exe). You should see the Welcome screen for the SOLIDWORKS Installation 

Manager. Select Individual (on this computer) and click Next.  
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4. You will then see the Serial Number screen where you can enter your serial number for your 

SOLIDWORKS PCB installation. Note that you do not need to enter multiple serial numbers if your 

SOLIDWORKS serial number is the same as your SOLIDWORKS PCB serial number. Click Next.  

 

5. The SOLIDWORKS Installation Manager will verify your serial number and perform an automatic 

system check for any existing versions of SOLIDWORKS or SOLIDWORKS PCB. Take note of any 

messages or warnings during this step.  
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6. At the Summary screen, you can change the settings and options defined for the installation. To do 

so, click CHANGE on the right side of each option. 

 

7. Click CHANGE next to Products to go to the Product Selection screen. Scroll down and ensure that 

SOLIDWORKS PCB is checked ON. Nested here are the individual SOLIDWORKS products. Click Back 

to Summary when finished.  

 

http://www.hawkridgesys.com/
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8. In the Download Options, we recommend disabling the Background Downloader, as it is known to 

cause issues with upgrades. Click CHANGE next to Download Options, then deselect Use the 

background downloader. Click Back to Summary when finished.  

9. Confirm that all the information on the Summary screen is correct. Accept the license agreement then 

click Download and Install to begin the installation.  
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When the installation is complete, you will be asked to join the SOLIDWORKS Customer Experience 

Improvement Program. We recommend joining this, as it provides software performance information to 

SOLIDWORKS and enables the use of the CAD Admin Dashboard through the Customer Portal. The 

information this sends to SOLIDWORKS is treated confidentially and does not result in the transfer of any 

file information. After making the selection, click the Finish button to complete the installation. 

 

10. When the software is launched for the first time after installation, you may need to activate the 

license (if using standalone licensing). Follow the prompts to complete this. You will also be 

prompted to accept the license agreement. 

11. When running SOLIDWORKS PCB for the first time, you may be prompted to allow SOLIDWORKS PCB 

through the firewall. Allow it, if so. 
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12. At the SOLIDWORKS PCB Start screen, click File > Sign in SOLIDWORKS PCB Services (or Altium 

Vault), or click Start a New PCB Project.  

 

In the sign in dialog, for Server Address, enter the name of the computer running SOLIDWORKS PCB 

Services (or Altium Vault) and the port number in the format machinename:9780. Note that 

machinename can be specified as localhost if SOLIDWORKS PCB Services (or Altium Vault) is installed on 

the same computer as SOLIDWORKS PCB (i.e. when using a local configuration). Also enter your 

Username and Password, as specified at step 6 of the SOLIDWORKS PCB Services (or Altium Vault) 

installation (section 2). Click Login to start using SOLIDWORKS PCB. 
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Appendix: License Transfer  

You are allowed one activation per standalone license, for your business computer and for your home 

computer. As part of the license agreement, you may not use both simultaneously.  

Each activation transaction is coded to the hardware of your computer. If you are moving your 

SOLIDWORKS PCB installation to a new computer, you will need to transfer your license activation 

before activating on the new computer. You should also do this before reformatting or replacing your 

hard drive or operating system. If your SOLIDWORKS PCB license is tied to your main SOLIDWORKS 

license (i.e. they are the same number), please see our guide titled 2021 Product Activation for the 

transfer process.  

This process is not required for a new installation. If your computer does not have internet access, refer 

to the E-mail Transfer section of this document.  

Online Transfer  

1. Go to Start > All Programs > SOLIDWORKS 2021 > SOLIDWORKS PCB.  

2. Once SOLIDWORKS PCB launches, click on the File tab and choose Help>Deactivate 

Licenses…  
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3. Choose to transfer Automatically over the Internet and click Next.  

 

4. The software will connect to the SOLIDWORKS activation servers and you will be informed when 

the license has been successfully transferred.  

 

5. Press the Finish button to complete the process.  

Note: SOLIDWORKS PCB will no longer run on this machine unless it is re-activated.  

E-mail Transfer  

1. Go to Start > All Programs > SOLIDWORKS 2021 > SOLIDWORKS PCB.  

2. Once SOLIDWORKS PCB launches, click on the File tab and choose Help>Deactivate 

Licenses…  
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3. Choose to activate Manually via e-mail and click Next.  

4. On the next page, press the Save button to create an activation request file.  

Note: Once you have saved this file, your activation is disabled. Do not exit the activation 

window until you have read in the response file from SOLIDWORKS and completed the 

process or you will not be able to run SOLIDWORKS PCB to complete the transfer.  

5. Browse to a location on your computer to store this .txt file and press the Save button. Copy this .txt 

file onto a removable storage device and move it to a machine with internet access.  

6. E-mail this file as an attachment to activation@solidworks.com.  

7. SOLIDWORKS will send a return e-mail with a different .txt file attached. Save this file to a 

removable storage device and move it to the machine awaiting the activation transfer.  

8. In the activation wizard, press the Open button on the e-mail activation page.  

9. Browse to the response file and press the Open button.  

10. The next page will show you that your transfer is complete.  

11. Press the Finish button to complete the process.  

Note: SOLIDWORKS PCB will no longer run on this machine unless it is re-activated.  
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