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SOLIDWORKS PCB Connector 2020 

Installation Guide  

 

 

This guide gives instructions for installing SOLIDWORKS PCB Connector 2020. SOLIDWORKS PCB 

Connector works alongside Altium Designer to facilitate the ECAD-to-MCAD collaboration process. 

SOLIDWORKS PCB Connector can be used in either a standalone or client-server installation 

configuration.  Please contact Hawk Ridge Systems Technical Support if you are unsure of your 

SOLIDWORKS PCB configuration type.  

This is not a troubleshooting guide. If you have any technical issues with SolidWorks, please contact 

Hawk Ridge Systems technical support. This document is only to be distributed and used by Hawk Ridge 

Systems customers. Any other use is prohibited. 
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Product Information  

SOLIDWORKS PCB Connector is a tool that integrates Altium Designer with SOLIDWORKS 3D to allow 

collaboration between electrical and mechanical designers. Changes to a PCB design can be made in 

either Altium Designer or SOLIDWORKS 3D then synchronized between the two programs, via the 

SOLIDWORKS PCB Connector.  

When using SOLIDWORKS PCB Connector, the PCB design tools are provided by Altium Designer, while 

the 3D collaboration tools are provided by SOLIDWORKS 3D. Note that sales and support for Altium 

Designer are not provided by Hawk Ridge Systems or SOLIDWORKS.  

 Refer to www.solidworkspcb.com for more information. 

Licensing  

SOLIDWORKS PCB 2020 can be used with standalone and network licenses. Note that the license type 

differs from the installation configuration type, which can be standalone or shared. The license type can 

be standalone or client-server (this guide is for the standalone configuration). Either license type can be 

used with either configuration type.  

If you have a standalone license, you will need to activate SOLIDWORKS PCB 2020 after installing. You 

will be automatically prompted to do this when launching the application after an upgrade. Refer to our 

guide titled 2020 Product Activation for more information on activation methods. If you are moving your 

SOLIDWORKS PCB 2020 installation to a new computer, you will need to transfer your license activation 

off the old computer before activating on the new one. Refer to the Appendix for instructions on 

transferring your SOLIDWORKS PCB standalone license.  

If you have a network license, the SolidNetwork License Manager on the license server computer needs 

to be of a version at or above the version of SOLIDWORKS PCB 2020 that you are installing. If this is not 

http://www.solidworkspcb.com/
http://www.solidworkspcb.com/
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already the case, refer to our guide titled 2020 Network Server Installation to install and activate the 

SolidNetwork License Manager.  

Configuration Requirements  

If you are installing SOLIDWORKS PCB 2020, and are looking to take advantage of 3D imaging and data 

transfer, you must either install SOLIDWORKS 3D along with SOLIDWORKS PCB 2020 or have 

SOLIDWORKS 3D previously installed on your computer. It is recommended that SOLIDWORKS 3D and 

SOLIDWORKS PCB be of the same version and service pack, however it is not required. See the 

compatibility matrix below. 

 

Program Components  

For SOLIDWORKS PCB Connector, you will need to install (in addition to Altium Designer):  

• SOLIDWORKS PCB Connector  

• SOLIDWORKS PCB Services  
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Refer to the table below for more information on the four program components.  

Program Component  Description  Typical Installation Location  

SOLIDWORKS PCB  

Services  

Service that enables communication and 

collaboration between the SOLIDWORKS 

PCB and SOLIDWORKS 3D programs  

Server computer accessible to all 

user computers  

SOLIDWORKS PCB  Standalone PCB design program typically 

used by an electrical designer  

ECAD user computer  

SOLIDWORKS PCB  

Connector  

Extension for Altium Designer to allow it 

to connect to SOLIDWORKS PCB 

Services, enabling 3D integration  

ECAD user computer running 

Altium Designer  

SOLIDWORKS PCB  

Add-In  

Add-in for SOLIDWORKS 3D (typically 

used by a mechanical designer), 

allowing it to connect to SOLIDWORKS 

PCB Services and push changes back to 

SOLIDWORKS PCB  

MCAD user computer running 

SOLIDWORKS 3D  

 

 

Installation Types  

SOLIDWORKS PCB Connector can be installed in a shared or local configuration.  

In a shared configuration, SOLIDWORKS PCB Services is installed on a server computer or another 

computer that is accessible over the network to all the user computers. The user computers run either 

Altium Designer with the PCB Connector or the SOLIDWORKS PCB Add-In. These components all connect 

to SOLIDWORKS PCB Services over the network. This is illustrated in the image above.  

In a local configuration, SOLIDWORKS PCB Services is installed on the same computer as the design tools 

(Altium Designer and SOLIDWORKS PCB Connector). This would typically be used if one user works 

independently on the electrical and mechanical PCB design aspects, without collaboration.  
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Before Installation 

Hawk Ridge Systems highly recommends taking a moment before installing SOLIDWORKS and ensuring 

you are ready to load your new software. First, check the following links to ensure minimum system 

requirements and the video card compatibility is met. Also, confirm that the hard drive has enough space 

to have at least 15% free space, after the full installation. Back-up data such as any shared Toolbox 

library, Design Library, Template files, or a data management vault. As always, verify workmates, 

customers, or vendors are all on the same version of SOLIDWORKS. SOLIDWORKS cannot open files 

from newer versions. 

Hawk Ridge Systems also highly recommends ensuring the following TCP ports are open between 

SOLIDWORKS PCB client systems and the SOLIDWORKS PCB Services (or Altium Vault) server system: 

9780 – HTTP port 

9785 – HTTPS port 

3690 – SVN port 

4649 – WebSocket port 

 

Installing SOLIDWORKS PCB Services  

This section installs the SOLIDWORKS PCB Services program.  

1. Select Server Products on the Welcome screen and navigate to SOLIDWORKS PCB Services  

2. Check the box next to SOLIDWORKS PCB Services and click Next.  

 

http://www.solidworks.com/sw/support/SystemRequirements.html
http://www.solidworks.com/sw/support/SystemRequirements.html
http://www.solidworks.com/sw/support/videocardtesting.html
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3. Specify the installation location, database folder, revisions file folder, and port number by selecting 

CHANGE, next to PCB Options on the Summary Page, for custom settings. Click Back to Summary 

when finished. We recommend keeping the default values for all options here. 

4. CHANGE or accept the default(s), shown in the screenshots below, then click Download and Install.  
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5. Open a browser and go to the URL http://machinename:9780, where machinename is the name of 

the computer running SOLIDWORKS PCB Services and 9780 is the port used at step 3 above (e.g. 

http://server01:9780). Note that machinename can be specified as localhost if you are connecting to 

SOLIDWORKS PCB Services from the same computer on which it is installed. We suggest 

bookmarking this page for easy access to the SOLIDWORKS PCB Services interface.  

6. Log in with the user name admin and password admin.  

 

7. Click on USERS > Add User, then use the form to enter information for a new user. Repeat this for all 

the users that will be connecting to SOLIDWORKS PCB Services.  Note that users can be added to 

roles and new roles can be created. Roles can then be used to control user permissions to 

SOLIDWORKS PCB data.  

 

8. After adding all users, click on the VCS tab to show the DefaultRepository. Click on the Share button 

to bring up the Manage Permissions dialog. Add users or roles to the repository to give the users 
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added at step 7 access to this repository. Note that you can create multiple repositories with different 

users having different permissions to each.  

 

9. Click Sign Out when finished.  

10. Note that all user computers will need to be able to communicate with SOLIDWORKS PCB Services 

over the network on the port specified at step 3. Add exceptions to all firewalls or security programs 

that might affect this communication. 

Installing SOLIDWORKS PCB Connector  

1. Sign into your Altium Account if you are not signed in automatically.  

2. Launch Altium Designer, open the DXP tab, then click Extensions and Updates.  

3. On the Extensions and Updates page, scroll down to SOLIDWORKS PCB Connector, then click the 

download icon in the top-right corner to begin the installation.  

 

4. In the Confirm dialog box, click Yes to proceed with the installation.  
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5. On the SOLIDWORKS PCB Connector Registration page, enter your SOLIDWORKS PCB Connector 

serial number and click Register.  

6. On the Confirm dialog, either click Yes to restart the system and complete the installation, or click No 

to complete the restart later.  

Appendix: License Transfer  

You are allowed one activation per standalone license, for your business computer and for your home 

computer. As part of the license agreement, you may not use both simultaneously.  

Each activation transaction is coded to the hardware of your computer. If you are moving your 

SOLIDWORKS PCB installation to a new computer, you will need to transfer your license activation 

before activating on the new computer. You should also do this before reformatting or replacing your 

hard drive or operating system. If your SOLIDWORKS PCB license is tied to your main SOLIDWORKS 

license (i.e. they are the same number), please see our guide titled 2020 Product Activation for the 

transfer process.  

This process is not required for a new installation. If your computer does not have internet access, refer 

to the E-mail Transfer section of this document.  

Online Transfer  

1. Go to Start > All Programs > SOLIDWORKS 2020 > SOLIDWORKS PCB.  

2. Once SOLIDWORKS PCB launches, click on the File tab and choose Help>Deactivate 

Licenses…  
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3. Choose to transfer Automatically over the Internet and click Next.  

 

 

4. The software will connect to the SOLIDWORKS activation servers and you will be informed when 

the license has been successfully transferred.  

 

5. Press the Finish button to complete the process.  

Note: SOLIDWORKS PCB will no longer run on this machine unless it is re-activated.  

E-mail Transfer  

1. Go to Start > All Programs > SOLIDWORKS 2020 > SOLIDWORKS PCB.  

2. Once SOLIDWORKS PCB launches, click on the File tab and choose Help>Deactivate 

Licenses…  
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3. Choose to activate Manually via e-mail and click Next.  

4. On the next page, press the Save button to create an activation request file.  

Note: Once you have saved this file, your activation is disabled. Do not exit the activation 

window until you have read in the response file from SOLIDWORKS and completed the 

process or you will not be able to run SOLIDWORKS PCB to complete the transfer.  

5. Browse to a location on your computer to store this .txt file and press the Save button. Copy this .txt 

file onto a removable storage device and move it to a machine with internet access.  

6. E-mail this file as an attachment to activation@solidworks.com.  

7. SOLIDWORKS will send a return e-mail with a different .txt file attached. Save this file to a 

removable storage device and move it to the machine awaiting the activation transfer.  

8. In the activation wizard, press the Open button on the e-mail activation page.  

9. Browse to the response file and press the Open button.  

10. The next page will show you that your transfer is complete.  

11. Press the Finish button to complete the process.  

Note: SOLIDWORKS PCB will no longer run on this machine unless it is re-activated.  

 

mailto:activation@solidworks.com

	SOLIDWORKS PCB Connector 2020 Installation Guide
	Product Information
	Licensing
	Configuration Requirements
	Program Components
	Installation Types

	Before Installation
	Installing SOLIDWORKS PCB Services
	Installing SOLIDWORKS PCB Connector
	Appendix: License Transfer
	Online Transfer
	E-mail Transfer


