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Legal Notices
SOLIDWORKS Associative Interface for Abaqus 2023 is © 2023 Dassault Systemes Simulia Corp.

This page specifies the patents, trademarks, copyrights, and restricted rights for the SIMULIA Abaqus 2023:

Patents

SOLIDWORKS Associative Interface for Abaqus is protected by U.S. Patents number: 7,499,845 ; 7,558,714
; 9,031,819 ; 8,224,633 ; 9,117,040 ; 9,037,440 ; 9,239,895 ; 10,380,275 ; 9,582,510 ; 8,831,926 ; 10,360,324 ;
9,405,867 ; 8,346,522 ; 9,223,754 ; 9,671,943 ; 9,542,506 ; 9,626,463 ; 10,402,517 ; 9,223,909 ; 9,582,519 ;
10,515,159 ; 10,740,513 ; 9,965,574 ; 9,322,259 ; 10,550,690 ; 10,311,180 ; 10,108,761 ; 10,037,404 ; 9,228,873
; 9,646,119 ; 10,338,117 ; 9,576,087 ; 10,102,316 ; 10,379,147 ; 10,156,599 ; 10,699,034 ; 10,061,878 ; 10,303,825
; 10,101,188 ; 10,262,087 ; 10,354,026 ; 10,628,537 ; 10,599,879 ; 10,386,212 ; 10,671,776 ; 10,229,179 ;
10,394,230 ; 10,685,154 ; 10,671,777 ; 10,349,911 ; 10,853,535 ; 10,891,788 ; 10,915,680 ; 10,943,037 ;
10,948,896 ; 10,915,675 ; 11,048,835 ; 11,281,824 ; 11,334,691

Other patents pending.

Trademarks

Abaqus, 3DEXPERIENCE, the Compass icon, the 3DS logo, CATIA, BIOVIA, GEOVIA, SOLIDWORKS,
3DVIA, ENOVIA, NETVIBES, MEDIDATA, CENTRIC PLM, 3DEXCITE, SIMULIA, DELMIA and IFWE
are commercial trademarks or registered trademarks of Dassault Systèmes, a French "société européenne"
(Versailles Commercial Register # B 322 306 440), or its subsidiaries in the United States and/or other countries.
All other trademarks are owned by their respective owners. Use of any Dassault Systèmes or its subsidiaries
trademarks is subject to their express written approval.

DS Offerings and services names may be trademarks or service marks of Dassault Systèmes or its subsidiaries.

Third-Party Copyrights Notices

SOLIDWORKS Associative Interface for Abaqus may include open source software components. Source code
for open source software components licensed under terms and conditions that mandate availability of such
source code is available upon request. The original licensors of said open source software components provide
them on an "as is" basis and without any liability whatsoever to customer (or licensee).

Under zlib/libpng License with Acknowledgement:

Zlib 1.1.4

Copyright © 1995-2004 Jean-loup Gailly and Mark Adler
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License Terms

zlib/libpng License with Acknowledgement

Copyright © 2002-2007 Charlie Poole

Copyright © 2002-2004 James W. Newkirk, Michael C. Two, Alexei A. Vorontsov

Copyright © 2000-2002 Philip A. Craig

This software is provided 'as-is', without any express or implied warranty. In no event will the authors be held
liable for any damages arising from the use of this software.

Permission is granted to anyone to use this software for any purpose, including commercial applications, and to
alter it and redistribute it freely, subject to the following restrictions:

1. The origin of this software must not be misrepresented; you must not claim that you wrote the original software.
If you use this software in a product, an acknowledgment (see the following) in the product documentation is
required.

Portions Copyright © 2002-2007 Charlie Poole or Copyright © 2002-2004 James W. Newkirk, Michael C. Two,
Alexei A. Vorontsov or Copyright © 2000-2002 Philip A. Craig

2. Altered source versions must be plainly marked as such, and must not be misrepresented as being the original
software.

3. This notice may not be removed or altered from any source distribution.

Restricted Rights

This clause applies to all acquisitions of Dassault Systèmes Offerings by or for the United States federal
government, or by any prime contractor or subcontractor (at any tier) under any contract, grant, cooperative
agreement or other activity with the federal government. The software, documentation and any other technical
data provided hereunder is commercial in nature and developed solely at private expense. The Software is
delivered as "Commercial Computer Software" as defined in DFARS 252.227-7014 (June 1995) or as a
"Commercial Item" as defined in FAR 2.101(a) and as such is provided with only such rights as are provided in
Dassault Systèmes standard commercial end user license agreement. Technical data is provided with limited
rights only as provided in DFAR 252.227-7015 (Nov. 1995) or FAR 52.227-14 (June 1987), whichever is
applicable. The terms and conditions of the Dassault Systèmes standard commercial end user license agreement
shall pertain to the United States government's use and disclosure of this software, and shall supersede any
conflicting contractual terms and conditions. If the DS standard commercial license fails to meet the United
States government's needs or is inconsistent in any respect with United States Federal law, the United States
government agrees to return this software, unused, to DS. The following additional statement applies only to
acquisitions governed by DFARS Subpart 227.4 (October 1988): "Restricted Rights - use, duplication and
disclosure by the Government is subject to restrictions as set forth in subparagraph (c)(l)(ii) of the Rights in
Technical Data and Computer Software clause at DFARS 252-227-7013 (Oct. 1988)

SOLIDWORKS Associative Interface for Abaqus is © 2023 Dassault Systemes Simulia Corp.
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SOLIDWORKS Associative Interface User's
Guide
This guide provides information for system administrators on how to install and configure the components of the
SOLIDWORKS Associative Interface. The guide also provides information for end users on how to transfer models
from SOLIDWORKS to Abaqus/CAE.

This guide is intended for use with SOLIDWORKS Associative Interface Version 2.8. The content was updated in
April 2023.

SOLIDWORKS Associative Interface4
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What's New
This page describes recent changes in the SOLIDWORKS Associative Interface.

Abaqus 2023 FD03 (PF.2323)

Support for SOLIDWORKS 2023
This guide is intended for use with Release 2.8 of the SOLIDWORKS Associative Interface add-in.

Release 2.8 of the SOLIDWORKS Associative Interface supports SOLIDWORKS 2023 and supports Abaqus/CAE
2023 or later releases.

To check the release number of the add-in you are using, see Determining the release number of the SOLIDWORKS
Associative Interface add-in.

Benefits: The updated compatibility improves the overall workflow.

For more information, see System requirements for the SOLIDWORKS Associative Interface.
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SOLIDWORKS Associative Interface:
overview

The SOLIDWORKS Associative Interface allows you to transfer the geometry of a SOLIDWORKS model to
Abaqus/CAE.

In this section:

• About the SOLIDWORKS Associative Interface
• What is associative import?
• Using the SOLIDWORKS Associative Interface

SOLIDWORKS Associative Interface6
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About the SOLIDWORKS Associative Interface
The SOLIDWORKS Associative Interface allows you to transfer the geometry of a SOLIDWORKS model to
Abaqus/CAE.

The SOLIDWORKS Associative Interface consists of the following two components:

• The SOLIDWORKS Associative Interface add-in. The add-in is a plug-in for SOLIDWORKS that allows you to
save a model in SOLIDWORKS as an assembly (.eaf) file. The SOLIDWORKS Associative Interface add-in is
delivered on the assembly media (see the SIMULIA Installation Guide for more information). For details on
additional delivery methods, search for "How to obtain the Abaqus/CAE Associative Interface” in the Search our
Knowledge field at http://www.3ds.com/support.

• The Abaqus/CAE CAD Connection toolset. The CAD Connection toolset, which is enabled with a SOLIDWORKS
Associative Interface license, allows you to import an assembly file that is generated by the SOLIDWORKS
Associative Interface add-in. The SOLIDWORKS Associative Interface license is available as an add-on product
from your local SIMULIA office.
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What is associative import?
Associative import allows you to easily transfer a part or assembly from SOLIDWORKS to Abaqus/CAE.
You can subsequently modify the model in SOLIDWORKS and propagate these modifications to Abaqus/CAE without
losing any analysis features assigned to the model in Abaqus/CAE.

The SOLIDWORKS Associative Interface is useful when you are iterating on the design of a model in SOLIDWORKS
based on the results of analyses conducted in Abaqus. Figure 1 shows the connection between SOLIDWORKS and
Abaqus/CAE using associative import.

Figure 1: Using associative import to export a model from SOLIDWORKS (left) to Abaqus/CAE (right).

When you use associative import to transfer a model from SOLIDWORKS to Abaqus/CAE, the model appears in the
current Abaqus/CAE viewport. The parts and assembly from SOLIDWORKS are stored in the Abaqus/CAE model
database and appear in the Model Tree. You can use SOLIDWORKS to modify the parts or to change the position of
components in the assembly; when the modifications are complete and the model is ready to be analyzed, perform
another associative import. Every time you import the model into Abaqus/CAE, Abaqus/CAE updates the current
viewport and the Model Tree to reflect the changes.

In addition, associative import retains any features that you added to the model with Abaqus/CAE. Any of the features
that you created in Abaqus/CAE—such as partitions, loads, boundary conditions, sets, and surfaces—are regenerated
each time you import the modified model from SOLIDWORKS to Abaqus/CAE. For example, if you partitioned a
cell with Abaqus/CAE, the partition is regenerated each time you import the model from SOLIDWORKS into
Abaqus/CAE. However, the regeneration of features may fail if the changes that you made with SOLIDWORKS change
the topology of the model in ways that fail to fully support the creation of those features.

When you import an assembly, Abaqus/CAE creates parts that correspond to the imported part instances and maintains
the relationship between the parts and their instances. Abaqus/CAE does not support subassemblies; if the
SOLIDWORKS model includes subassemblies, Abaqus/CAE imports the complete model as a single assembly. In
addition, features defined at the assembly level in SOLIDWORKS (such as merges or splits) are not imported into the
Abaqus/CAE model.

SOLIDWORKS Associative Interface8
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In most cases Abaqus/CAE retains the names of the parts from the SOLIDWORKS model.

9SOLIDWORKS Associative Interface
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Using the SOLIDWORKS Associative Interface
The SOLIDWORKS Associative Interface offers two associative import methods: automatic associative import and
manual associative import.

Automatic associative import

Automatic associative import transfers the geometry of a SOLIDWORKS model to Abaqus/CAE in a single
step. Sessions of SOLIDWORKS and Abaqus/CAE must be running simultaneously on the same computer.
Using the CAD Connection toolset, you establish a link between Abaqus/CAE and SOLIDWORKS. As soon
as an assembly file is created by the SOLIDWORKS Associative Interface add-in, the assembly is imported
automatically into Abaqus/CAE. After the model has been transferred, you can continue to make design
modifications in SOLIDWORKS and propagate these modifications to the Abaqus/CAE model with a single
mouse click. For detailed instructions on performing an automatic associative import, see Using automatic
associative import.

Manual associative import

Manual associative import is a multistep procedure that can be used to perform an associative import when
SOLIDWORKS and Abaqus/CAE are running on different computers or on different platforms. Using the
SOLIDWORKS Associative Interface add-in, you can save an assembly (.eaf) file to a specified location.
Using the CAD Connection toolset, you can import the geometry into Abaqus/CAE or use the assembly file to
update an existing model in Abaqus/CAE at a later time. For detailed instructions on performing a manual
associative import, see Using manual associative import.

SOLIDWORKS Associative Interface10
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System requirements for the
SOLIDWORKS Associative Interface
The components of the SOLIDWORKS Associative Interface are supported on the platforms indicated in the table
below.

Table 1: Supported platforms for the SOLIDWORKS Associative Interface.

Abaqus/CAE CAD Connection toolsetSOLIDWORKS Associative Interface
add-in

Platform

Windows/x86-64

Linux/x86-64*

* The manual associative import method must be used when Abaqus/CAE is running on a Linux platform.

Release 2.8 of the SOLIDWORKS Associative Interface add-in can be installed with all SOLIDWORKS releases
beginning with SOLIDWORKS 2023. For more information about installing the SOLIDWORKS Associative Interface
add-in in SOLIDWORKS, see Installing the SOLIDWORKS Associative Interface add-in.

The CAD Connection toolset for Abaqus/CAE supports the SOLIDWORKS Associative Interface in Abaqus 6.8 or
later.

For the latest information about which versions of SOLIDWORKS and Abaqus/CAE are supported by the
SOLIDWORKS Associative Interface, refer to the Support page at www.3ds.com/simulia.
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Units
SOLIDWORKS allows you to change the displayed units of measure in a model; if you change the displayed units,
all measurements and parameters in the model are converted and updated to reflect the new units.
Abaqus/CAE has no units built into it.

When you use associative import to transfer a model from SOLIDWORKS, Abaqus/CAE imports the displayed
numerical measurements without regard for the displayed units.

For example, consider a model created in SOLIDWORKS of a cube that measures 30 millimeters on a side (see Figure
1). If the displayed units system in SOLIDWORKS is MMGS (millimeter, gram, second), Abaqus/CAE imports a
cube with a side length of 30. If the displayed units system in SOLIDWORKS is CGS (centimeter, gram, second),
Abaqus/CAE imports a cube with a side length of 3.

Figure 1: Abaqus/CAE ignores the displayed units when importing models from SOLIDWORKS.

The individual parts in an assembly should use the same units system. When you import an assembly with mixed units
into Abaqus/CAE, all of the parts are scaled to a consistent set of units before the import. However, if you subsequently
update the Abaqus/CAE assembly by importing an individual part, the units for that part are not scaled and may be
inconsistent with the existing dimensions in Abaqus/CAE.

Note:  Some model assemblies that are imported using Release 1.1 of the SOLIDWORKS Associative Interface
may employ inconsistent units when positioning the assembly components in Abaqus/CAE. To resolve this
problem, rewrite the assembly (.eaf) file for the model from SOLIDWORKS using Release 1.2 or higher of
the SOLIDWORKS Associative Interface add-in, and import the new assembly file into Abaqus/CAE.

SOLIDWORKS Associative Interface12
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Installing the SOLIDWORKS Associative
Interface add-in

The SOLIDWORKS Associative Interface add-in is a plug-in component for SOLIDWORKS. The add-in must
be enabled after it is installed.

In this section:

• Installing the SOLIDWORKS Associative Interface add-in
• Enabling the SOLIDWORKS Associative Interface add-in
• Determining the release number of the SOLIDWORKS Associative Interface add-in
• Uninstalling the SOLIDWORKS Associative Interface add-in
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Installing the SOLIDWORKS Associative Interface add-in
The following procedure describes how to install the SOLIDWORKS Associative Interface plug-in on Windows
systems.

Before you begin:

You need administrative privileges to install the plug-in. SOLIDWORKS must be installed and licensed on your system
before installing the plug-in. If you are installing the SOLIDWORKS Associative Interface on an operating system
that uses User Access Control (UAC), such as Windows Vista or Windows 7, you must turn off UAC or select the
least secure setting.

1. Obtain the SOLIDWORKS Associative Interface zip file from the assembly media (see the SIMULIA
Installation Guide for more information).

2. Unzip the SOLIDWORKS Associative Interface zip file and save the contents to a permanent directory;
the directory must be accessible to all users of the SOLIDWORKS Associative Interface. The zip file
contains the add-in .dll file.

3. Start SOLIDWORKS as a Windows administrator in one of the following ways:

• For instructions on installing the SOLIDWORKS Associative Interface from the command line,
see “Installing or removing SIMULIA Abaqus/CAE Associative Interface for SolidWorks via
command line,” which can be found by entering the title in the Search our Knowledge field at
http://www.3ds.com/support.

• From the Start menu, Shift + right-click SOLIDWORKS and select Run as administrator from
the context menu.

• From the desktop, Shift + right-click SOLIDWORKS and select Run as administrator from the
context menu.

You must be part of the local administrator group to open SOLIDWORKS as an administrator.

4. Select File->Open from the main menu bar.

The Open dialog box appears.

5. In the Files of type field, select Add-Ins (*.dll).

6. Navigate to the directory that contains the add-in file. Select the add-in .dll file, and click Open.

SOLIDWORKS installs the SOLIDWORKS Associative Interface add-in.

SOLIDWORKS Associative Interface14
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Enabling the SOLIDWORKS Associative Interface add-in
The following procedure describes how to enable the SOLIDWORKS Associative Interface add-in in SOLIDWORKS
after you have installed it.

1. From the SOLIDWORKS main menu, select Tools->Add-Ins.

SOLIDWORKS displays the Add-Ins dialog box.

2. In the Add-Ins dialog box, the SOLIDWORKS Associative Interface add-in is listed as Abaqus/CAE
underneath the Other Add-ins heading (see Figure 1).

• To enable the SOLIDWORKS Associative Interface add-in in the current SOLIDWORKS session,
toggle on the check box in the Active Add-ins column.

• To enable the SOLIDWORKS Associative Interface add-in for future SOLIDWORKS sessions,
toggle on the check box in the Start Up column.

Figure 1:The Add-Ins dialog box.

3. Click OK.

If you toggled on Active Add-ins for the SOLIDWORKS Associative Interface add-in, Abaqus appears

in the Tools menu in the SOLIDWORKS main menu bar, and the Export to Abaqus/CAE icon 
appears in the SOLIDWORKS toolbar.
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4. To disable the SOLIDWORKS Associative Interface add-in, follow the above steps and toggle off the
appropriate check boxes.

SOLIDWORKS Associative Interface16
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Determining the release number of the SOLIDWORKS Associative Interface
add-in
Use the procedure below to determine which release of the SOLIDWORKS Associative Interface add-in you are using.

This information may be necessary if you are contacting SIMULIA for troubleshooting issues related to the
SOLIDWORKS Associative Interface.

1. From the SOLIDWORKS main menu, select Tools->Abaqus->Export to Abaqus/CAE.

Export to Abaqus/CAE appears in the SOLIDWORKS PropertyManager.

2. In the PropertyManager, click the question mark .

The dialog box that appears contains trademark information and the release number for the
SOLIDWORKS Associative Interface add-in.

17

Determining the release number of the SOLIDWORKS Associative Interface add-in



Uninstalling the SOLIDWORKS Associative Interface add-in
The following procedure describes how to uninstall the SOLIDWORKS Associative Interface add-in.

To uninstall the SOLIDWORKS Associative Interface add-in, run the following command from a command prompt:

regsvr32 /c /u full_path_to_dll_file

where full_path_to_dll_file is the location of the saved add-in .dll file on your computer. Solidworks session need
to be closed for successful uninstallation of plug-in using this command.

The SOLIDWORKS Associative Interface add-in is disabled in SOLIDWORKS, and the Abaqus/CAE item is removed
from the Add-Ins dialog box.

Note:  On Windows Vista, User Account Control (UAC) must be turned off for the administrator account and
the user account before uninstalling the SOLIDWORKS Associative Interface add-in.

SOLIDWORKS Associative Interface18
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Importing a part or assembly from
SOLIDWORKS to Abaqus/CAE

Associative import through the SOLIDWORKS Associative Interface allows you to transfer model geometry
and subsequent design changes from SOLIDWORKS to Abaqus/CAE without losing any analysis features that
are defined in Abaqus/CAE.

Associative import can be performed automatically or manually; for an overview of the two import techniques,
see Using the SOLIDWORKS Associative Interface.

In this section:

• Using automatic associative import
• Using manual associative import
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Using automatic associative import

You can use automatic associative import to import an assembly from SOLIDWORKS to Abaqus/CAE.

Follow the instructions below to import an assembly from SOLIDWORKS to Abaqus/CAE using automatic associative
import.

1. Start Abaqus/CAE, and enter the Assembly module.

2. From the main menu bar, select Tools->CAD Interfaces->SOLIDWORKS.

3. From the SOLIDWORKS dialog box that appears, choose Auto-assign port and click Enable.

Abaqus/CAE displays the port number that it assigned in the message area. (If desired, you can click
Specify port and enter the port number.)

4. Start SOLIDWORKS, and load the model to be exported.

Abaqus appears in the Tools menu in the SOLIDWORKS main menu bar. If Abaqus does not appear
in the Tools menu, refer to Installing the SOLIDWORKS Associative Interface add-in.

5. If the model includes any new or modified parts, save the SOLIDWORKS model. Current
SOLIDWORKS part (.SLDPRT) files must exist for each part in the assembly before using the
SOLIDWORKS Associative Interface.

6. Select Tools->Abaqus->Export to Abaqus/CAE from the SOLIDWORKS main menu.

The Export to Abaqus/CAE options appear in the SOLIDWORKS PropertyManager.

7. In the SOLIDWORKS PropertyManager, specify the following information:

a. Toggle on Open in Abaqus/CAE (see Figure 1).

Figure 1: Use automatic associative import to transfer the model directly to
Abaqus/CAE.

b. If necessary, change the default number in the Open in Abaqus/CAE field so that it matches the
port number displayed by Abaqus/CAE when you enabled the CAD interface.

c. The SOLIDWORKS Associative Interface saves necessary files (the assembly file and part geometry
files) to a working directory during the import. If necessary, change the path in the Working
Directory field to save these files in a different location.

d. By default, the SOLIDWORKS Associative Interface automatically saves the current version of
the SOLIDWORKS model as part of the export process. To prevent the SOLIDWORKS files from

SOLIDWORKS Associative Interface20
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being saved automatically, toggle off Autosave files before export. If you toggle off this option,
you must manually save the SOLIDWORKS model before exporting it to Abaqus/CAE.

e. Toggle on Export named entities if you want to create sets and surfaces that correspond to a named
face or edge. By default, this option is toggled off.

f. The SOLIDWORKS Associative Interface provides the option to export a SOLIDWORKS Multibody
Part as separate parts. By default, Export each body as separate part is toggled off.

g. The Retain Boundary option allows you to retain the intersecting boundaries in Abaqus/CAE. By
default, this option is toggled off.

8. Click the green check mark  in the SOLIDWORKS PropertyManager.

The model appears in the current Abaqus/CAE viewport. If an assembly is open in SOLIDWORKS,
the parts are imported into Abaqus/CAE and an assembly of part instances is created automatically. If
a single part is open in SOLIDWORKS, only the part is imported into Abaqus/CAE. You can use the
parts and the assembly in an Abaqus/CAE analysis; for example, you can apply sections to the parts,
and you can apply loads and boundary conditions to the assembly.

9. If you modify the model in SOLIDWORKS, click the Export to Abaqus/CAE icon  to update
the model in Abaqus/CAE. The modified model is imported immediately into Abaqus/CAE using the
settings previously specified in the Export to Abaqus/CAE dialog box. You can also select
Tools->Abaqus->Export to Abaqus/CAE from the SOLIDWORKS main menu to change the settings
and import the updated model.

Note:  If you toggled off the Autosave files before export in the Export to Abaqus/CAE
dialog box, you must manually save the modified SOLIDWORKS model before exporting it to
Abaqus/CAE.

Abaqus/CAE imports only the modified parts. Any changes that you make to the position of components
in the SOLIDWORKS assembly will also be exported to Abaqus/CAE. Any components that you
suppress or unsuppress in SOLIDWORKS are suppressed or resumed similarly in Abaqus/CAE. If
you hide a component in SOLIDWORKS, the visibility of that part instance in Abaqus/CAE is turned
off; use the Assembly Display Options in Abaqus/CAE to control the visibility of part instances (for
more information, see "Controlling instance visibility" in the Abaqus/CAE User's Guide).

Features (such as loads and sets) and geometric modifications that you created in Abaqus/CAE are
updated to account for the changes to the SOLIDWORKS parts. Abaqus/CAE will be unable to
regenerate some features if the topology of the part has changed significantly.

10. From the Abaqus/CAE main menu bar, select Tools->CAD Interfaces->SOLIDWORKS to show
the port number that is being used or to disable the connection with SOLIDWORKS. For more
information, see "Creating a CAD connection" in the Abaqus/CAE User's Guide.

21SOLIDWORKS Associative Interface
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Using manual associative import
You can use manual associative import to export an assembly from SOLIDWORKS to Abaqus/CAE.

Follow the instructions below to import an assembly from SOLIDWORKS to Abaqus/CAE using manual associative
import.

1. Start SOLIDWORKS, and load the model to be exported.

Abaqus appears in the Tools menu in the SOLIDWORKS main menu bar. If Abaqus does not appear
in theTools menu, refer to Installing the SOLIDWORKS Associative Interface add-in.

2. If the model includes any new or modified parts, save the SOLIDWORKS model. Current
SOLIDWORKS part (.SLDPRT) files must exist for each part in the assembly before using the
SOLIDWORKS Associative Interface.

3. Select Tools->Abaqus->Export to Abaqus/CAE from the SOLIDWORKS main menu.

The Export to Abaqus/CAE options appear in the SOLIDWORKS PropertyManager.

4. In the SOLIDWORKS PropertyManager, specify the following information:

a. Toggle off Open in Abaqus/CAE (see Figure 1).

Figure 1: Use manual associative import to save an assembly file.

b. In the Working Directory field, specify a path and file name to which the assembly file will be
saved.

c. By default, the SOLIDWORKS Associative Interface automatically saves the current version of
the SOLIDWORKS model before it creates the assembly file. To prevent the SOLIDWORKS files
from being saved automatically, toggle off Autosave files before export. If you toggle off this
option, you must manually save the SOLIDWORKS model before creating the assembly file.

d. Toggle on Export named entities if you want to create sets and surfaces that correspond to a named
face or edge. By default, this option is toggled off.

e. The SOLIDWORKS Associative Interface provides the option to export a SOLIDWORKS Multibody
Part as separate parts. By default, Export each body as separate part is toggled off.

f. The Retain Boundary option allows you to retain the intersecting boundaries in Abaqus/CAE. By
default, this option is toggled off.

5. Click the green check mark  in the SOLIDWORKS PropertyManager.

SOLIDWORKS Associative Interface22
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SOLIDWORKS saves the assembly (.eaf) file and any necessary part files in ACIS (.sat) format.
You can now end your SOLIDWORKS session.

6. If necessary, copy the assembly file and all of the ACIS part files to the computer where you will be
running Abaqus/CAE.

7. Start Abaqus/CAE, and select File->Import->Assembly from the main menu bar.

The Import Assembly dialog box appears.

8. From the File Filter menu at the bottom of the Import Assembly dialog box, select Assembly File
(*.eaf*).

9. Select the assembly file that was written in Step 5, and click OK.

10. From the Import Assembly from EAF File dialog box that appears, select the assembly or individual
part instances to import, and click OK.

The selected part instances appear in the current Abaqus/CAE viewport. You can use the parts and the
assembly in an Abaqus/CAE analysis; for example, you can apply sections to the parts, and you can
apply loads and boundary conditions to the assembly.

For more information about importing assembly files, see "Importing an assembly from an Elysium
assembly file" in the Abaqus/CAE User's Guide.

11. If you modify the model in SOLIDWORKS, use the following steps to propagate the changes to the
model in Abaqus/CAE:

a. Repeat Steps 1–5 to create an updated assembly file. The name of the assembly file can change
between imports; however, the names of the parts and components in the SOLIDWORKS model
must remain the same.

b. If necessary, copy the assembly file and any ACIS part files that have been modified since the last
import to the computer where you are running Abaqus/CAE.

c. Open the existing model in the current viewport of Abaqus/CAE.
d. Import the updated assembly file using the procedure in Steps 7–10.

Abaqus/CAE imports only the modified parts. Any changes that you made to the position of
components in the SOLIDWORKS assembly will also be imported to Abaqus/CAE. Any components
that you suppressed or unsuppressed in SOLIDWORKS are suppressed or resumed similarly in
Abaqus/CAE. If you hid a component in SOLIDWORKS, the visibility of that part instance in
Abaqus/CAE is turned off; use the Assembly Display Options in Abaqus/CAE to control the
visibility of part instances (for more information, see "Controlling instance visibility" in the
Abaqus/CAE User's Guide).

Features (such as loads and sets) and geometric modifications that you created in Abaqus/CAE are
updated to account for the changes to the SOLIDWORKS parts. Abaqus/CAE will be unable to
regenerate some features if the topology of the part has changed significantly.
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Using the SOLIDWORKS Associative
Interface scripting interface
You can use the scripting interface for the SOLIDWORKS Associative Interface to iterate on the design of your model.

For example, you can attempt to minimize the weight of your design by running a script that decreases the thickness
of a region until Abaqus calculates that a maximum stress level is reached. The scripting interface for the SOLIDWORKS
Associative Interface utilizes the SOLIDWORKS VBA macro scripting interface to update the SOLIDWORKS model
in Abaqus/CAE and to save SOLIDWORKS parts in assembly (.eaf) file format. The scripting interface provides
the following four methods:

SetPortNumber(port)

You use the SetPortNumber method to assign the port that will be used by the CAD Connection toolset. port
is a long integer specifying the port number.

SetWorkingDirectory(directory)

You use the SetWorkingDirectory method to specify where the SOLIDWORKS Associative Interface
saves files (the part geometry files) during the import. directory is a string specifying the path to the working
directory.

SetAutoSave(save)

You use the SetAutoSave method to automatically save the current version of the SOLIDWORKS model in
assembly (.eaf) file format as part of the export process. save is a long integer specifying whether to save the
current version of the SOLIDWORKS model. If save=0, the model is not saved; if save=1, the model is saved.

ExportToCAE(export)

You use the ExportToCAE method to update the model in Abaqus/CAE. export is a long integer specifying
whether to update the model. If export=0, the model is not updated; if auto=1, the model is updated.

Before you run a SOLIDWORKS Associative Interface script for the first time, you must do the following:

1. Start SOLIDWORKS, and select Tools->Macro->Edit from the main menu bar.

2. Open a file containing a script (.swp file).

3. From the main menu bar, select Tools->References.

4. Verify that the following libraries (.tlb file) are registered:

• Visual Basic For Applications
• SOLIDWORKS Extensibility Type Library
• OLE Automation
• SOLIDWORKS version Constant Type Library
• SwAddinTolAnalyst 1.0 Type Library
• Sw2AbqPlugin 1.0 Type Library
• SOLIDWORKS version Commands Type Library
• SOLIDWORKS version Exposed Type Libraries for add-in use
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The following example illustrates the four methods that are provided in the SOLIDWORKS Associative Interface
scripting interface. The example updates a SOLIDWORKS part in Abaqus/CAE.

Dim mySAIPlugin As ISw2AbqPlugin
Set mySAIPlugin = swApp.GetAddInObject("Sw2AbqPlugin.Sw2AbqPlugin")
Dim port As Long
port = 45001
mySAIPlugin.SetPortNumber(port)
Dim workDir As String
workDir = "C:\wdir\SAI_TMP\"
mySAIPlugin.SetWorkingDirectory(workDir)
Dim auto As Long
auto = 1
mySAIPlugin.SetAutoSave(auto)
mySAIPlugin.ExportToCAE(auto)
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