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SOLIDWORKS PCB 2017 Installation Guide 

 

  

This guide gives instructions for installing SOLIDWORKS PCB 2017. It is written for standalone 

installations of SOLIDWORKS PCB 2017. In this configuration, all program components are on the same 

computer. If your software is installed in a shared configuration where a server computer, or other 

computer able to reach the network, hosts SOLIDWORKS PCB Services data, while user computers run 

either SOLIDWORKS PCB, SOLIDWORKS PCB Connector or the SOLIDWORKS PCB Add-In.  

Please contact Hawk Ridge Systems Technical Support if you are unsure of your SOLIDWORKS PCB 

configuration type. 

SOLIDWORKS PCB 2017 uses the same installation manager as other SOLIDWORKS products, 

including the 3D CAD software. If upgrading other SOLIDWORKS products along with SOLIDWORKS 

PCB 2017, please also refer to their upgrade guides for further instructions. 

This is not a troubleshooting guide.  If you have any technical issues with SolidWorks, please contact Hawk 

Ridge Systems technical support.  This document is only to be distributed and used by Hawk Ridge Systems 

customers.  Any other use is prohibited. 
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ABSTRACT: This guide gives instructions for installing SOLIDWORKS PCB 2017. It is 
written for standalone installations of SOLIDWORKS PCB 2017. In this 
configuration, all program components are on the same computer. 
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Product Information 

SOLIDWORKS PCB is a PCB design tool that integrates with SOLIDWORKS 3D to allow collaboration 

between electrical and mechanical designers. Changes to a PCB design can be made in either 

SOLIDWORKS PCB or SOLIDWORKS 3D then synchronized between the two programs. 
 

SOLIDWORKS PCB Connector is also available. This product enables SOLIDWORKS 3D integration 

with Altium Designer. Here the PCB design tools are provided by Altium Designer, while the 3D collaboration 

tools are provided by SOLIDWORKS PCB Connector. Note that sales and support for Altium Designer 

are not provided by Hawk Ridge Systems or SOLIDWORKS. 

 

Refer to www.solidworkspcb.com for more information. 
 

Licensing 

SOLIDWORKS PCB 2017 can be used with standalone and network licenses. Note that the license type 

differs from the installation configuration type, which can be standalone or shared.  The license type can 

be standalone or client-server (this guide is for the standalone configuration). Either license type can be 

used with either configuration type. 

If you have a standalone license, you will need to activate SOLIDWORKS PCB 2017 after installing. You 

will be automatically prompted to do this when launching the application after an upgrade.  Refer to our 

http://www.hawkridgesys.com/
http://www.solidworkspcb.com/
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guide titled 2017 Product Activation for more information on activation methods. If you are moving 

your SOLIDWORKS PCB 2017 installation to a new computer, you will need to transfer your license 

activation off the old computer before activating on the new one. Refer to the Appendix for instructions on 

transferring your SOLIDWORKS PCB standalone license. 

If you have a network license, the SolidNetwork License Manager on the license server computer needs 

to be of a version at or above the version of SOLIDWORKS PCB 2017 that you are installing. If this is 

not already the case, refer to our guide titled 2017 Network Server Installation to install and activate 

the SolidNetwork License Manager. 

Configuration Requirements 

If you are installing SOLIDWORKS PCB 2017, and are looking to take advantage of 3D imaging and data 

transfer, you must either install SOLIDWORKS 3D along with SOLIDWORKS PCB 2017 or have 

SOLIDWORKS 3D previously installed on your computer. It is recommended that SOLIDWORKS 3D 

and SOLIDWORKS PCB be of the same version and service pack, however it is not required. 

Program Components 

If you have purchased SOLIDWORKS PCB, you will need to install: 
 

 SOLIDWORKS PCB 

 SOLIDWORKS PCB Services 

 SOLIDWORKS PCB Add-In 
 

If you have purchased SOLIDWORKS PCB Connector, you will need to install: 
 

 SOLIDWORKS PCB Connector 

 SOLIDWORKS PCB Services 

 SOLIDWORKS PCB Add-In 

 
Refer to the table below for more information on the four program components. 

 

Program Component Description Typical Installation Location 

SOLIDWORKS PCB 
Services 

Service that enables communication and 
collaboration between the SOLIDWORKS 
PCB and SOLIDWORKS 3D programs 

Server computer accessible to 
all user computers 

SOLIDWORKS PCB Standalone PCB design program typically 
used by an electrical designer 

ECAD user computer 

SOLIDWORKS PCB 
Connector 

Extension for Altium Designer to allow it 
to connect to SOLIDWORKS PCB 
Services, enabling 3D integration 

ECAD user computer running 
Altium Designer 

SOLIDWORKS PCB 
Add-In 

Add-in for SOLIDWORKS 3D (typically 
used by a mechanical designer), 
allowing it to connect to SOLIDWORKS 
PCB Services and push changes back 
to SOLIDWORKS PCB 

MCAD user computer running 
SOLIDWORKS 3D 

http://www.hawkridgesys.com/
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Installation Types 

SOLIDWORKS PCB can be installed in a shared or local configuration. 
 

In a shared configuration, SOLIDWORKS PCB Services is installed on a server computer or another 

computer that is accessible over the network to all the user computers. The user computers run either 

SOLIDWORKS PCB, PCB Connector or the SOLIDWORKS PCB Add-In. These components all 

connect to SOLIDWORKS PCB Services over the network. This is illustrated in the image above. 

 

In a local configuration, SOLIDWORKS PCB Services is installed on the same computer as the design 

tools (SOLIDWORKS PCB Add-In and SOLIDWORKS PCB or SOLIDWORKS PCB Connector).  This 

would typically be used if one user works independently on the electrical and mechanical PCB design 

aspects, without collaboration. 

Before Installation 

Hawk Ridge Systems highly recommends checking your system before installing SOLIDWORKS PCB 

2017. Follow these steps to ensure you are ready to install. 

1. Check operating system and hardware compatibility. 

 Check that the hardware and operating system of your computer meet the SOLIDWORKS PCB 
2017 system requirements. 

 Make sure you are using the recommended graphics card driver. 

 Ensure you are using the latest version of your operating system. Check for and install any Windows 
updates before installing SOLIDWORKS PCB 2017. 

 You can also review the Hawk Ridge Systems SOLIDWORKS PCB 2017 System Requirements 
Guide, which gives an in-depth look at optimizing a computer for use with SOLIDWORKS PCB 
2017. 

 The SOLIDWORKS PCB 2017 application is supported on these operating systems: Windows 7 

SP1 (Professional, Ultimate and Enterprise), Windows 8.1, Windows 10. 

http://www.hawkridgesys.com/
https://support.hawkridgesys.com/hc/en-us/articles/227163268-SOLIDWORKS-PCB-2017-System-Requirements%20%20%20;
http://www.solidworks.com/sw/support/videocardtesting.html
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 It is not supported on: Windows XP, Windows Vista, Windows 7, Starter and Home editions of 
Windows 7 SP1, Windows 8. 

 The SOLIDWORKS PCB 2017 server components are supported on the same operating systems 

as the application, plus: Windows Server 2008 R2 SP1, Windows Server 2012. 

 Note that SOLIDWORKS PCB 2017 is only supported on 64-bit operating systems. 

2. Check that you have sufficient free space on the destination drive before installing. Ensure the free 
space is greater than the estimated installation size (approximately 12 GB for the full SOLIDWORKS 
2017 installation with all components). Also make sure this drive has at least 15% free space. A full 
disk can cause out-of-memory crashes and cannot be defragmented to optimize performance. 

3. Back-up your data.  

4. Obtain your SOLIDWORKS 2017 installation media. 

 The latest version of the SOLIDWORKS Installation Manager can be downloaded from the 
SOLIDWORKS Customer Portal. If you do not have a Customer Portal account, please refer to our 

guide titled 2017 Product Registration to create and register one. 

 The SOLIDWORKS Installation Manager can be used to the download the necessary files and 
complete the installation in one process. 

 The SOLIDWORKS Installation Manager can also be used to download the full SOLIDWORKS 
2017 installation files before completing the installation. This file set is approximately 12 GB and 
is equivalent to the DVD. It is useful if several computers need to be upgraded, as the files can be 
copied to those computers via the network or a USB flash drive. 

 You can also use a SOLIDWORKS 2017 DVD, if available. We strongly recommend installing any 
service pack updates if prompted during the installation.  

5. Ensure you are logged into Windows with an Administrator account. Disable any security software 

(anti- virus, anti-spyware, Windows User Account Control) for the duration of the installation. 
6. Close down all SOLIDWORKS programs and leave them closed for the duration of the installation. 

 

 

 

 

 

 

 

 

 

 

 

 

 

http://www.hawkridgesys.com/
http://customerportal.solidworks.com/
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Installing SOLIDWORKS PCB Services 

This section installs the SOLIDWORKS PCB Services program. 

 

1. Select Server Products on the Welcome screen and navigate to SOLIDWORKS PCB Services. 

2. Check the box next to SOLIDWORKS PCB Services, and click Next. 

 

 
 

3. Specify the installation location, database folder, revisions file folder, and port number by selecting 

CHANGE, next to PCB Options on the Summary Page, for custom settings. Click Back to Summary 

when finished. We recommend keeping the default values for all options here. 

4. CHANGE or accept the default(s), shown in the screenshots below, then click Download and Install. 

 

http://www.hawkridgesys.com/
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5. Open a browser and go to the URL http://machinename:9780, where machinename is the name of 

the computer running SOLIDWORKS PCB Services and 9780 is the port used at step 3 above (e.g. 

http://server01:9780). Note that machinename can be specified as localhost if you are connecting to 

SOLIDWORKS PCB Services from the same computer on which it is installed. We suggest 

bookmarking this page for easy access to the SOLIDWORKS PCB Services interface. 

6. Log in with the user name admin and password admin. 

 

7. Click on USERS > Add User, then use the form to enter information for a new user. Repeat this for all 

the users that will be connecting to SOLIDWORKS PCB Services. Note that users can be added to 

roles and new roles can be created. Roles can then be used to control user permissions to 

SOLIDWORKS PCB data. 

http://www.hawkridgesys.com/
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8. After adding all users, click on the VCS tab to show the DefaultRepository. Click on the Share button 

to bring up the Manage Permissions dialog. Add users or roles to the repository to give the users 

added at step 7 access to this repository. Note that you can create multiple repositories with different 

users having different permissions to each. 

 

9. Click Sign Out when finished. 

10. Note that all user computers will need to be able to communicate with SOLIDWORKS PCB Services 

over the network on the port specified at step 3. Add exceptions to all firewalls or security programs 

that might affect this communication. 

Standalone Installation 

REMINDER: If upgrading from a previous version of SOLIDWORKS PCB, we strongly 

recommend backing up data before proceeding. 

1. Make sure you are logged in as the administrator. 
 

 

2. Disable all anti-virus and anti-spyware tools and turn off Windows User Account Control. 
 

 

http://www.hawkridgesys.com/
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3. Locate your SOLIDWORKS 2017 installation media (DVD or download) and launch the setup 
application (setup.exe). You should see the Welcome screen for the SOLIDWORKS Installation 
Manager. Select Individual (on this computer) and click Next. 

 

 
 

4. You will then see the Serial Number screen where you can enter your serial number for your 
SOLIDWORKS PCB installation. Note that you do not need to enter multiple serial numbers if your 
SOLIDWORKS serial number is the same as your SOLIDWORKS PCB serial number. Click Next. 

 

 
 

5. The SOLIDWORKS Installation Manager will verify your serial number and perform an automatic 

system check for any existing versions of SOLIDWORKS or SOLIDWORKS PCB. Take note of any 
messages or warnings during this step. 

http://www.hawkridgesys.com/
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6. At the Summary screen, you can change the settings and options defined for the installation. To do 
so, click CHANGE on the right side of each option. 

 

 
 

7. Click CHANGE next to Products to go to the Product Selection screen. Scroll down and ensure 
that SOLIDWORKS PCB is checked ON. Nested here are the individual SOLIDWORKS products. 
Click Back to Summary when finished. 

 

http://www.hawkridgesys.com/
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8. In the Download Options, we recommend disabling the Background Downloader, as it is known 
to cause issues with upgrades. Click CHANGE next to Download Options, then deselect Use the 
background downloader. Click Back to Summary when finished. 

9. Confirm that all the information on the Summary screen is correct. Accept the license agreement 
then click Download and Install to begin the installation. 

 

10. When the installation is complete, you will be asked to join the SOLIDWORKS Customer Experience 
Improvement Program. We recommend joining this, as it provides software performance information 
to SOLIDWORKS and enables the use of the CAD Admin Dashboard through the Customer Portal. 
The information this sends to SOLIDWORKS is treated confidentially and does not result in the 
transfer of any file information. After making the selection, click the Finish button to complete the 
installation. 

 

 

http://www.hawkridgesys.com/
http://www.solidworks.com/sw/support/customer-experience-improvement-program.htm
http://www.solidworks.com/sw/support/customer-experience-improvement-program.htm
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11. When the software is launched for the first time after installation, you may need to activate the license 
(if using standalone licensing). Follow the prompts to complete this. You will also be prompted to 
accept the license agreement. 

12. When running SOLIDWORKS PCB for the first time, you may be prompted to allow SOLIDWORKS 
PCB through the firewall. Allow it, if so. 

 

13. Follow the activation prompts to activate your SOLIDWORKS PCB license. Please refer to our article 
2017 Product Activation for more information on license activation and deactivation. 

 
14. At the SOLIDWORKS PCB Start screen, click File > Sign in SOLIDWORKS PCB Services, or 

click Start a New PCB Project. 

 

 
 

15. In the sign in dialog, for Server Address, enter the name of the computer running SOLIDWORKS 

PCB Services and the port number in the format machinename:9780. Note that machinename can 

be specified as localhost if SOLIDWORKS PCB Services is installed on the same computer as 

SOLIDWORKS PCB (i.e. when using a local configuration). Also enter your Username and 

Password, as specified at step 6 of the SOLIDWORKS PCB Services installation (section 3). Click 

Login to start using SOLIDWORKS PCB. 

http://www.hawkridgesys.com/
https://support.hawkridgesys.com/hc/en-us/articles/210493067-2016-Product-Activation


   

www.hawkridgesys.com USA: 1.877.266.4469  CANADA: 1.866.587.6803 

 

 

  

Installing SOLIDWORKS PCB Add-In 

SOLIDWORKS 2016 & 2017 

The SOLIDWORKS PCB Add-In is installed by default with SOLIDWORKS 3D 2016 SP3 and above. 

If you are running an earlier service pack of SOLIDWORKS 3D 2016, upgrade to SP3 or above. 
 

1.   To access the SOLIDWORKS PCB Add-In, run SOLIDWORKS 3D then go to Tools > Add-Ins > 

SOLIDWORKS PCB 2016/2017 and click the check box to enable it.  This will add the 

SOLIDWORKS PCB tab to the task pane on the right of the SOLIDWORKS 3D window. 

 

 

 

http://www.hawkridgesys.com/
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2. Select the SOLIDWORKS PCB tab from the Task Pane in SOLIDWORKS 3D.  Select either New 

Board Assembly or Pull Board From Vault to bring up the SOLIDWORKS PCB Services sign in 

dialog.  For Server Address, enter the name of the computer running SOLIDWORKS PCB Services 

and the port number in the format machinename:9780. Note that machinename can be specified as 

localhost if SOLIDWORKS PCB Services is installed on the same computer as SOLIDWORKS 3D 

(i.e. when using a local configuration). Also enter your Username and Password, as specified during 

the SOLIDWORKS PCB Services installation. Click OK to start using the SOLIDWORKS PCB Add-

In. 

 

 

SOLIDWORKS 2015 

If you are running SOLIDWORKS 3D 2015, follow the directions below. 

1. Go to the SOLIDWORKS Customer Portal, click the Downloads and Updates link to access the 

Downloads page, then select the 2015 version and download the SOLIDWORKS PCB Add-In 

installation files. 

2. Run the setup wizard then click Next at the Welcome screen. 

3. At the Select Destination Location screen, specify the destination folder for the SOLIDWORKS 

PCB Add-In then click Next. 

4. At the Ready to Install screen, click Install. 
5. Click Finish once the installation completes. 

6. When the setup dialog box appears, enter the name of the computer running SOLIDWORKS PCB 
Services and the port number in the format machinename:9780, then click OK. Note that 
machinename can be specified as localhost if SOLIDWORKS PCB Services installed on the same 
computer as the SOLIDWORKS PCB Add-In (i.e. when using a local configuration). 

 

 
 
 
 

 

http://www.hawkridgesys.com/
http://customerportal.solidworks.com/
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Installing SOLIDWORKS PCB Connector 

Skip this section if you purchased SOLIDWORKS PCB instead of SOLIDWORKS PCB Connector. 

1. Sign into your Altium Account if you are not signed in automatically. 

2. Launch Altium Designer, open the DXP tab, then click Extensions and Updates. 

3. On the Extensions and Updates page, scroll down to SOLIDWORKS PCB Connector, then click 

the download icon in the top-right corner to begin the installation. 

 

4. In the Confirm dialog box, click Yes to proceed with the installation. 

5. On the SOLIDWORKS PCB Connector Registration page, enter your SOLIDWORKS PCB 

Connector serial number and click Register. 

6. On the Confirm dialog, either click Yes to restart the system and complete the installation, or click No 

to complete the restart later. 

 

Appendix: License Transfer 

You are allowed two activations per standalone license, one for your business computer and one for your 

home computer. As part of the license agreement, you may not use both simultaneously. 

Each activation transaction is coded to the hardware of your computer. If you are moving your 

SOLIDWORKS PCB installation to a new computer, you will need to transfer your license activation before 

activating on the new computer. You should also do this before reformatting or replacing your hard drive 

or operating system. If your SOLIDWORKS PCB license is tied to your main SOLIDWORKS license (i.e. 

they are the same number), please see our guide titled 2017 Product Activation for the transfer process. 

This process is not required for a new installation. If your computer does not have internet access, refer to 

the E-mail Transfer section of this document. 

 

Online Transfer 

1. Go to Start > All Programs > SOLIDWORKS 2017 > SOLIDWORKS PCB. 

 
2. Once SOLIDWORKS PCB launches, click on the File tab and choose Help>Deactivate Licenses… 

http://www.hawkridgesys.com/


   

www.hawkridgesys.com USA: 1.877.266.4469  CANADA: 1.866.587.6803 

 

3. Choose to transfer Automatically over the Internet and click Next. 

 

 
 

4. The software will connect to the SOLIDWORKS activation servers and you will be informed when 
the license has been successfully transferred. 

 

 
 

5. Press the Finish button to complete the process. 
 

Note: SOLIDWORKS PCB will no longer run on this machine unless it is re-activated. 

 

 

 

http://www.hawkridgesys.com/
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E-mail Transfer 

1. Go to Start > All Programs > SOLIDWORKS 2017 > SOLIDWORKS PCB. 
 

2. Once SOLIDWORKS PCB launches, click on the File tab and choose Help>Deactivate Licenses… 
 

 

3. Choose to activate Manually via e-mail and click Next. 
 

 
 

4. On the next page, press the Save button to create an activation request file. 
 

 
 

Note: Once you have saved this file, your activation is disabled. Do not exit the activation 

window until you have read in the response file from SOLIDWORKS and completed the process 

or you will not be able to run SOLIDWORKS PCB to complete the transfer. 

http://www.hawkridgesys.com/


   

www.hawkridgesys.com USA: 1.877.266.4469  CANADA: 1.866.587.6803 

5. Browse to a location on your computer to store this .txt file and press the Save button. Copy this .txt 
file onto a removable storage device and move it to a machine with internet access. 

 

 
 

6. E-mail this file as an attachment to activation@solidworks.com. 
 

 
 

7. SOLIDWORKS will send a return e-mail with a different .txt file attached. Save this file to a removable 

storage device and move it to the machine awaiting the activation transfer. 
 

 

8. In the activation wizard, press the Open button on the e-mail activation page. 
 

 

9. Browse to the response file and press the Open button. 
 

 
 

10. The next page will show you that your transfer is complete. 
 

 
 

11. Press the Finish button to complete the process. 
 
Note: SOLIDWORKS PCB will no longer run on this machine unless it is re-activated. 

 

http://www.hawkridgesys.com/
mailto:activation@solidworks.com

