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SolidNetWork License Manager Options File 

This guide is written for SOLIDWORKS 2015.  If you are using an earlier version of SOLIDWORKS, please 

download our earlier installation documents to correctly load and administer your version of 

SOLIDWORKS. 

The SNL Manager is an easy to install and use interface that gives administrators the ability to make 

changes which affect their users’ access to SOLIDWORKS licenses. The SNL Manager is licensed by 

FlexLM, which is a standard network licensing manager that allows license administrators to be as secure 

(or as open) with licenses as needed. 

By default, the SolidNetWork License Manager does not use an options file, and gives equal preference to 

all users checking out a license. By creating and applying an options file, an administrator can: 

• Allow the use of features  

• Deny the use of features 

• Reserve licenses 

• Restrict the number of licenses available 

• Control the amount of information logged about license usage 

• Enable a report log file 

• Control the rereading of licenses 

This is not a troubleshooting guide.  If you have any technical issues with SolidWorks, please contact 

Hawk Ridge Systems technical support. 

This document is only to be distributed and used by Hawk Ridge Systems customers.  Any other use is 

prohibited. 

©2015 Hawk Ridge Systems 
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How to Create an Options File 

An options file is typically created using Notepad, but any text editor can be used. Simply typing the 

appropriate commands using the correct syntax (one per line- typically with a line in between) will apply 

the correct settings to the license manager. 

In order to allow the license manager to read the options file, it needs to be saved with the name 

“sw_d,“ and filetype “.opt”. After finishing the options file, selecting “Save As,” and typing “sw_d.opt” 

into the Filename box will allow its preferences to be read. 

The default location of the options file is “C:\Program Files (x86)\SOLIDWORKS SolidNetWork License 

Manager\license\sw_d.opt.” 

How to load the Options File 

Click Start > All Programs > SOLIDWORKS [Year Version] > SolidNetWork License Manager > 

SolidNetWork License Manager directly on the server hosting the SolidNetWork License Manager, or 

connected to the server via a remote session. 

 

1. When the SolidNetWork License Manager opens, click the Modify button. 
 

 

2. Click the radio button to “Activate/Reactivate” and click Next. 
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3. Click the check box to turn on the Options File. The default path: “C:\Program Files 

(x86)\SOLIDWORKS SolidNetWork License Manager\license\sw_d.opt” appears. This is the 

location where the file lives. 

4. If you already saved the file to this path, click the Next button. Otherwise, use File > Save As… 

to save the Options file as “sw _d.opt” in this location, or copy and paste the file to this location 

using Windows Explorer. Click Next to finish the Modify operation. 

5. Make sure that the file is identified as sw_d.opt and not sw_d.opt.txt in the path. If the file is 

identified as sw_d.opt.txt you will need to remove the “.txt”. 

6. In Windows Explorer, browse to C:\Program Files (x86)\SOLIDWORKS SolidNetWork License 

Manager\licenses folder location, slowly double click on the “sw_d.opt.txt” file name and remove 

the “.txt”. 

7. It may be necessary in Windows Explorer to uncheck “Hide extensions for known file types” in 

Tools > Folder Options > View tab > Advanced Settings. 

Save the log file for future use or exit out of the log file. Click the OK button to exit out of the 

SolidNetWork License Manager. You have successfully loaded the SNL Options file. 

 

How to replace the Options File 

1. Click Start > All Programs > SOLIDWORKS [Year Version] > SolidNetWork License Manager > 

SolidNetWork License Manager directly on the server hosting the SolidNetWork License Manager 

or connected to the server via a remote session. 

2. Use the Windows Explorer to browse to the SNL Options file location: 

“C:\Program Files (x86)\SOLIDWORKS SolidNetWork License Manager\licenses” folder and 

rename sw_d.opt to sw_d.opt-old.txt and paste the new sw_d.opt file into the location. 

3. Click the Start button and click OK to the warning message “The license server has been 

started.” 

4. Click the View Log button and find the lines where the log specifies “using options file:” and lists 

the path and the “License server system started on <server_name>” for verification that the 

sw_d.opt is in use. 
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5. Save the log file for future use, or exit out of the log file. 

6. Click the OK button to exit out of the SolidNetWork License Manager. You have successfully 

replaced the SNL Options file. 

 

Options File Syntax 

The options file requires a certain syntax be used when applying settings. Below is a list of the accepted 

commands that will be accepted by the SolidNetWork License Manager: 

Command Effect 

AUTOMATIC_REREAD Turn off automatic reread of licenses at midnight 

BORROW_LOWWATER Set the number of BORROW licenses that cannot be borrowed 

DAEMON_SELECT_TIMEOUT Defines the vendor daemon’s timeout limit. 

DEBUGLOG 
Writes debug log information for this vendor daemon to the specified 

file (version 8.0 or later vendor daemon) 

EXCLUDE Deny a user access to a feature. 

EXCLUDE_BORROW Deny a user the ability to borrow BORROW licenses. 

EXCLUDE_ENTITLEMENT 
Deny a user the ability to activate licenses held in a fulfillment record in 

trusted storage. 

EXCLUDEALL Deny a user access to all features served by this vendor daemon. 

FQDN_MATCHING Sets the level of host name matching. 
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GROUP Define a group of users for use with any options. 

GROUPCASEINSENSITIVE 
Sets case sensitivity for user and host lists specified in GROUP and 

HOST_GROUP keywords. 

HOST_GROUP Define a group of hosts for use with any options (version 4.0 or later). 

INCLUDE Allow a user to use a feature. 

INCLUDE_BORROW Allow a user to borrow licenses. 

INCLUDE_ENTITLEMENT 
Allow a user to activate licenses held in a fulfillment record in trusted 

storage. 

INCLUDEALL Allow a user to use all features served by this vendor daemon. 

LINGER Allow a user to extend the linger time for a feature beyond its check in. 

MAX 
Limit usage for a particular feature/group—prioritizes usage among 

users. 

MAX_BORROW_HOURS Changes the maximum borrow period for the specified feature. 

MAX_OVERDRAFT Limit overdraft usage to less than the amount specified in the license. 

NOLOG Turn off logging of certain items in the debug log file. 

REPORTLOG 
Specify that a report log file suitable for use by the FlexNet Manager 
license usage reporting tool be written. 

RESERVE Reserve licenses for a user or group of users/hosts. 

TIMEOUT 
Specify idle timeout for a feature, returning it to the free pool for use by 

another user. 

TIMEOUTALL Set timeout on all features. 

 

Options File formatting 

The SNL Options file allows control over “General Options,” “Targeted Options” or a combination of both. 

See “Options File Syntax” starting on page 139 of the FlexLM pdf (%SolidNetWork License Manager 

Installation Directory%\Docs\flexuser\licensingenduserguide.pdf). 

In general, we want to establish and control general operating parameters first, and then control feature 

specific parameters. 

 

Setting Parameters for Certain Users 

The options file allows the license administrator to control various operating parameters of FlexLM. Users 

can be identified by their user name, host name, display, IP address, or PROJECT (which is set with the 

LM_PROJECT environment variable).  

The User_Name should be the client’s standard Windows Login ID. 
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Groups 

Groups are created in the options file to allow for the callout of multiple users at once, instead of 

individual users. There is no known limit to the number of groups that can be created. 

Syntax – GROUP group name user1 user2 user3 

By default, usernames and group names are case sensitive. This can be changed by adding a line at the 

beginning of the options file changing the GROUPCASEINSENSITIVE variable to ON. See the advanced 

example below.  

 

Options File Product Reference List 

Below is a list of all SOLIDWORKS products that can be referenced with an options file, as well as the 

proper syntax for this reference. 

Command Product 

animator SOLIDWORKS Animator 

cae_cosmosfloworkspe SOLIDWORKS Flow Simulation 

cae_cosmosfloworksstd SOLIDWORKS Flow Simulation Standard 

cae_cosmosmotion SOLIDWORKS Motion 

cae_cwadvpro SOLIDWORKS Simulation Premium 

cae_cwdesigner SOLIDWORKS Simulation 

cae_cwpro SOLIDWORKS Simulation Professional 

catiatoswtrans CATIA V5-SOLIDWORKS Translator 

circuitworks CircuitWorks 

Designchecker SOLIDWORKS Design Checker 

edrw eDrawings Professional 

elec2d SOLIDWORKS Electrical 2D 

elec3d SOLIDWORKS Electrical 3D 
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elecpro SOLIDWORKS Electrical Professional 

featureworks FeatureWorks 

pdmworks SOLIDWORKS Workgroup PDM 

pdmworks_as SOLIDWORKS Workgroup PDM for SOLIDWORKS Explorer 

pdmworks_sa SOLIDWORKS Workgroup PDM Contributor 

photoview PhotoView 360 

piping SOLIDWORKS Routing 

plastics_pro SOLIDWORKS Plastics Standard 

plastics_premium SOLIDWORKS Plastics Professional 

plastics_advanced SOLIDWORKS Plastics Premium 

scanto3d ScanTo3D 

SOLIDWORKS SOLIDWORKS Standard 

swepdm_cadeditorandweb SOLIDWORKS Enterprise PDM CAD Editor 

swepdm_contributorandweb SOLIDWORKS Enterprise PDM Contributor 

swepdm_viewer SOLIDWORKS Enterprise PDM Viewer 

swepdm_processor SOLIDWORKS Enterprise PDM Processor License 

swoffice SOLIDWORKS Office 

swofficepremium SOLIDWORKS Premium 

swofficepremium_cwpro SOLIDWORKS Premium with Simulation Professional 

swofficepremium_cwadvpro SOLIDWORKS Premium with Simulation Premium 

swofficepro SOLIDWORKS Professional 

swsustainability  SOLIDWORKS Sustainability 

taskscheduler SOLIDWORKS Task Scheduler 

toolbox SOLIDWORKS Utilities 
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Let’s look at an example 

The example below is what would be typed into the text editor. 

 

#START  

TIMEOUTALL 600 

MAX_BORROW_HOURS 336  

BORROW_LOWWATER 3 GROUP 

#END 

 

Let’s examine what this file is telling us… 

# indicates a comment. No action will be performed by the system. 

TIMEOUTALL 600  

TIMEOUTALL set timeout on all features.  

600 refers to the amount of time in seconds that the SOLIDWORKS license can be idle before being 

returned to the license pool. The default value is 900. Any value in seconds less than or equal to 900 will 

default to 900 (15 minutes).  

 

MAX_BORROW_HOURS 336  

MAX_BORROW_HOURS Maximum amount of time in hours a SOLIDWORKS license can be borrowed.  

336 Total hours SOLIDWORKS licenses can be borrowed. A borrowed license is a license or series of 

SOLIDWORKS licenses that are removed from the pool of licenses. The maximum borrow limit is 720 (30 

days). Any value greater than 720 will default to 720.  

 

BORROW_LOWWATER 3  

BORROW_LOWWATER sets the number of licenses for a BORROW feature that cannot be borrowed. 

3 specifies the number of SOLIDWORKS licenses that cannot be borrowed from the total pool.  
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Advanced Example 

The example below is what would be typed into the text editor: 

 

#start general parameters  

TIMEOUTALL 600  

MAX_BORROW_HOURS 336  

BORROW_LOWWATER 3  

GROUPCASEINSENSITIVE ON  

#end general parameters 

#start feature specific parameters  

GROUP TECH kevinm johnb larsp  

RESERVE 1 SOLIDWORKS USER jaredc  

RESERVE 3 swofficepremium USER jaredc  

RESERVE 1 cae_cwadvpro USER jaredc 

RESERVE 1 cae_cosmosfloworkspe USER jaredc  

EXCLUDE swofficepremium USER glennw  

EXCLUDE cae_cwadvpro USER glennw  

EXCLUDE cae_cosmosfloworkspe USER glennw  

INCLUDE_BORROW SOLIDWORKS USER jaredc 

INCLUDE_BORROW swofficepremium USER jaredc 

INCLUDE_BORROW cae_cwadvpro USER jaredc  

INCLUDE_BORROW cae_cosmosfloworkspe USER jaredc  

INCLUDE_BORROW SOLIDWORKS GROUP TECH  

INCLUDE_BORROW swofficepremium GROUP TECH  

#end feature specific parameters 
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NOTE: GROUPCASEINSENSITIVE ON must be specified to allow for host and usernames to be typed 

into the text editor without sensitivity to case.  

GROUP TECH kevinm johnb larsp  

GROUP is the Syntax identifier specifying a group name to be identified  

TECH is the Group name  

kevinm johnb larsp are user names (Windows Login IDs) that are part of the TECH group 1. No limit to 

# of groups that can be created 

 

RESERVE 1 SOLIDWORKS USER jaredc  

RESERVE only “Reserves” the SOLIDWORKS license for jaredc.  

1 Specifies the number of licenses that are reserved. 

Any licenses reserved for a user are dedicated to that user. Even when that user is not 

actively using the license, it is unavailable to other users.  

SOLIDWORKS is the feature for which we want to specify  

USER identifies the user jaredc to use the “SOLIDWORKS” feature  

jaredc is the username  

 

EXCLUDE  swofficepremium USER glennw  

EXCLUDE prevents glennw from obtaining a SOLIDWORKS Premium license  

swofficepremium is the feature for which we want to specify  

USER identifies the user glennw is not to use the “swofficepremium” feature  

glennw is the username  

 

INCLUDE_BORROW swofficepremium GROUP TECH  

INCLUDE_BORROW allows the TECH group to borrow SOLIDWORKS Premium  

swofficepremium is the feature for which we want to specify  

GROUP identifies the Group TECH to use the ”swofficepremium” feature  

TECH is the Group name  
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Looking at all of the EXCLUDE and INCLUDE_BORROW options listed in the above example and based on 

the options identified, user “glennw’ has no borrow rights and the “TECH” group may only borrow 

SOLIDWORKS and SOLIDWORKS Premium licenses 

 

Frequently Asked Questions 

Can I use the SNL Options file I have from a previous year? 

 
Yes. In general, the procedure for creating and applying the options file has remained consistent between 

releases, with no features being removed. 

 

Where can I find the FLEXLM User’s Guide for additional information?  

The FLEXLM Users guide can be found in:  

C:\Program Files\SOLIDWORKS Corp\SOLIDWORKS\setup\flexlm\flexuser, Chapter 13 Managing the 

Options File starts on page 107.  

 

Can you use HOSTS in the options file?  

Yes, machine host names can be used. Syntax: HOST  

 

What happens if I have conflicting statements? 

Rules of precedence take effect when INCLUDE and EXCLUDE statements are combined in the same 

options file and control access to the same feature (in license files) or fulfillment record (in trusted 

storage). The following define the precedence when both types of statements appear together: 

• If there is only an EXCLUDE list, everyone who is not on the list is allowed to use the feature.  

• If there is only an INCLUDE list, only those users on the list are allowed to use the feature.  

• If neither list exists, everyone is allowed to use the feature.  

• The EXCLUDE list is checked before the INCLUDE list; someone who is on both lists is not allowed to 

use the feature. 

Once you create an INCLUDE or EXCLUDE list, everyone else is implicitly outside the group. This feature 

allows you, as a license administrator, the ability to control licenses without having to explicitly list each 

user that you wish to allow or deny access to. In other words, there are two approaches; you either: 

• Give most users access and list only the exceptions 
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or 

• Severely limit access and list only the those users that have access privileges 

 

Can you use Internet options in the options file?  

Yes, you can use machine IP addresses and wildcards. 

The wildcard character is an asterisk (*). 

 

Why won’t the license manager read my options file?  

Check to make sure that when the text file was renamed to sw_d.opt that “Hide extension for known file 

types” was turned off.  

This will result in a file named sw_d.opt.txt, and will not be read properly by the license manager. 

Remove “.txt” to fix the file name.  

 

Why are the reserve functions not showing up in the license manager tab?  

Reserved licenses will be reserved for the user or users they are specified for, but will not show as used 

licenses in the license manager tab unless the user is logged on and using the license. The log file will 

also not show the reserve function of the options file. 

 

Why can’t I close the license manager after viewing the log file?  

Before the license manager can be closed the log file must first be closed.  

 

How do these Include and Exclude functions work?   

Exclude always supersedes Include  

• If there is only an Exclude list, anyone not on the list is considered included.  

• If there is only an Include list, only the users on the list are allowed to use the feature.  

• If neither option is used then everyone is allowed to use the feature  

• If there are both Include and Exclude Lists, users who have been excluded from a particular 

feature will not be able to use the feature, regardless of any Include commands. 

 

Is there a character limit? 

Lines in the options file are limited to 4000 characters. The \ character is the line-continuation character. 
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